PDA

View Full Version : Maestro Tools for XP



Todd Sorensen
03-23-2002, 09:14 AM
I have run into a problem using the new beta version of maestro tools for XP. Giga is running fine on XP. I have been working on a peice that uses a variety of patches from my GOS library. The problem is that some of the Leg Exp patches will just stop sustaining for no apparent reason. Almost like they have received a note off command or the sustaing pedal has been raised. I have checked and made sure that MT is set up correctly and that the channels that are misbehaving aren\'t bypassed, Etc. I have even taken these same sounds and settings for MT and placed them on a different machine that is running 98SE and tried to recreate the problem but as of yet I can only get this problem to occur using MT for XP beta version on my XP machine. Any ideas?

Jeannot Welter
03-23-2002, 09:45 AM
Which MIDI ports are you using?

Jeff Hurchalla
03-23-2002, 10:05 AM
Hi Todd-
A couple possibilities. First, if you\'re using the LEG-EXP patch in polyphonic mode (as opposed to Maestro\'s mono mode) you won\'t be able to sustain the notes with the sustain pedal, meaning if you don\'t hold a note manually it won\'t keep playing. But I have the feeling that may not be what\'s happening. More likely you\'re running out of polyphony. The LEG-EXP patches are extremely voice hungry and will probably exhaust your computer resources faster than any other patch you could load. Tom could give you exact numbers.. however my educated guess is this: for a single note, the EXP layers consume 8-10 voices and the LEG portion(lasting about the first half second of the note) consumes an additional 8-10 voices. In addition (as if we needed more voice eating!) when a single line finishes one note and begins a new note, there\'s also a brief period where the note-off decay of the last note plays at the same time as the attack of the new note. Anyway, the point is that I wouldn\'t be surprised if a single EXP-LEG line uses more than 30 voices at certain times (when using Maestro), though I would put average use closer to 15. Since Gigastudio starts to do note-stealing when it runs out of polyphony, this might account for the unexpected note-offs. Maestro performs the LEG portion of the EXP-LEG patches, so in essence this consumes twice as much polyphony as using the EXP-LEG patch without Maestro.

In any event, my first guess is you\'re running out of polyphony due to the high resource usage of this patch. It could be something else and I don\'t want to overlook other possibilities like a bug. If you find that the problem occurs when you play many instruments, or when you play many notes at the same time with EXP-LEG, but that it doesn\'t occur with single EXP-LEG notes by themselves, I suspect it\'s just that you\'ve run out of resources. These EXP-LEG patches are quite flexible, but they\'re limited in a sense by using so many voices.
Hope this helps-

Jeff

[This message has been edited by Jeff Hurchalla (edited 03-23-2002).]