• Register
  • Help
Results 1 to 7 of 7

Topic: midi usb latency

  1. #1

    midi usb latency

    OK, I have had it. I thought my keyboard skills sucked, but not as bad as it seems they have gotten.
    I have a USB (uno) interface hooked to my giga box which also runs sonar. This is a p4 1.5 with 1.5 gig of memory, intel board.
    When I got my Roland MIDI guitar the latency was wierd but I figured it was just the way it was and assumed I wasted another $800 on buying the Roland MIDI converter. But, now I am using my keyboard and playing a percussion part (which I have done thousands of times with non-usb midi interfaces with no latency) and realize something is up.
    I found some very conflicting info doing a google search and was wondering if anyone else has noticed this problem. I don\'t mind buying a new interface if the problem is USB, I certainly could get a PCI or Firewire, but I am sick of spending money and finding out I have less of a system than when I recorded with Cakewalk 2 for DOS into my Fostex 16 track [img]images/icons/mad.gif[/img]
    Any info would be appreciated.

  2. #2

    Re: midi usb latency

    I\'ve hadn\'t had any latency problems, but my computer does BSOD on a regular basis, pointing to my UNO USB inteface as the culprit. I\'m finally giving up on USB midi and going back to my game port. Never had a crash with it.

  3. #3

    Re: midi usb latency

    I use a MIDISport USB 2x2 with a Mac and have no perceptible latency. I think latency is usually a problem with audio interfaces, not MIDI. There\'s so little data being transferred though a MIDI interface that it shouldn\'t cause any latency on its own. What kind of sound card are you using and what buffer sizes do you have assigned for it?


  4. #4

    Re: midi usb latency

    The USB interface I think adds a bit of latency, but not enough to be the sole problem. Check your buffer settings. I can easily detect anything over 128k. I know immediately if I set my buffers any higher. So try that [img]images/icons/smile.gif[/img]

  5. #5

    Re: midi usb latency

    I found that on older motherboards (mainly P3) acpi was not implemented so well when used with XP (win2k seemed to work just fine) and killed usb midi interfaces. My solution for this was to turn acpi off by removing the acpi pc in device manager and reinstalling it as a standard pc. With P4 class systems I have not encountered this problem as much. My guess is that the acpi implementation has gotten better on newer mobos (but this is still only a guess). Here\'s a link that explains the procedure above: web page

    This may not be everyone\'s experience, but it was mine. Hope it helps in some way.

  6. #6

    Re: midi usb latency

    Are you sure that you\'ve got the right settings selected in the software? Have you tried calling the interface vendor support line? You may have omitted to select the appropriate driver/not changed the latency from it\'s default values.
    Hope you get it sorted soon, fwiw, I think you\'ll be able to fix this with a software tweak.

  7. #7

    Re: midi usb latency

    I guess I am confused on which settings to change.
    I am using a MOTU 2408 mk3 and see no way to changes any settings and Sonar 3.
    The Uno has no settings either.
    It could be a Hardware issue I guess but I would think a P4 1.5 with 1.5gig would be sufficient.
    Thanks for the help.

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts