• Register
  • Help
Results 1 to 6 of 6

Topic: Error Code 5: Unable to Allocate Memory

  1. #1

    Error Code 5: Unable to Allocate Memory

    I have MS Windows 2000 (French version) but I have a message box when I load several files in Gigastudio 160 2.53 :

    \"Error Code 5: Unable to Allocate Memory\"

    Please, help me ...

    I know you can have the same problem with the English version

  2. #2

    Re: Error Code 5: Unable to Allocate Memory

    I had that problem with Windows 2000, when there wasn\'t enough memory to load a particular sample. If I unloaded a few to free some up, it would work. For this reason, I switched back to Windows 98SE. I can load way more samples now than with 2000 - I\'m sure the OS just hogs more memory than 98 so I went back. I think a well configured 98 machine is leaner and more efficient for Giga.


  3. #3

    Re: Error Code 5: Unable to Allocate Memory

    Hello Mathieu,

    Please take a moment to read this post from the Giga development team regarding memory allocation issues with Win2k/Xp:



  4. #4

    Re: Error Code 5: Unable to Allocate Memory

    Hi Mathieu,

    I have Win98 and went test-upgrading to Windows 2000. I bought Win 2000 only for this test.

    I HAD EXACTLY THE SAME PROBLEM WITH memory allocation. I assume we simply have a nasty BUG here in Giga.
    By the time I wrote to help-desk twice or so and they did not give me any answer. The link from pmuse is only general \"blabla\" and does not hit the point.

    After testing a number of configurations I gave up, went back to Win98 and I am still quite happy with it.

    Any other users having this problem ?


  5. #5

    Re: Error Code 5: Unable to Allocate Memory

    If you can\'t load Gigafiles up to 90-100% under win2k or XP, try this:

    Download and install Cacheman.

    Start it, go to Settings, Tweaks, Disk tab and set IO Page Lock Limit to a higher value. I\'ve tried the maximum value (depends on total RAM) and I can load up to 98% into Giga.

    This settings does affect other things, like loading speed.

    Just check it out. Perhaps it helps for you.

  6. #6

    Re: Error Code 5: Unable to Allocate Memory

    The fix for Error Code 5 (Win XP) is a simple one:

    Set LargeSystemCache to 0 (changed from the default of 1) in the registry.

    No fuss, no muss!

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts