• Register
  • Help
Results 1 to 6 of 6

Topic: Dropout issues in Sonar

  1. #1

    Dropout issues in Sonar

    Using Sonar 3, I\'m getting quite a few dropouts. I forgot what settings I used to use in the old version of Sonar. Can anyone recommend good settings for a 2GHz machine w/ 1GB RAM? There\'s buffer size, msec latency, and a couple other options in the Audio settings... I\'m not quite sure what I should set them to.

    Thanks in advance

  2. #2

    Re: Dropout issues in Sonar

    You can set a buffer size of 128 or 256 if you need it to be low, you probably have to set this value on your soundcard somewhere too, before starting Sonar. You can set the latency as low as you like and just highten if you experience dropouts. If you play dxi in realtime, you would want it to be as low as possible, of course.

    I have identical specs and run at a buffer of 128 and 2,9 ms latency, works fine for most projects that aren\'t too complex..

    Good luck! [img]images/icons/smile.gif[/img]

  3. #3
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: Dropout issues in Sonar

    Try the following procedure from Cakewalk Support:

    Audio has Unexpectedly Dropped Out

    The information in this article applies to:

    SONAR 3 Producer Edition
    SONAR 3 Studio Edition
    SONAR 2
    SONAR 1

    If SONAR suddenly stops producing audio during recording or playback followed by the appearance of a red dropout indicator light, you\'ve very likely experienced a dropout. Sometimes instead of a dropout, you may experience a stutter during playback (a small section of audio repeats itself once or twice before normal playback resumes). Or, you may occasionally experience a glitch or pop during audio playback (a brief interruption or clicking noise is heard, but audio playback then continues normally from that point).
    Eliminating Dropouts

    Complete all the steps listed in the SONAR Help file under the category Dropouts and Other Audio Problems.

    There may be a bad setting in the AUD.INI file. Try one of the following methods:
    Easy Method - Close SONAR and delete the AUD.INI file from the SONAR folder. After restarting SONAR you may need to point the app to your WaveData folder. (Options | Audio | Advanced Tab | Data Directory field)

    Advanced Method - Close SONAR. Open SONAR\'s AUD.INI file in Notepad. Delete everything listed beneath the line PictureDir=C:\\Cakewalk Projects\\Picture Cache. Save the file and restart SONAR.

    Go to Options | Audio | General and move the Latency slider toward the Safe setting.

    Click on the Advanced tab and set the I/O Buffer Size to 256.

    Open a file that has this problem and run the Tools | Compact Audio Data command.

    Make sure nothing else is running while SONAR is open. Choose Start | Run and type MSCONFIG. Click OK, then click on the Startup tab at the upper right of the window that opens. Uncheck all items listed, click OK, then restart your computer. You can always recheck those items again at a later time.

    If, and only if, you have an UltraDMA hard drive, make sure it\'s in DMA mode. Go to Control Panel | System | Device Manager and click the plus next to Disk Drives. Double click on your hard drive, click Settings, and make sure the DMA box is checked. If it is not, check it, restart, and make sure it stays checked.

  4. #4

    Re: Dropout issues in Sonar

    Sam, please explain a bit more. How many tracks of audio are you running and how many tracks of midi (and how much controller data is passing through?) are the dropouts consistent? do they happen in the same spot on every playback/recording?

    It could be a rare problem but I actually had a bad sector on my hd that prevented sonar for recording more data when it came to a specific point in the sequence. The remedy here was to run scandisk, surface scan and have it correct the problem.

    The second undocumented problem could relate to the midi buffer. Try setting it a notch higher than the default (I think the default is 512, so make it 1024 bytes). If too much information is travelling over your network (using MidiOverLan) you could experience a dropout with a low buffer setting.

    Of course make sure your soundcard has been profiled correctly and that you\'re running the best drivers for your soundcard. ASiO is not always the best choice, even if your soundcard supports it. WDM drivers seem to work better for me.


  5. #5

    Re: Dropout issues in Sonar


    I\'m an idiot.. I don\'t even know what WDM or ASIO is. [img]images/icons/smile.gif[/img] I see it when I download the drivers for my Audiophile 2496 card, but it means nothing to me unfortunately.

    The dropout was occurring with a wind sextet, nothing intensive at all. But you know what, I ran disk defrag analysis and man.. there was red all over the graph! Pretty bad fragmentation. So I\'ll run a defrag later, and that will probably help.

    Thanks for the tips, guys.

  6. #6

    Re: Dropout issues in Sonar


    I\'ve found there\'s one tweak that TOTALLY cured my dropout problem in Sonar. The tweak originally comes from Cakewalk\'s FAQ (so it\'s kosher) - I first saw it mentioned on the cakewalk forum at homerecording.com, though I don\'t know why it isn\'t more well-known, given how much difference it made to my system.

    Go into the Cakewalk program folder and find the aud.ini file. Open the file in Notepad.

    Find the line that says \"stopifstarved . . .\"

    If it says \"stopifstarved = 1\", then change the \"1\" to a \"0\". Save the file and close it.

    I don\'t really know what this does - presumeably with it set to \"1\", it tells the soundcard to stop (ie dropout) if there\'s any break in the data flow. When I last suggested this tweak to someone else, somebody jumped in and said it will cause clicks and pops in the recorded audio, even though you don\'t hear them while you\'re recording. Although I can see the logic in that, I have found it in practice to be totally untrue. I went from a system that dropped out all the time (running only a few a tracks, like you) to one that I could play and record loads of tracks on at low latency with no problem, just by doing this tweak. And my recorded audio never has clicks or other artefacts.

    Give it a try.

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts