• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Topic: Cubase SX help please

Share/Bookmark
  1. #1

    Cubase SX help please

    I\'m using SX on an XP machine as an expensive VStack, hosting two Kontakts that are each loaded with 16 instruments. On each track assigned to the first one, the In is WaveCenter PCI port 1 (emulated), the out is Kontakt #1, and the MIDI channel is Any.

    Why am I getting a MIDI loop? And why are all the tracks\' MIDI VU meters dancing instead of just the track going to the channel I\'m playing?

    There\'s no loop if I record onto SX and just play MIDI from the track - it\'s something silly I\'m missing that only affects live MIDI input - but that proves it\'s not an audio loop.

    Thanks.

  2. #2

    Re: Cubase SX help please

    Originally posted by Nick Batzdorf:
    I\'m using SX on an XP machine as an expensive VStack, hosting two Kontakts that are each loaded with 16 instruments. On each track assigned to the first one, the In is WaveCenter PCI port 1 (emulated), the out is Kontakt #1, and the MIDI channel is Any.

    Why am I getting a MIDI loop? And why are all the tracks\' MIDI VI meters dancing instead of just the track going to the channel I\'m playing?

    There\'s no loop if I record onto SX and just play MIDI from the track - it\'s something silly I\'m missing that only affects live MIDI input - but that proves it\'s not an audio loop.

    Thanks.
    <font size=\"2\" face=\"Verdana, Arial\">Are the Kontact instruments set to receive Omni or a specific channel?

  3. #3

    Re: Cubase SX help please

    Each instrument inside Kontakt is set to a specific channel (and output). Those settings above are the ones for each SX track.

  4. #4

    Re: Cubase SX help please

    This is a quirk of using SX in this way. Each channel is sending all midi channels on all the tracks in your setup, so...Here\'s what you have to do for each midi track:

    Enable the input transformer to local.

    Set the mode to Filter.

    Put a check mark in the box Active Module 1.

    At the top of the transformer window, set Filter Targe to be Channel. Condition to be Unequal. Parameter 1 = 1. On the next midi track set everything the same except Parameter 1 should = 2. Basically Parameter 1 is equal to the midi channel you want sent out of that track. All this is doing is allowing ONLY your selected channel to pass through the track to the VSTI.

    I\'ve just saved an input transformer preset for this purpose and just change the value for parameter 1 depending on the midi channel I want sent out of that track.

    Hope this is helpful and clear enough!

    -matt mariano

  5. #5

    Re: Cubase SX help please

    You the man! Thanks so much.

  6. #6

    Re: Cubase SX help please

    Originally posted by Nick Batzdorf:
    You the man! Thanks so much.
    <font size=\"2\" face=\"Verdana, Arial\">No problem! Glad to help.

    -matt mariano

  7. #7
    Senior Member
    Join Date
    May 2000
    Location
    Ojai, California
    Posts
    305

    Re: Cubase SX help please

    Hi,

    Cant you achieve the same result by simply assigning a channel number rather than specifying,
    \"Any\"?

  8. #8

    Re: Cubase SX help please

    Nope, that was the first thing I tried.

  9. #9

    Re: Cubase SX help please

    Originally posted by Nick Batzdorf:
    I\'m using SX on an XP machine as an expensive VStack, hosting two Kontakts that are each loaded with 16 instruments. On each track assigned to the first one, the In is WaveCenter PCI port 1 (emulated), the out is Kontakt #1, and the MIDI channel is Any.

    Why am I getting a MIDI loop? And why are all the tracks\' MIDI VU meters dancing instead of just the track going to the channel I\'m playing?

    There\'s no loop if I record onto SX and just play MIDI from the track - it\'s something silly I\'m missing that only affects live MIDI input - but that proves it\'s not an audio loop.

    Thanks.
    <font size=\"2\" face=\"Verdana, Arial\">Nick,
    try switching off midi thru (File~Preferneces~Midi).

    Brian

  10. #10

    Re: Cubase SX help please

    Thanks, but the filter Matt explained really is the way to solve the problem. I\'ve set it up that way, and everything is working fine - I haven\'t had to touch that machine for a couple of days, since it just sits there and plays samples.

    Anyway, I suspect MIDI thru [sic] wouldn\'t have an effect when you have no outputs connected to your MIDI interfaces.

Go Back to forum

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •