• Register
  • Help
Results 1 to 9 of 9

Topic: OT-Cubase SX 2.0 export to midi question

Share/Bookmark
  1. #1

    OT-Cubase SX 2.0 export to midi question

    My post on the Steinberg forum is getting no repsonse, so maybe someone here can help:

    I\'m having trouble exporting midi files. Can someone just verify if this is supposed to work? Is anyone sucessfully exporting SX projects to midi files?

    I\'m using 2.0.1 (the latest patch), Windows XP. I can\'t get type 1 or type 0 to work. It picks up the first 5 or so tracks, and then ignores the others. It also ignores mute and solo..

    Pardon the intrusion

  2. #2

    Re: OT-Cubase SX 2.0 export to midi question

    Strange, I would assume SX enables you to export midi files with no problem. Do you also have audio tracks in the project?

  3. #3

    Re: OT-Cubase SX 2.0 export to midi question

    Originally posted by sporter:
    Is anyone sucessfully exporting SX projects to midi files?
    <font size=\"2\" face=\"Verdana, Arial\">Works here no problem.
    I\'m a Logic user but I also use SX 2.0 for some of my Cubase clients...

    Go into preferences>Midi>Midi File and make sure to check all the export options except \'export as Type 0\' (my advice to you...).
    Check all the import options as well.

    click \'Apply\' and \'ok\'.
    Try to export your file again now and you should be in business...

    The only problem w/ SX and a PITA is that when you import the midi file back in you may have to reassign manually certain midi instruments (OUT)again. It\'s not always automatic and I\'m not sure why.

    Hope this helps.

    Joshua Hanks. [img]images/icons/cool.gif[/img]

  4. #4

    Re: OT-Cubase SX 2.0 export to midi question

    Sporter,

    On your midi tracks, are you doing any VSTi stuff? If so, could the missing tracks be the frozen VSTis (which would no longer be midi, but now be audio)?

    Mutes/Solos -
    As far as I know, SX ignores these when making a midi file (a shame).

    Missing tracks -
    If your midi file is exported as type 0, all tracks with the same midi channel number will be merged - even if they are assigned to different midi ports. The result upon import is that you appear to have lost tracks - but of course the info is simply bundled into a single track.
    This doesn\'t happen with type 1. With type 1 every track can be assigned to the same midi channel and it will remain discrete when imported later.

    Sorry I can\'t be more help. All I can say is that\'s the way it\'s SUPPOSED to work.

  5. #5

    Re: OT-Cubase SX 2.0 export to midi question

    Got it working now, thanks for the help. Checking all the boxes except the last seemed to do the trick.

  6. #6

    Re: OT-Cubase SX 2.0 export to midi question

    Originally posted by JHanks:
    </font><blockquote><font size=\"1\" face=\"Verdana, Arial\">quote:</font><hr /><font size=\"2\" face=\"Verdana, Arial\">Originally posted by sporter:
    Is anyone sucessfully exporting SX projects to midi files?
    <font size=\"2\" face=\"Verdana, Arial\">Works here no problem.
    I\'m a Logic user but I also use SX 2.0 for some of my Cubase clients...

    Go into preferences>Midi>Midi File and make sure to check all the export options except \'export as Type 0\' (my advice to you...).
    Check all the import options as well.

    click \'Apply\' and \'ok\'.
    Try to export your file again now and you should be in business...

    The only problem w/ SX and a PITA is that when you import the midi file back in you may have to reassign manually certain midi instruments (OUT)again. It\'s not always automatic and I\'m not sure why.

    Hope this helps.

    Joshua Hanks. [img]images/icons/cool.gif[/img]
    </font><hr /></blockquote><font size=\"2\" face=\"Verdana, Arial\">Yea thats right. I works fine..In your Prefs. under midi file, make sure that your exporting type \'o\'. then jsut like u would an audio mixdown,put your locators around the midi file,solo it..and Export>midi file...rich

  7. #7

    Re: OT-Cubase SX 2.0 export to midi question

    it may be collapsing multiple tracks into single tracks, if there isn\'t multiple MIDI channels being used throughout the whole song.

    Type 0 will collapse everything to a single track.

    Type 1 will allow for multiple tracks (but will collapse multiples as I stated above)

  8. #8

    Re: OT-Cubase SX 2.0 export to midi question

    Thanks for all the help! I guess all the SX users hang here instread of the Steinberg forum..

    I\'ll check this out tonite, I can\'t remember what is checked and what is not checked.

    Patrick, you asked about audio tracks in the project. Does it matter? I assumed it would just ignore the audio tracks. (?)

  9. #9

    Re: OT-Cubase SX 2.0 export to midi question

    Originally posted by KingIdiot:

    Type 0 will collapse everything to a single track.

    Type 1 will allow for multiple tracks (but will collapse multiples as I stated above)
    <font size=\"2\" face=\"Verdana, Arial\">That\'s right.
    It\'s much better to export as Type 1 for multiple midi tracks and that\'s the reason why I\'ve advised you to check all the export options EXCEPT \'export as Type 0\' which automatically will allow you to midi export as Type 1.

    If you export as Type 0, as King mentioned, all your midi tracks will collapse to a single track.
    You\'ll then need to use the \'Dissolve Part\' function in SX when importing your tracks back in, in order to see all the tracks...
    [img]images/icons/wink.gif[/img]

Go Back to forum

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •