• Register
  • Help
Results 1 to 4 of 4

Topic: Maestro Tools/Sonar No Midi - Help!

  1. #1

    Maestro Tools/Sonar No Midi - Help!

    I have configured Maple,Sonar,Maestro tools, and Giga as advised. When I open Sonar and Maestro tools midi works as it should but when I open Giga all midi transmission stops and I can not get it back. I have to shutdown, reboot and try again with the same results. I have checked the configuration of each component and can not see anything that should cause this. What am I missing?

    Thank you in advance.


  2. #2
    Join Date
    Oct 2000
    Orcas Island

    Re: Maestro Tools/Sonar No Midi - Help!


    Could be the Windows device bug. Please give a call and we\'ll do what we can to get you up and running.


  3. #3

    Re: Maestro Tools/Sonar No Midi - Help!

    Hi Tradd,
    Without just a few details, it\'s tough for me to pinpoint the troubles, but I should be able to guide you through getting it to work here.

    My first guess is that you are starting Sonar before Gigastudio. There is a potential for problems in that order - always start Gigastudio, then Maple, then Sonar. Things aren\'t actually as complicated as this, but you will be sure to be safe from problems this way. When you are done, close everything in reverse order - Sonar, then Maple, then Gigastudio.
    The other main point I have to suggest is that you may be launching Sonar by using Gigastudio\'s launch sequencer button which would definitely cause the midi chain to be broken - you need to start Sonar from the Windows start menu while using Maple (see the paragraph at bottom of this post).

    But again I only have a few details, so here\'s some further help. These instructions would be overkill ordinarily, but they should help you to get things configured correctly:

    Close all running applications and then start Gigastudio. In Giga\'s \"Settings | Hardware/Routing\" tab, choose \"none\" for all the midi inputs, and then press the \"Apply\" button. Close Gigastudio and restart it. This time in the \"Settings | Hardware/Routing\" tab, choose \"Maple Midi In: Port 1\" for the first midi input port, \"Maple Midi In: Port 2\" for the second midi In port, and if you have Gigastudio 160 configure the third and fourth midi input ports in a similar fashion. Again, you must press \"Apply\". Keep Gigastudio running.

    Start Maple. In the \"Options | Midi Settings\" menu item, choose \"Accept input from sequencer or scoring program\", and press \"OK\" button. Keep Maple running.

    Start Sonar. Select the menu item \"Options | Midi Devices...\". [I\'m cutting and pasting this paragraph from Maple help.] For the Input Ports half of the dialog that comes up, ensure that no Maple Midi In Ports are selected. For the Output Ports half of the dialog, select and highlight every one of the Maple Midi Out Ports, and deselect any Nemesys MidiOut ports. Press OK.
    For each of your future (or existing) projects, you should configure every midi track destined for GigaStudio to send its output to a \"Maple Midi Out: Port x\". You will do this by choosing the correct output in the Port column of each track. While you are using Maple, do not send midi output from any Sonar track to a Nemesys MidiOut port.

    While using Gigastudio and a Sonar/Cakewalk configuration with Maple, do not start Sonar/Cakewalk by using GigaStudio\'s launch sequencer button. Instead, start Sonar or Cakewalk from the Start menu or from a desktop icon.

    Good luck, and I hope this will help you to get things going fine.


  4. #4

    Re: Maestro Tools/Sonar No Midi - Help!

    Thank you so much for taking time out to help me with my problem. I was opening the programs in the wrong order, which I guess could have been the source of all of the problems I was having. I was starting Maple, Sonar, then Giga.

    Now that you have enlightened me - I am thoroughly enjoying your program!


Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts