• Register
  • Help
Results 1 to 6 of 6

Topic: Please help with the DXi tempo bug!

  1. #1

    Please help with the DXi tempo bug!

    I have carefully read all the postings about this, and I know what I am supposed to do (I think). I have tried it six or seven times but the tempo bug remains...

    One problem is that when I run the \"wrapper\" (that is Cakewalk VST Adapter 4, isn\'t it?) I get an error message \"The application has failed to start because CWDXPX1.dll was not found. Re-installing the application may fix the problem.\" The program then goes on and finishes by telling me that the plug-ins are successfully installed. But they aren\'t. There are three different GPOs listed in the wrapper but only one appears in Sonar3 and it is the old tempo-bugged DX1.

    I have re-installed the wrapper 3 times and nothing has changed.

    Does anyone know where the CWDXPX1.dll is supposed to live? That would be a good start.

  2. #2

    Re: Please help with the DXi tempo bug!

    Originally posted by Poolman:

    Does anyone know where the CWDXPX1.dll is supposed to live? That would be a good start.
    <font size=\"2\" face=\"Verdana, Arial\">I have Sonar 2 and the file is in it\'s directory (Program Files/Cakewalk/Sonar2).
    Try reinstalling Sonar and let me know if it helps.

  3. #3

    Re: Please help with the DXi tempo bug!

    I think you may have not un-installed GPO before re-installing it with a VSTi only. You probably are wrapping the VSTi correctly but Sonar will only grab the \'true\' DXi to use. I don\'t use Cakewalk\'s wrapper, I use DirectiXer.

    Instead of competely un-installing GPO and re-installing it, you might look about on shareware sites for a little program called \"DX uninstaller\"
    It works great for removing the directX programs from the registry so they don\'t keep showing up in your programs.

  4. #4

    Re: Please help with the DXi tempo bug!

    Georgedaae and Nexus,

    Thanks for the replies, but I am in worse trouble.

    I have deleted the old GPO with your DX delete program. I have reinstalled Sonar3 and CW VST Adapter and GPO (specifying it as VST). (I still get error messages using the wrapper.)

    What happens now is that GPO still appears in the list of DXi\'s (should there be a list of VST\'s?) and can be brought up and loaded, but does not appear in the the audio track it was loaded into, though it is listed in the DXi box. I have made and saved a short Sonar piece with sounds loaded into the GPO. When I reload it I see the screen loading in the GPO sounds using a progress meter, and again they appear in the DXi box, but not in the audio track they should be loaded in.

    Things work but only in the old style, i.e. The tempo bug still rears its ugly head. Why did Garry ever put GPO out in this condition?

    The big question is: How do I access the VST version of GPO in Sonar if it does not appear anywhere as a choice, only as DXi?

  5. #5

    Re: Please help with the DXi tempo bug!

    MORE: I have downloaded and used DirectiXer. It set up the VST version of GPO OK and this appeared in Sonar at last. So I get things started using this VST version. Only trouble is now that Sonar crashes (hangs) as soon as it encounters the first note of the piece.


  6. #6
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: Please help with the DXi tempo bug!

    I would remove any other VST wrapper programs and then contact Cakewalk. It appears that you have a corrupted file or bad entry in the registry. When you run the VST Wrapper that comes with Sonar it should fine all plugins as long as you have the correct folder to scan. Make sure you scan with Sonar closed. Then reopen Sonar and under where you add the DXi plugins there should be one called \'VST\'. Click on \'VST\' and you should get a submenu with Garritan Personal Orchestra.

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts