• Register
  • Help
Results 1 to 7 of 7

Topic: GOS, Giga, Sonar - port issues!?!

  1. #1

    GOS, Giga, Sonar - port issues!?!

    Help! I\'m trying to set up Giga on a separate computer and am having problems with Sonar sending the right port info to giga. I\'ve tried using midi channel and instrument number in sonar which seems to work fine for port 1, though when I look at giga things have morphed and every channel on all ports becomes filled with the instrument I just loaded and all ports in giga are receiving midi data.
    I have turned off \"Always Echo current midi channel\" but the problem still exists.

    Is there something I am missing in Sonar that will allow me to send port, channel, and patch specific information?

    Thank you in advance!


  2. #2

    Re: GOS, Giga, Sonar - port issues!?!

    A little more information about my set up:
    I am usig Midi-Over-Lan, with Music Lab\'s Connection Center and Maple Tools as interface from sequencing computer.

  3. #3
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: GOS, Giga, Sonar - port issues!?!

    Did you setup the MIDIoverLan por ts in Sonar? You must set these up first. Don\'t have Sonar in front of me to give you the name of the exact menu item.

    Then in your track select the MIDIoverLAN port which should show up after adding the port. You can then select what patch change number and MIDI channel to send it on.

  4. #4

    Re: GOS, Giga, Sonar - port issues!?!

    I as it currently stands – I have Lan out in Sonar configured, echo off in sonar as well as in both instances of Midi-over-Lan.

    My Problem for example: I want to sound bass pizz in giga, port 4, channel 16, instrument #64
    In Sonar I have set up as follows:
    Midi in – Delta 1010
    Midi out – Lan out (only one option here – no port choices)
    Bank --- (I can not get this to do anything! I’ve tried different numbers but see no
    Channel – 16 (my desired channel in giga)
    Patch – Soprano Sax (#64) - (#64 is assigned to Bass pizz in giga)

    Midi out from sonar is being received on ALL ports in giga so channel 16 sounds on ports 1,2,3,and 4.
    I can not figure out how to get the correct port to sound in giga.

  5. #5

    Re: GOS, Giga, Sonar - port issues!?!

    You\'ll probably need to set up the ports correctly in Sonar first, and then you may also need to configure Maple and Giga after you have done that. But the first thing to do will be to set up Sonar the way you\'ll need. It sounds like midi-over-lan is a piece of software that provides more than one port. If it has only one port however, than you will be limited to one port while using it. But I\'ll assume it has multpiple ports, and I\'ll guess in the midi connection center you mentioned, you may be able to tell midi-over-lan to present multiple ports, rather than a single one. When you said you have only one choice in Sonar, which is the \"Lan-out\", then that suggests you will need to change midi-overlan somehow so that it gives you more ports to choose from. Let me know if this helps or not.


  6. #6

    Re: GOS, Giga, Sonar - port issues!?!

    Hi Jeff - thank you for your assistance!
    Midi-over-Lan(music Lab) has a single lan line connection between the two computers. Music Lab\'s Connection Center has 4 ports which I have configured to each of the Maple ports.
    I am receiving midi and channel messages fine on port one. I just can\'t seem to be able to dictate in Sonar that I want port 4(3,or 2) only on a particular track.

  7. #7

    Re: GOS, Giga, Sonar - port issues!?!

    Problem solved!!!
    I had only set up Lan-Out 00 instead of numorous outs (01-04)in my sequencing computer. By setting the additional Lan-Outs I was able to use the Connection Center on my Giga computer to route midi to the 4 Maple ports and thus the 4 ports in Giga. Thank you Haydn and Jeff for your help!


Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts