• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Topic: Low Memory warning during load w/ 2gb ram

Share/Bookmark
  1. #1

    Low Memory warning during load w/ 2gb ram

    I built a new pc just to run GPO stand-alone. I have 2 gb of ram in the machine and was quite suprised to see the \'Low Memory\' warning dialog pop up when a little over 1 gb of voices had been loaded. The voices seemed to continue to load but upon playback I seem to get some crackling in the signal. I\'m using BrainSpawn\'s Forte as the VST host. Anyone have any suggestions?

  2. #2
    Moderator
    Join Date
    Jun 2000
    Location
    Chandler, Arizona
    Posts
    4,045

    Re: Low Memory warning during load w/ 2gb ram

    You need to open up Task Manager and take a look at what is using the memory. You can open up Task Manager by hitting Ctrl-Shift-Esc at the same time. Click on the Performance tab and it will show you the amount of free memory, how big the swap file is, etc. Click on the processes tab to see what is using the memory.

    Does your system actually show 2 GB of memory? Task Manager will let you know.

  3. #3

    Re: Low Memory warning during load w/ 2gb ram

    Thanks for the suggestion. I was using task manager to view the remaining memory. The point is ... I\'m getting a low memory warning with task manager showing over 700mb of ram still available!

  4. #4
    Moderator
    Join Date
    Oct 2000
    Location
    Orcas Island
    Posts
    11,454

    Re: Low Memory warning during load w/ 2gb ram

    bousley,

    You should be okay with just 1 GB. Try using just the dry instruments. Have you tried the GPO Studio VST Host?

    Gary Garritan

  5. #5
    Moderator
    Join Date
    Jun 2000
    Location
    Chandler, Arizona
    Posts
    4,045

    Re: Low Memory warning during load w/ 2gb ram

    What OS are you using? What applications are installed? Really need more details.

    Is this a low virtual memory error? Some programs must have a swap file to work so the swap file may need to be larger.

  6. #6

    Re: Low Memory warning during load w/ 2gb ram

    Gary,

    Thanks for the suggestions. The idea behind the 2gb system was to be able to load any voice I thought I might use within GPO at the start of the session. I have another two machines that run GigaStudio and yet another that runs ProTools. I like the idea of doing one sample load at the beginning of the session. I had tried using the RTAS plugin within ProTools but found having to wait for all the voices to reload when moving from one piece to another a little tedious. I have tried the GPO Studio VST Host but it didn\'t recognize the MOL (midi over lan) virtual ports that allows all the machines to communicate. Also, I am using all dry voices. I have seven instances of GPO active and have about 45 voices loaded.

  7. #7

    Re: Low Memory warning during load w/ 2gb ram

    Are you using WinXP? Isn\'t there some per-thread or per-process memory limit? Perhaps NI can weigh in on this. I have 1.5GB of memory on one machine and have hit the same warning at near 1GB. It may not be a bug as much as an imposed OS limitation.

  8. #8
    Moderator
    Join Date
    Jun 2000
    Location
    Chandler, Arizona
    Posts
    4,045

    Re: Low Memory warning during load w/ 2gb ram

    I have had up to 1.5 GB of memory loaded without this error in WinXP. I\'ve also had 8 instances of Kontakt loaded and GPO player fully loaded without this error. I had 11 instances of Kontakt, Kontakt player and Kompakt player loaded without this error.

  9. #9

    Re: Low Memory warning during load w/ 2gb ram

    The thread limitation being referred to is 2gb anyway so it shouldnt be causing the problem.

  10. #10

    Re: Low Memory warning during load w/ 2gb ram

    After you have disable the swap file, you make sure the registry setup is correct for large ram memory. Not recommend for user have only 512mb. In the registry editor go to :

    HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Con trol\\Session Manager\\Memory Management

    The right of the window contain two keys named :

    DisablePagingExecutive « you will have to put the value (1) »
    LargeSystemCache « you will have to put the value (0) »

    It is a top expert which gave me this information.

    Hope this help!

    -Benny

Go Back to forum

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •