• Register
  • Help
Page 1 of 6 1234 ... LastLast
Results 1 to 10 of 54

Topic: OSX users, let's figure this thing out!

  1. #1

    OSX users, let\'s figure this thing out!

    I thought I could be a little more proactive in helping track down these problems some of us are having in OSX. If everyone could give a short report on what you\'re using GPO with, (software and hardware) if it works for you or not. (sometimes or rock solid) If it crashes, what were you doing when it crashed? Is your library on the same drive as the app. etc....

    I have seen this kind of thing help by letting patterns emerge and narrowing down the culprit (or culprits)

    Really don\'t want it to turn into a crabfest or anything like that. And it\'s probably just as helpful to hear a report from someone who\'s got everything working solidly (Ned!) and what kind of usage they are putting it through.

    It\'s also a GREAT idea to send crashlogs to Gary. He will send them right over to NI to Martin, who\'s the top guy for this kind of stuff.

    My setup:

    MDD 1.25, 2GB, OS 10.3.2
    Motu midi express 128 (usb)
    Motu 2408mk111
    Logic 6.33
    DP 4.12

    New drivers for the Motu stuff
    Brand new install of Panther
    Rock solid until GPO added

    I\'ve managed to crash Logic and DP three or four times in the last few hours.

    Logic crash was a full kernel panic.

    In Logic I was playing back a short piece with maybe 36 instruments loaded, but only 12 or so were actually triggering from the midi files. I can\'t remember what else caused the crashes but sometimes I can just hit a button that it doesn\'t like for some reason, and that\'s it. Automation appears to be problematic in Logic as well.

    DP crashes and freezes.

    DP crashes when I tried to edit CC1 data in the event list. It also crashed when I tried to set up a midi device group. It also lost it\'s way to the library, but that was easily fixed.

    My library resides on a seperate drive from the app. I don\'t know if that\'s significant or not but you never know (until you do!)

    Also I should add that if any of you programmer types out there can read a crashlog and are willing to do a cursory examination of them, maybe we can post them right here. (bet there\'s a lot that could be learned)

    So that\'s about it for now. I hope we can hear from a lot of you guys. Maybe we can get to the bottom of it.


  2. #2

    Re: OSX users, let\'s figure this thing out!

    GJood idea, Esteso.

    My setup is very close to yours, except on a Quicksilver Dual Gig. Same OS, same apps.

    Logic 6.3.3

    I have two major gripes - the stuck notes (rewind while a note is playing, and it plays forever), and the multi-instrument automation problem. Both are known, and appear to be \'features\' of Logic. :-( I simply do not use Logic with Kontakt or Kontakt Player, as a result.

    DP 4.12

    I have no problems at all with GPO in DP, though I do wish the multiple outputs would get implemented. As it is, only outputs 1-2 appear in DP. I don\'t know if this is a Motu or NI problem.


  3. #3

    Re: OSX users, let\'s figure this thing out!

    OS X 10.3.2 + Logic 6.3.2 + MOTU 828 MKII + Dual G5 2Ghz + 2 gigs RAM = no problems for me.

  4. #4

    Re: OSX users, let\'s figure this thing out!

    Originally posted by esteso:

    In Logic I was playing back a short piece with maybe 36 instruments loaded,
    <font size=\"2\" face=\"Verdana, Arial\">I could never get close to 36 instruments. The most I got before upgrading to 008 was 16 over 4 instances. With that, I could playback but couldn\'t record the whole lot as audio. I couldn\'t even record the violins as audio (only four instruments) without the cpu overloading.

    Yesterday (after upgrading), I could play back 16 instruments over two instances fairly cleanly; we\'ll see what happens from there.

  5. #5

    Re: OSX users, let\'s figure this thing out!

    Panther, powerbook G4 1.33 Ghz, 512 MB of RAM, cubase SL 1. No big problems, but sometimes I have the problem of stuck notes.
    I reached the limit with 17 instruments playing together (a string orchestra made up with ens. instruments) and the included reverber on.
    Is there anybody who works with GPO on a laptop?

  6. #6

    Re: OSX users, let\'s figure this thing out!

    Just wanted to throw this in this thread:

    Obviously, the first thing on anyone\'s mind who\'s planning an OSX machine to run a RAM based sampler is ...\"ram\".

    To that end, I\'d like to just remind that OSX is \"very\" sensitive to ram incompatiblities. The issues from this can turn up in any number of ways..from subtle, to severe. And it will get worse the more load you put on it. There have been more than a \"few\" people who purchased Macs with OSX who put aftermarket ram in it from the start, who have had more than their fair share of issues (apps quiting, kernel panics, etc), who tried to solve the issue by adding more ram, only to find the situation get worse.
    If you have any doubts, remove all the ram but what came with your mac. Start putting load on it (doesn\'t matter how you do it), and see if it crashes or you get unexpected quit ..poof. There are ram checkers and they sometimes work..sometimes not. The best way is to yank the aftermarket ram and see if the problem goes away. I\'ll mention here, if this is the case (or bad logic board) you\'ll have this same behavior in any app. Not just GPO or etc. It will be consitant crashing across the board. You may find your machine freezes just sitting there. These are all symptoms of bad ram or logic board.

    To add to that, Apple has had more than their fair share of hardware failures (QC) lately. There are people who even after removing all the ram except for the apple branded ram that came with the machine, had the same sort of behavior, who ended up having their logic boards replaced.

    More than a few. And I\'ve worked on a few of them. The frustration here is, when you have the same hardware, OS revision, software revision, etc, and \"you\" have problems that the other person does not have my be worth checking some of this out.

    Here\'s some other things that can cause wierd behavior in OSX and apps: the \"blue box\" or \"classic\" compatiblity environment.
    It\'s set to boot at startup by default (even if you are not using it).
    And, after you run a \"classic app\" under OSX the bluebox remains running until you quit it. It doesn\'t quit with the app. You can got to the \"classic\" control panel in OSX and set it to not start automatically on boot AND you can also kill it if it\'s running actively.

    I recommend NOT using classic ..ever, if you can help it...specifically if you are on a dual boot , single drive system (such as a powerbook).

    Here\'s some other things/differences that could be out there, Panther uses a new updated file system addition to HFS+ called \"journaling\". Journaling, works something like Disk Warrior that runs all the time. It rearranges your file system based on priority and it will auto defrag any file over 20 megs that\'s fragmented.

    It will also reduce your disk response and load capability by about 10%. When you install OSX, you have the option to \"not\" activate journaling. I recommend that if you are going to use audio apps on your Panther install. You can also turn it off. (active journaling). But, regardless of which option you choose, when you install panther on a drive you have erased with the drive setup that comes with Panther install, you will note your drive now reads xxxxx hfs+ (journaling).

    Some more: fonts. Many mac users, might typically have a DTP collection of fonts in their system and may be using a font utility such as \"suticase\" from extensis, etc. This is one area that I think I\'ve seen \"more\" instability from than anything else. Some of these utilities \"auto activate\" fonts and over time, the font cache gets corrupted and will cause a crash in just about any app you open. To clean this up, there are instructions from most of these font util makers on how to delete all the font cache files (whcih might be strewn about your drive in numerous folders), and deleted the font database and prefs to they can be rebuilt fresh. DeepSix is a free utility that will search for such adobe and other font cache files across drives and wack them in one shot.

    The other thing related to this, when you install Panther, it does not search your drives for fonts. But, it \"will\" pull in everything in your OS9 sys/fonts folder. So, if you\'ve been hording fonts from OS9 in your OS9 fonts folder, they are now in your OSX install.
    Having multiple fonts of same type or name is also a cause of problem. A bad or corrupt font as well can cause issues. If you are using a font mangement system (even the built in one in Panther) make sure you have it set to DO NOT manage system fonts. If a font util removes one of the base system fonts or replaces it with a different version sub, OSX will buck like a mustang. There are only a few base system fonts that come with Panther, but one of them is \"helvetica\" a common font. If you are into DTP you might have 4 different versions of this font. Your font utilitiy might see these as duplicates and remove or deactivate all but one. What I\'m saying is, if it\'s managing your system fonts, it may \"remove\" that font and try to sub a different helvetical font..which would cause OSX and apps to crash.

    So, that\'s another area to just be wary of. Most of my studio clients run very clean systems..just panther and their needed audio apps, etc. But, some of them, use their macs for \"everything\" including a DTP business with Quark, PS, etc and about 2000 fonts on their system along with a font management utility. So, I mention some of the things I\'ve come across.

    As a last bit, \"any\" USB, firewire device could be the source of trouble. If you are troubleshooting, and having problems, remove all of them you can (save the apple keyboard/mouse). Use of FW HDs has become so previlant that many people no longer even consider it a 3rd party add on. More than once I\'ve been on phone with client instructing them to remove ALL connected devices save the keyboard/mouse and somewhere down the line they mention their files are on the FW hd. Removing the HD cleared up the issues. There have been some updates along the way (firmware, etc) that have fixed some of these issues. Some people never have any issues with them. And others..seem determined to chain as many FW devices together as they can, and just consider it part of their mac and never think to remove any of it when they have trouble.

    That means, hubs, everything. HEre\'s a very interesting one, client had perfectly working system suddenly go south. I asked what had changed...nothing of course. Finally I asked him to remove all 3rd party devices. That fixed it. We traced it to the USB hub...but he swore it worked just fine for months..how could it just go bad. I asked him what he had changed in regards to what hardware he had plugged in. He had removed one of the USB devices a week before to take with him on a trip..but left the USB cable plugged into the hub..with no device attached to it.

    To test this, we plugged the hub back in, but removed the dangling cable. Problem gone.

    It was probably the strangest issue I\'ve run across, in that regard, but I post it here to show when you get to trying to isolate the issue, make sure you unplug \"everything\"...and don\'t leave any cables plugged in. Some people do this, becuase it makes it easier to reattach the device..ie..leave the USB/FW cable lieing out etc. Be aware that this \"could\' be a possible source of conflict.

    Lastly, I\'ll mention the user mantainence that you should do on your OSX system.

    Reparing permissions. EVerybody has heard this one. But, what you may not know is, that most \"installers\" from 3rd party companies frag your permissions to some degree. You should always rebuilt permissions after \"every\" install of any software to be safe. And you should religiously repair them about once a week or so. Once permissions start to go wacky, folders will dim out in the finder and not be accessible, you\'ll start getting file not found errors, any sort of wierdness, that eventually, could lead to file corruption, disk corruption. Most installs you wont\' find much corruption. But, I\'ll just mention, that I\'ve seen some 3rd party installers that fragged persmission \"royally\". Took about 20 mins to repair the damage the installer did to file permissions. So, \"always\" run this. And do it religiously, it won\'t hurt your machine to \"over\" do this. (think of this as the equivilent of rebuilding your desktop file on OS9...do it, and do it often to prevent catastrophic file loss or irreperable damage)
    To repair permissions: applications/utilities/disk utility.
    Select the volume your OSX is isntalled on. Select the \"repair persmissions\" button. If anything is wrong, it will list it.
    You can, for an even more complete job, run the utility from the OSX CD after rebooting from the CD. If you can\'t get persmissions repaired just running the utility locally, you might try this method.

    To that note: I\'l mention Norton. Do NOT use anything by symantec on your mac...specifically an OSX install. It\'s just asking for it. And I\'ve had plenty of experience repairing drives and otherwise that have had Nortons running on it. They usually do more harm than they fix things. You should \'only\" run such 3rd party apps, IF you have problems and have tried all OSX means to get things up and need the files on the drive. After you get the files (if you do) using such a utility, wipe the drive with OSX install disk and reinstall fresh. Same goes for DiskWarrior, techtool, etc. They are handy in emergencies, but I would not trust them for daily maintenance. (just my experience). They chances are likely that they will cause more harm than they will fix if used over time.

    Next : Cron Jobs\". These are the maintenance scripts that run every night at 3:10am on your OSX machine that clear out unused cache, rotate logs, etc. The problem is, they ONLY run if your machine is on and awake at that time. If you are like most people your machine is asleep..and the jobs won\'t run. This means, you need to run this jobs \"yourself\". There are daily scripts, a weekly script and a monthly script. Out of those, the weekly is the most intense and takes the most time..a few mins.

    You have a couple of options here. One is to get a free utility that makes this easy to run them at will. I tend to frown on using any 3rd party utility for such things, but people report they work ok. The issues are, if you upgrade your OS, they may have changed some of the things about how this works, and your utility that kept your machine fresh, might suddenly make things a mess without you knowing it.

    You can run them simply /manually, thru the terminal app.
    applications/utilities/terminal. You\'ll see your user name/login with a square next to it. This is the command prompt.
    type \"sudo periodic daily\" with no quotes and hit return. It will ask for your password. (admin password you setup on OSX). It will run very quickly and return the prompt. Next type \"sudo periodic weekly\" again, no quotes and hit return. This one will take a few mins and you\'ll hear your drives cruching away. Eventually, it will return the command prompt. Type \"sudo periodic monthly\" and hit return. That\'s it. Done.

    Doing these 2 things, (repair permissions and cron jobs) will keep your OSX install fresh. Anyway, that\'s it for now. Some of this will probably be redundant for many of you. I apologise for that. And I apoligise for the long post here. But, hopefully, this info might prove useful to some who are having problems. When you\'ve confirmed that you have the same revisions of DP, GPO, etc same mac, same OS, and having all sorts of issues no one else is having? Time to start looking at some of these areas to see if you have ram issues or if your permissions are fragged or etc.

    Hope that helps.

  7. #7

    Re: OSX users, let\'s figure this thing out!

    Trond, Just curious, are you using the Kontakt player as an AU or within a VST wrapper?
    I have no trouble at all with the AU version, but the VST with Audioease wrapper doesn’t work at all for me. The graphics get all messed up, and the pointer’s coordinates don’t match the buttons and menus on the player.

    G4,1.25g processor, 2g. ram, DP 4.12, MOTU 1224 audio interface with PCI324 audio card.

    Also when you say outputs, are you referring to audio outputs in DP? I’m sure you know this but if you want to increase your audio outputs, make sure that you have enough available when you set up your studio size. (Setup/Configure Audio System/Configure Studio Size). Then make sure the outputs you want to use are selected in the Audio Bundles menu. (Audio/Audio Bundles). Then they will show up in the output menu for GPO in the Tracks window. I’ve never been real comfortable with this audio bundles thing. However, this may not be at all what you’re referring to.

    Also remember Mac Guys, In OSX virtual memory will kick in when you don’t realize it. It’s not like the good old days of OS9. At this point things will just creep along. That’s why we need to get as much ram as we possibly can.

    Esteso, This is a great idea.


  8. #8

    Re: OSX users, let\'s figure this thing out!

    trond, can you see what happens in DP if you record a track with CC1 data and then edit it in the Event list? Just erase a few bars or re-record some mod wheel stuff on the same track (merge) or change the values on a few events manually.

    That\'s how I got DP to crash yesterday.

    Ned, does the 828 have midi or are you using another unit for midi? I think the midi input component is particularly critical and so it\'s nice to know which ones are smooth sailing.

    Michael, if you can wait until fall you might be able to get into a G5 powerbook.


  9. #9

    Re: OSX users, let\'s figure this thing out!

    Originally posted by esteso:

    My setup:

    MDD 1.25, 2GB, OS 10.3.2
    Motu midi express 128 (usb)
    Motu 2408mk111
    Logic 6.33
    DP 4.12

    New drivers for the Motu stuff
    Brand new install of Panther
    Rock solid until GPO added

    I\'ve managed to crash Logic and DP three or four times in the last few hours.

    Logic crash was a full kernel panic.

    <font size=\"2\" face=\"Verdana, Arial\">Esteso,

    I have exactly the same setup as you do! Do not look any further for the culprit, it is your MOTU stuff. I did change my MOTU souncard for an RME Multiface, and I never had a Kernel crash again (use to have several per day before changing the MOTU crashcard) .

    But I do still have problems while using GPO on MAC OS X, but not this one.

  10. #10

    Re: OSX users, let\'s figure this thing out!


    Thanks for thos very intersting contribution.

    I did try this \"cron jobs\" procedure. here is the copy of the terminal and it does not accept any typing after this????

    Last login: Tue Mar 2 21:07:21 on ttyp1
    Welcome to Darwin!
    Iwan-Roths-Computer:~ iwanroth$ sudo periodic daily

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these two things:

    #1) Respect the privacy of others.
    #2) Think before you type.


    I did repair the disk privileges just before doing this

    Someone does know what this means??

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts