• Register
  • Help
Results 1 to 4 of 4

Topic: giga and Logic Audio

Share/Bookmark
  1. #1

    giga and Logic Audio

    I can\'t use my giga with logic audio. I was using giga studio inchanel 1&2 but now LA switch automatically ti 1&2. I change the out in giga to 3&4, but It doent sounds. When I switch in reverse order(LA 3&4 giga 1&2) In logic appears a legend: Hardware is busy. Any ideas or suggestion?

  2. #2

    Re: giga and Logic Audio

    Jose, I think you must be pretty close to getting it happening. Below I\'ve pasted a reply from Nemesys\' Kevin Phelan to another user with a similar problem.

    The core of the problem seems to be that Logic allows you only to select HOW MANY audio channels you will use - and not pick what numbers they are. On the other hand (as you obviously know) Giga lets you pick specific channel numbers. It looks as though if Logic has been told it needs 4 channels, it will try and take the first four, not the first four available. In your case I\'m guessing that telling Giga to use 3&4, then telling Logic only to use two channels (which will make it want 1&2), and then restarting both programmes, would get you going. On the other hand, if you wanted 4 audio channels for Logic, you\'d have to move Giga to 5&6, because Logic would insist on using the lowest four numbered channels. I could be reading this wrong and haven\'t tried it myself as my setup doesn\'t appear to have the balls to run Giga+midi+audio.

    Here\'s Kevins reply (also note that you need to be running a particular minimum version number of Giga).

    Hello Dave,

    It appears that Logic and Gigastudio are both fighting over the Mixtreme\'s 16
    audio channels. This will happen even when
    Gigastudio isn\'t actually running.

    Solution:

    Gigastudio allows you to enable or disable each individual audio channel on the
    Mixtreme card.

    Logic allows you to specify the *maximum number* of channels you would like to
    enable on the card.

    So take the following steps:

    1) Run Gigastudio. On the Settings->Hardware/Routing page disable all audio
    output channels. Enable channels 15 and 16.

    2) While Gigastudio is running, start Logic Audio. In the second Audio Drivers
    settings page, under ASIO choose \"Max I/O streams\"
    of 14 IN and 14 OUT. Then enable ASIO and relaunch Logic.

    Assuming both programs exit correctly and save their settings, it should now be
    possible to start either program or both at the same time without crashes.

    Notes:

    * This assumes that the user wants to reserve 14 channels for Logic Audio and 2
    channels for Giga. Of course you can change
    this. Just remember that Logic takes over a range of channels from 1 up to the max you specify. Logic ignores channels above
    this max. You can assign these extra channels to Giga or to another app.

    * Gigastudio 2.01.36 is a necessary update for this setup to work, because previous versions of Gigastudio wouldn\'t let you change the sample depth from 24 bits to 16 bits. Plus some problems with Logic
    integration have been addressed.

    Kevin
    Nemesys Tech Support

  3. #3

    Re: giga and Logic Audio

    I have a system with an SW1000 and an SB Live; in Giga if I want to output to the SW1000 I have to select \"SB Live\" in the pull-down list; and if I want to output to the SB, I have to select \"SW1000\" in the pull-down list. Go figure.

    So I don\'t known that I would entirely trust Giga\'s channel allocation either.

  4. #4

    Re: giga and Logic Audio

    Chadwick Thanks for your answer, but I still can\'t find the solution, my card is a delta 44 and every time. After try the solution you send me, when I switch off the outs in giga, it automatically turns on 1&2when I press apply!!! of course logic audio is trying to work with 1&2 drivers, and when again I select 3&4 for giga, Logic answer me with hardware maltion. and hardware is Busy


Go Back to forum

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •