• Register
  • Help
Results 1 to 9 of 9

Topic: A very strange bug with Midi over LAN

  1. #1

    A very strange bug with Midi over LAN

    sponsored links

    Sorry to post that here.

    But I know there is a lot of users on that forum.

    I had to re-install all my DAW after changing my mother board.

    I run 2 PCs with a GigaPC linked to my DAW with a crossover cable. (No LAN switch.)

    This is the problem : I get 4 voices instead of 2 for a stereo samples... so, my polyphony resource is divide by 2...

    I don’t use the ‘Echo to’ option in any way.

    I don’t use Local Pipe.

    This is not a sequencer problem : same problem with Nuendo or Samplitude...

    When I click the ‘Send test MIDI event’ I get 4 polyphony voices in Gigastudio...

    I send Music Lab a mail : no answer...

    Anyone get that trouble ?

  2. #2

    Re: A very strange bug with Midi over LAN

    Two quick thoughts on this:

    (a) you might have the midi ports locked in Gigastudio. I think this toggles on and off by clicking on the red-white flashing bar on the lower left of GS.

    (b) you have a midi loop.

  3. #3

    Re: A very strange bug with Midi over LAN

    I had a similar problem, but looking back I think it was user error. I probably had my keyboard sending out data on multiple channels or something.

    Anyway, to try to solve it I ended up using \"filtering\" in the MOL window. This is best done using IP addresses, rather than computer names. (There are some bugs with the computer name deal that force you to reboot too fix them.) To use the IP addresses, you will need to have your PCs set to use fixed IP addresses, rather than DHCP.

    I posted a detailed description of how to do this in one of the other threads recently. (Hardware/Software/Off-Topic - not sure which.)

    Best of luck!

  4. #4

    Re: A very strange bug with Midi over LAN

    Hi, Marko.

    Well if I turn the Midi loop off in Gigastudio (Keyboard ’flashing’ red) I get... nothing.

    No more midi signal in GS...

    So I have to keep that option on (white).

    (Anyway, I still don’t understand what this Midi Loop option is about...)

    And at this moment, I use Midi Over LAN only in one direction : from my DAW (Midi to LAN, LAN out anabled) to my Giga PC (Midi from LAN, LAN-in anabled).

    Nothing more...

    So if there is a Midi Loop, I really don’t see where...

    Hi, Jon.

    I’ll check up my Keyboard controller.

    I hope this is a user problem... (and not an hardware problem !)

  5. #5

    Re: A very strange bug with Midi over LAN

    Simon Ravn asked me to post this for him:

    Hi Crystal!

    I had the same problem on a machine a while back. It could be two things. If you\'re not using FILTERING (by choosing the host machine by IP or hostname, on the GS machine(s)). Try turning on that and see if it helps. If that still doesn\'t fix it, try enabling \"Assign correspondent device number\" (and make sure that the device numbers you assign here are the same on the in and out!).
    - Simon Ravn

    Hope this helps!

  6. #6

    Re: A very strange bug with Midi over LAN

    Hi, Hansi.

    And Hi, Simon !

    (Banned but still here to help... Very gentle to do that.)

    So I’m not alone !

    I’ll try it now.

    (And, yes, I’ve just checked my keyboard with a VSTI in Nuendo : no problems. And I tried a single note drawing in the midi editor : still 4 voices in GS. So no keyboard, sound card or sequencer problem)

  7. #7

    Re: A very strange bug with Midi over LAN

    Problem solved !

    You were right, Simon, the filtering choice is definitely the good one.

    I didn’t have to enable the \"Assign correspondent device number\" option.

    It works.

    And Jon, this is the link you were talking about : http://www.northernsounds.com/cgi-bin/ultimatebb.cgi?ubb=get_topic;f=3;t=007182
    So I put the IP address for my DAW, and the for my GigaPC

    Dave (Govett) was talking about the 248 value at the end of the ‘subnet mask’, as essential to reduce the network range, so I did it too...

    But, two things :

    What is DNS about ?
    I put the value in XP (My DAW), but I didn’t in 98se (My GigaPC), because it asks a ‘host’ and ‘domain’ names or numbers in 98se... I don’t know what it is.
    Well it works though.
    But what is DNS ?

    In both systems (XP or 98se) we have the possibility to check some options (or ‘link’ in 98se) calling ‘Microsoft Network client’ and ‘Individuals windows session manager’ (translated from French, I don’t know the English formulation)
    It seems that those options unchecked make LAN more faster...
    But do we need them ?
    What are those options about ?

  8. #8

    Re: A very strange bug with Midi over LAN

    Oh, OK.

    Hi, Haydn.

    So DNS is a Web option.

    Then we don’t need it for a ‘home local network’, like our DAW network.

    (I have a separate PC for the web, and only the web, for security reasons of course.)

    Thanks Haydn for the reply.

  9. #9
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: A very strange bug with Midi over LAN

    DNS stands for Domain Name System. DNS resolves domain names (northernsounds.com) to IP addresses ( or vice versa. This makes it easier to navigate the web by names. Without DNS you would have to type in the IP address which are not easy to remember.

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts