• Register
  • Help
Results 1 to 8 of 8

Topic: PC not seeing my Midi interface

  1. #1

    PC not seeing my Midi interface


    I\'m trying to set up a Windows 98 PC to run GigaStudio standalone, and I\'m having problems with the computer not seeing my Midi interface.

    The interface is a MOTU MidiExpress XT. I\'ve installed the Windows 98 drivers from MOTU, but when I get to the setup portion of the installation, I get a message telling me that the MidiExpress can\'t be seen. I know that it\'s not the interface itself that is broken, because I have a second MidiExpress that I have also tried and haven\'t had more success.

    I\'m thinking it could be the parallel cable. I couldn\'t find a cable that had db25 male-to-female connectors at the local stores, so I had to buy a male-male and add a male-to-female adapter at one end of the cable. Maybe that\'s a no-no? Also, the cable length is 25 ft. Is that much too long? Long enough that the PC couldn\'t see the interface?

    If it\'s not the cable, then I guess it has to be some setting in the computer\'s BIOS. My motherboard is a ECS K7SEM v3.0M. Right now, the parallel port address is 378h, the mode is SPP, and the IRQ is 7. Those are the default settings. Still, I have played around with many different combinations of settings without success.

    That\'s about it. I\'d appreciate any tips and suggestions that anyone might have. I\'m a Mac user whose a total newbie when it comes to PC\'s, so I can use all teh help I can get!

    Many thanks.

  2. #2
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: PC not seeing my Midi interface

    Many parallel port interfaces don\'t work with the default BIOS settings. Try changing it to EPP. I just installed a new motherboard and had the same issue with my MOTU MIDIExpress interface. Changing the mode in the BIOS fixed the issue. After you load Windows, make sure you reboot again and then install the drivers.

  3. #3

    Re: PC not seeing my Midi interface

    Ripped from MOTU\'s site (I\'ve added all bolding):

    1. Click on start/settings/control panels, double click Add New Hardware. In the first window click on “Next”. In the second window select “No, device is not in list” and then click on “Next.” ... you\'ll be prompted to search for drivers. Hit next, windows will search for drivers... select \"No device is not in list.\"

    2. The next window will offer a list of different types of hardware to install. Scroll down the list and select “Sound, Video, and Game Controllers.” Then click on next.

    3. In the next window, Windows will list a number of manufacturers. Because Mark of the Unicorn is not listed, simply click on “Have Disk.”

    4. Insert the driver disk or browse to the folder containing the expanded download. Click “OK” and at the next prompt click on “Finish.”

    5. Confirm the IRQ setting and Base Address or Port and click on “OK.” That\'s it. The driver is now installed.

    When installing a MIDI Timepiece AV (MTP-AV), a MIDI Express XT, a Micro Express, a Pocket Express or a PC MIDI flyer, you will then get a prompt to perform an auto setup. If you get a no reply from the interface it is important to confirm that the communication mode of your LPT port is set to EPP or bi-directional. This setting is established in the BIOS of your system. Your computer manufacturer can walk you through these settings if you are unfamiliar with BIOS.

    You will also need to check what IRQ the LPT port is set for. Our drivers require that LPT1 is set to IRQ 7. You can check what other device may be using the same IRQ by going to the System Control Panel, click the Device Manager tab, and double-click the Computer at the top of the list. Make sure that there isn\'t another device set to use IRQ 7.

    We\'ve found that legacy devices like sound Blaster cards cause problems with midi interfaces. In the system control panel/device manager, disable any legacy emulation setting for your sound card and/or disable any "Legacy drivers" that your sound card may install (labeled "legacy" or "dos" or "emulation&#34. To disable a driver, right click on it and choose "disable". Typically disabling legacy emulation will not affect the sound cards operation in windows.

    ECP printer port drivers are not compatible with MIDI under 98/ME. Use the normal Printer driver for the LPT port. To check whether or not you are using the normal driver, go to the device manager and click down on the ports list. Your LPT should read "Printer port (LPT 1)" rather than "ECP Printer Port (LPT1). To update the drivers select the ECP printer port and choose properties. Hit the drivers tab and the "update drivers" button. Choose "No" for auto scan, next and "show all drivers". You should see a "Printer Port" driver on the RH side. If not, use your windows CD to install the driver.

    Some network cards can cause problem with midi interfaces. If you\'ve done all the steps above and still have a problems, try disabling items listed under "network adapters" in device manager.

    Switcher boxes and copy protection dongles can also interfere with the scan. For troubleshooting, remove these devices.

    I hope this helps.

  4. #4

    Re: PC not seeing my Midi interface

    Many thanks for the help, guys. I\'d actually visited the MOTU site but didn\'t find all that info.

    Unfortunately, I\'ve now tried everything in there and nothing works. I always get the message that the MidiExpress XT couldn\'t be found when I try to do the auto-setup. I can only think that it must be the cables. I would have thought that using a parallel cable with male connectors at both ends and then adding a male-to-female adaptor at the MidiExpress end would work, but maybe that\'s a problem. I\'d certainly like a confirmation that this is the likely culprit before I order new cables though, because I can\'t seem to find this type of cable here in town and I\'ll have to order on the Net. So, if anyone knows if it might be the cables, I\'d appreciate if you\'d let me know.

    As far as the BIOS, I can set the address of the parallel port to either \"auto\", 3BCh, 278h, or 378h. Any clue as to what it should be set to? The default seems to be 378h, so maybe I should leave it that way.

    I\'ve tried the parallel port mode at EPP, ECP, and EPP+ECP, without success. When it\'s set to ECP or ECP+EPP, I also get a Parallel Port DMA setting that I can set to 0, 1, or 3. No idea what the correct setting should be for this one.

    In any case, I must have tried all possible combinations by now, without success.

    I\'ve also verified that no other device was using IRQ 7, so that doesn\'t seem to be the problem. BTW, does anyone know of a web site that would explain this IRQ thing to me as if I\'m a 4 year old? This is all new to me and I hate not having a grasp of what I\'m doing. For example, I saw that both my ATI Radeon video card and my M-Audio Delta 410 sound card are set to IRQ 11, and I don\'t know if it\'s normal of if I should be worried about an eventual conflict.

    Anyway, many thanks again for all the help.

  5. #5

    Re: PC not seeing my Midi interface

    There\'s a MOTU-related (but not sponsored) community of folks at unicornation.com who might be able to help you out more.

    I\'m tending to agree with you on the cable thing. You might have been given a serial cable. I\'d try a neighborhood Radio Shack--since you appear to be in Montreal, I\'m betting there is at least one nearby. You might try asking any neighbors or friends if they have a spare cable lying around somewhere.

    The default parallel port address should be just fine.

    IRQs...eep. Rather a toughie. IRQ (or Interrupt Request) is how devices get the attention of the processor. There\'s more info (much more) here:
    <a href=http://www.windows-help.info/hd_irq_com.htm>http://www.windows-help.info/hd_irq_com.htm</a>

    Your video & audio cards CAN share IRQs thanks to how they connect with the processor. There\'s a bit more info in the link.

    DMA (or Direct Memory Access, allowing data to bypass the processor and go straight from hardware to memory) can be any one of those options.

    It looks like you\'ll have to go with EPP as your parallel port setting.

    Keep us posted!

  6. #6

    Re: PC not seeing my Midi interface

    I\'m not sure of the length of cable, but I think you should also make sure the cable you have is bi-directional compatible too. (I think that\'s what O Boy was alluding to.) Some printer cables are not.


  7. #7

    Re: PC not seeing my Midi interface

    Again guys, thanks so much for your help.

    Mmm... It is possible that the cable I have is not bi-directionnal. It seems to be impossible to find the proper cable at the correct length here in Laval (yes, close to Montreal!), so I\'ll have to order it online.

    If someone has a few seconds, could you tell me if the cable at the following link is the proper type of cable for the MidiExpress? I\'d appreciate it, just so I\'m sure before I order.



  8. #8

    Re: PC not seeing my Midi interface

    I do not have a MIDI Xpress, but that is a \"proper\" bi-directional printer cable. It even has the right connectors on the ends! Relatively cheap, too.

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts