• Register
  • Help
Results 1 to 2 of 2

Topic: How I solved the Conexant Wavestream Error!!!

  1. #1

    How I solved the Conexant Wavestream Error!!!

    OK, Here\'s what I have:

    Cakewalk Sonar 2.1
    Gigastudio 160 2.53
    Midisport 4x4
    M-Audio Delta 1010
    Windows 2000 (also have used XP with the same config)

    I used to get the Conexant Wavestream error all the time. I won\'t even go into how many different setups and OS reinstalls that I tried. Instead, I\'ll tell you what I did to make everything work (and it WAS a midi problem after all):

    In Gigastudio, I selected ONLY audio outputs 3/4 on the Delta 1010 soundcard. All of the other outputs were cleared, i.e., unselected. On settings/hardware/routing, I chose the DELTA 1010 as the midi input. I DID NOT CHOOSE ANY MIDISPORT 4x4 PORTS IN GIGASTUDIO!!! VERY IMPORTANT!!! If you do not have another midi input except the 4x4, I don\'t know what to suggest, because this is the one thing I did that totally eliminated the Conexant error. If your computer has another cheapy sound card with a midi interface, select it and see if it solves the problem. I guess you could also select \"none,\" but I\'m not sure how this affects all of this.

    In SONAR (and this should work for any version of Cakewalk), I selected DIFFERENT audio outputs on my soundcard than Gigastudio was using. In this case I chose all of the outputs on the Delta 1010 EXCEPT 3/4, which I left as \"clear,\" i.e., unselected (this is what Gigastudio was using). I also chose ALL of the Midisport 4x4 inputs and outputs for SONAR, and NOT for Gigastudio (remember, I chose the Delta 1010 Midi interface for GS). VERY IMPORTANT!!! MAKE SURE THAT WHATEVER MIDI INTERFACE YOU CHOSE FOR GIGASTUDIO IS NOT SELECTED IN SONAR (in my case, the Delta 1010 midi interface)!!! YOU SHOULD BE ABLE TO DISABLE THE MIDI INTERFACE IN SONAR BY NOT SELECTING IT. THIS IS THE KEY. Also, I do not think it is possible that you could choose Midisport inputs/outputs 1-3 for Sonar and then leave input/output 4 for Gigastudio. I believe that you have to make sure that Sonar and Gigastudio do not both try to use the Midisport at the same time and in any way, even differently numbered ports. THE MIDISPORT MUST BE ASSIGNED TO YOUR SEQUENCING PROGRAM ONLY!!!

    THIS WAY GIGASTUDIO AND SONAR DO NOT TRY TO \"GRAB\" THE SAME HARDWARE IN ANY CIRCUMSTANCE. I believe that this is precisely why I no longer have any problems. It seems that BOTH programs try to grab the midi drivers AND the sound card drivers when you boot up (you can see that msg32 is working all the time under the task manager/processes), and that is what causes the error message. If you configure both programs without any hardware conlicts, there is peace and harmony.

    The tough part was getting both programs up and running so that I could change the settings, since when I was having all of the error messages I couldn\'t even get Gigastudio up and running long enough to change anything! If I remember right (I actually did all of these fixes MONTHS ago), I had to uninstall both programs (COMPLETE uninstall) and reinstall Gigastudio first, with the configuration I outlined above. I took notes, shut down Gigastudio, then re-installed Sonar making sure I chose NON-CONFLICTING choices in the midi and sound card departments.

    Everything has worked great - flawlessly - since then. To be honest, I do not remember exactly the order I did these things, but I am 98% sure what I outlined above is accurate.

    It seems to me that this same fix should apply to other programs beside Sonar and other hardware besides the two Midiman/M-Audio devices.

    If I was unclear about any of the above, please post any questions here and I will try to clarify my points. Please also let me know if these steps solve YOUR Conexant Wavestream Error problem.

    Good Luck!


  2. #2

    Re: How I solved the Conexant Wavestream Error!!!

    Congrats on getting it to work smoothly.

    I unfortunately have the Midisport 4x4 usb midi device and get the Conexant error as well. I\'m running barebones WinXP with nothing but Gigastudio.

    Interestingly enough, I can run fine as long as I don\'t touch the midi settings. As soon as I change a midi port (for example, if I need to use the VOTA Utility), I get the conexant error in about 20 minutes every time. Once I get this error, I have to reboot, run in diagnostic-mode, then it runs fine again, until the next midi setting change.

    If I reboot and don\'t run diagnostic mode, it instantly crashes again, so apparently diagnostic mode must also clear settings.

    My question is: is there anyway to force running in diagnostic mode? like via a command-line argument? If so, I could just force diag-mode to clear settings everytime I need to change midi settings, instead of crash-reboot.

Go Back to forum

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts