• Register
  • Help
Results 1 to 7 of 7

Topic: frustratingly slow loading time of GPO into Logic Pro

Share/Bookmark
  1. #1

    frustratingly slow loading time of GPO into Logic Pro

    Hi all,
    I have a Powermac G5 dual 2 Ghz machine with 1 Gig of Ram running the latest version of Panther, Logic Pro 6.4, and the most recent update of GPO. I've set up an entire orchestra in Logic inserting multiple instances of GPO's bundled Kontakt player. The problem I have is in the excruciatingly slow loading times every time I launch Logic. Is this normal and if not, has the problem been addressed by Native Instruments? (I know it's been mentioned before, but I couldn't find any posts indicating that there has yet been a solution found).

    Also annoying is the fact that when I want to switch back and forth between an open Logic song that DOESN'T require GPO and one that does (for example, to copy certain midi parameters from one file to another), the GPO sounds are VERY SLOWLY re-loaded each time I switch back to the GPO song, even if just for a moment. I also (naively) assumed that I could have two GPO orchestra songs set up simultaneously, and that the sounds wouldn't have to be re-loaded for both songs, since they were accessing the same patches, but I now presume this also to be incorrect? Thanks for any insight!
    - robjohn

  2. #2

    Re: frustratingly slow loading time of GPO into Logic Pro

    Do you have GPO's in your Autoload file? If so you might want to save that with a new name to use as a GPO template and make a new Autoload with nothing (instruments and effects) loaded in it, this will speed up your Logic launch time. As for GPO loading slow there are a few things that can cause that.
    How much free space was on the drive when you installed GPO?
    Do you leave you Mac on 24/7? OSX runs best if you leave it on all the time. If you are not able to leave it on all the time you should run the scripts that cron would normally run to keep your system running smooth (see below in "tune up for OSX").

    when was the last time you repaired the disk permissions?
    when was the last time you ran update_prebinding?


    "Tune up for OSX"
    In this order:

    1) Run repaired the disk permissions.
    2) Open the Terminal application and enter:

    sudo /etc/daily

    It will ask for your password. Now wait (it will take a min or so) while it does it's thing.

    Now enter:

    sudo /etc/weekly

    this will take a little longer.

    When it is done enter:

    sudo /etc/monthly

    this one is fast.

    Now enter:

    sudo update_prebinding -root /

    if this is the first time you are running update_prebinding it can take a while, this is the command that gets run when you install Apple software at the end of the install you see "optimizing system" it is pre binding the application to the libraries that it uses.

    You do not have to run update_prebinding often, once every 2 or 3 months or after you install a new program.

    I hope this helps some.


    Aaron
    Aaron Clark, C/C++, J2EE, Flash, Perl and PHP programming.
    Logic Pro 7.0.1, G5 1800x2, 3 Gig ram, GPO and GOS lite.
    My site: http://www.clarkaudio.com
    Where I work now: http://www.blinex.com/

  3. #3

    Re: frustratingly slow loading time of GPO into Logic Pro

    Thanks for the suggestions. I repaired disk permissions and ran pre-binding as per your suggestions but unfortunately it didn't seem to have an appreciable effect on load times. It feels likes a problem somehow inherent in GPO/Kontakt - surely it shouldn't take so long for GPO files to be loaded into the Kontakt player's RAM each time?
    And is there any way around the auto-reloading of GPO files each time I (for ex.) use Expose to go to another Logic song file not using GPO that is already open, and then come back to the Logic song file with GPO right afterwards? It makes it impossible to easily switch back and forth between 2 open Logic song files without enduring an absurd wait. Thanks -
    - robjohn

  4. #4

    Re: frustratingly slow loading time of GPO into Logic Pro

    moved up...

  5. #5

    Re: frustratingly slow loading time of GPO into Logic Pro

    Quote Originally Posted by robjohn
    moved up...

    moved up?

    I didn't understand this response, thought maybe you have found a way to increase speed in loading patches of GPO in Logic. It is frustrating, esp if you've got two programs open at once.

  6. #6

    Re: frustratingly slow loading time of GPO into Logic Pro

    er...I was just moving the message up on the board by posting the message "moving up" (much like I just did with THIS message!) Ok I'll stop..:-)
    - robjohn

    Quote Originally Posted by sam ward
    moved up?

    I didn't understand this response, thought maybe you have found a way to increase speed in loading patches of GPO in Logic. It is frustrating, esp if you've got two programs open at once.

  7. #7
    Senior Member
    Join Date
    Mar 2004
    Location
    Hamburg, Germany
    Posts
    175

    Re: frustratingly slow loading time of GPO into Logic Pro

    Hey,

    I noticed the same effect in cubase sx. Sometimes I forget to close a project and open a gpo project. When I switch between the two, it seems to free all used memory (?) of the project I came from, loading everything new from the project I am changing to. I noticed this behaviour with other plugins too. Maybe this is some kind of "automatic memory managment" in VSTi's?

    Malte

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •