• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Topic: Finally got Sibelius & GPO to work

  1. #1

    Talking Finally got Sibelius & GPO to work

    First off, thank you to all that have helped me in my efforts to get Sibelius and GPO to work together. After a lot of experimenting, I finally got it to work. For those that are experiencing trouble, try this:

    1) Open GPO Studio

    2) Open Sibelius and disable Kontakt Silver, enable GPO Player 1

    3) Close Sibelius

    4) Close GPO Studio

    5) Open Sibelius and start/open project

    6) Open GPO Studio and select instruments.


    This may appear confusing as many have said that you need to open GPO Studio BEFORE opening Sibelius, and that was true for me only when setting up the playback parameters. I tried it 'backwards' and it now works.

    Now I can enter that worst demo contest!

  2. #2

    Re: Finally got Sibelius & GPO to work


    Glad you got to the top of the mountain. What is your computer and set-up? I tried GPO for the first time tonight and used your procedure, but since I haven't tried it any other way, I don't know if it would have worked or not.

    Anyway, I got some great sounds. I loaded GPO 1 with a Flute, Clarinet, Bassoon, Violins lush, Viola lush, Cello lush and Bass pizzicato. That's only seven of the eight Kontakt slots available.

    Settings used for a "New" score in Sibelius were 44,100 and 512. I am using a Mac 15" (new) G4 laptop with a 1.5Ghz CPU and !G of RAM. After scoring the flute, clarinet, bassoon, and violins lush for 4 measures, my CPU usage was around 44.6% and I was getting some "clicks."

    My main problem was this: In the Mixer extended window I saw GPO 1 listed as the device, but the instrument listed in the mixer window was from the General MIDI bank. I thought it should list the GPO instruments, but clicking on the name box, I got the GM sound list.

    I read the GPO help a little and it said that in the "Play" Device dialog that you should answer "Yes" to GPO usage. I never found a column in that dialog that you could answer "yes" to. It has the device name (GPO, no problem), the second column where you select the sound modules and GPO wasn't listed there, then the latency column and the last column I fogot at the moment. Anyway, I saw no place in this dialog where I could answer "yes" as outlined in the help panel.

    Therefore, I guess my first attempt was a failure with Sibelius. I did remember to raise the MOD WHEEL (although I didn't select it in the Settings menu) and the volume did raise.

    I want to use GPO with a sequencer so after using Logic for 12 years, and seeing on this list that it was a nightmare, I purchased Digital Performer 4.12. It is taking a little time to get used to that beast so I haven't used it yet with GPO. I also used Finale for years--in fact all of my symphonic scores were created with Finale for the last 10 years, but it is a nightmare also when it comes to wanting to edit a score for playback. I feel you just have to have a sequencer.

    Since I didn't get much done with Sibelius, I couldn't try out the ~C1 mod wheel feature. I guess my problem is that I am so eager to use GPO that I am kind running in circles to get a vehicle that I will be comfortable with.

    If you use a PC, than I guess we are in different ball parks. Enjoyed reading about your success though with Sibelius.

    John Cannon

  3. #3

    Re: Finally got Sibelius & GPO to work

    I am happy to see other folks using Sibelius. Most of the forum seems to be sequencer oriented...:-)

    @John I am a PC guy, but I hope this few tricks can help you as well.I did a lot of running in circles too!!!, but now the baby is working like a charm.

    Did you do a "find new devices" in in the Play/Devices/ window? You should have all 8 GPO players listed. It is a mess to understand, but Kontakt silver is not the same as the kontakt player from Gary.

    For some reason, when I open GPO Studio, I have to go to settings and select "ignore modwheel", wait a few seconds and then go back to "default" again. Otherwise, you have to manually configure every instrument.

    Now...what really changed my life was the use a fabulous plug in called "GPO cresc and dim playback" and "GPO legato" made by Victor Etxebarria. It is amazing how my scores started to come to life! All the sudden, the possibilities are almost endless. Be sure that when you open the plug in, you select "process every hairpin in the selected page" and "use C1 modulation wheel instead of C7 volume".

    Before you start playing around with your scores, I advice you to work in two different copies, because whatever you write with the plugin is not undoable with control Z. Lets say you try a cresc from PP (28) to F (76) and you don't like it, you go back to the "graphical" score, copy paste and start over again.

    I don't know if I was helpful at all. Hope you can enjoy your scores soon!



    PC P IV 3.0 Gz
    1.5 GB RAM
    Windows XP
    Audiophile 2496

  4. #4

    Re: Finally got Sibelius & GPO to work


    Thanks for the new tips for volume and legato when using Sibelius. Are you using the upgraded Kontakt Player (V 1.0.2) or the one that came with GPO?

    I am trying to get GPO to work with Digital Performer (on my Mac laptop), because I want to input the CC1 volume with the Mod Wheel as I play. That's something you can't do in Sibelius, although your set-up seems to work great for you.

    Thanks again for your input.


  5. #5

    Re: Finally got Sibelius & GPO to work


    Let me know if you need any help getting GPO to run with DP, I do a lot of it.


  6. #6

    Re: Finally got Sibelius & GPO to work

    @ JMCannon: I did upgrade to Studio 1.2. It still has some bugs it seems, but we all know it is still a beta version. Funny things happen, for instance, when I record and the piece is finished, I get a cymbal crash when switching back to GPO Studio! :-D Go figure...

    Sibelius crashes when I want to change instruments in GPO Studio as well. I need to save the piece, close Sibelius and then make then changes, and even then some times it doesn't work. I really would like to know if I am the only one experiencing it, because the second problem is more serious.

  7. #7

    Re: Finally got Sibelius & GPO to work

    Funny you mention that. I had the same problem for a while. I got around it by minimizing the application I was using first. If you minimize Sibelius, then maximize GPO, make your changes, minimize GPO, then maximize Sibelius, I bet your problem will go away too. I have no explanation for why this works.

  8. #8

    Re: Finally got Sibelius & GPO to work

    I just bought Sibelius. Looking forward to using it with GPO. Any times that folks have about using its specific features with GPO would be welcome. For example, how to use Expresivo given that GPO doesn't use the standard note velocity for dynamics, etc..
    "Music is a manifestation of the human spirit similar to a language. If we do not want such things to remain dead treasures, we must do our utmost to make the greatest number of people understand their secrets" -- Zoltan Kodaly

  9. #9

    Unhappy Re: Finally got Sibelius & GPO to work

    @Mark: Tried that! It went for a while, but then stopped working as well. Annoying thing is that when I try to reopen, Sibelius asks me after 30 seconds if I want to run another copy. When I do, I can no longer play anything with my keyboard so I have to start all over again (GPO included).

    Sounds like I should reinstall everything or wait for the release of the official version.


  10. #10
    Join Date
    Oct 2000
    Orcas Island

    Re: Finally got Sibelius & GPO to work

    Quote Originally Posted by Rodolfo
    Funny things happen, for instance, when I record and the piece is finished, I get a cymbal crash when switching back to GPO Studio! :-D Go figure...
    Intelligent programming provides a cymbal crash to warn you of an impending crash. Did you also encounter the drum roll?

    Seriously, this is very strange behavior and one that has not been reported. Can you call or email me. I will get in touch with the Sibelius tech people and the GPO Studio designers and see what the problem is.

    Gary Garritan

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts