• Register
  • Help
Results 1 to 9 of 9

Topic: OT no midi sound

Share/Bookmark
  1. #1

    Question OT no midi sound

    Sorry I'd post this else where on the forums but with all the political discussions over there I'll never get an answer to this. I can not get any form of midi file to play on either of my 2 comp systems, one uses M Audio audiophile and the other uses Echo mia midi. I've tried using media players like real player, and I also tried playing them in Sonar. At least in sonar it shows the file being played, as in length even will show notation, but no sound, if I use any other media type player I can not even get it to play. All other sounds work fine in dvd, from web pages, cd's etc, just no midi...any ideas?



    PS if anyone has a degree in recording technology or music technology maybe you can take a look to my post in the general forums and add some feedback thanks!!!

  2. #2
    Senior Member
    Join Date
    Aug 2001
    Location
    www.wisemanproject.com
    Posts
    398

    Wink Re: OT no midi sound

    Audiophile is audio card, that has entrance and exit of the audio info. MIDI data is not audio data. Therefore you can't get any sounds if you connect it directly. You need to have some sound generator that read midi data and make sounds. Traditionaly, that job is for sound module and synthsizer, current trend is moving to software sampler and synth. Usual PC has cheap synth, so use it, if you need. Go to control panel - sound.

    It is like you want to read English text file without having any English font. But, you have PC, PC monitor and Word.
    Kentaro Sato (Ken-P)
    Composer/Conductor/Orchestrator
    www.wisemanproject.com

  3. #3

    Re: OT no midi sound

    Yeah, there should be a generic GM module installed. It is default in Windows and is independent of your sound card. It aint great, but that's all there is. Also, Quicktime has a built in GM synth engine, but I can't say that it's any better. Look at the sound option in your control panel and make sure that the Microsoft Wave Table GM Synth is installed. You may need to select it as the default GM out.

  4. #4

    Re: OT no midi sound

    Quote Originally Posted by žETH
    ...and I also tried playing them in Sonar. At least in sonar it shows the file being played, as in length even will show notation, but no sound, ...
    To get MIDI working in Sonar, check the second tutorial in the manual, beginning on page 58. If you are working with softsynths/samplers only, start reading on page 375.

    Yeah, it's a pain to have to read through it all, but it's well worth it.

    R.
    ==

  5. #5

    Re: OT no midi sound

    Thanks guys! I'll try looking for my sonar manual... Maybe it's a simple fix, so I'll ask, and if it's complicated I'll dig in my manuals some more. but in years past I used my synth keyboard with built in floppy drive, and I would layer my midi tracks on top of each other on the keyboard. I have several midi composistions saved, and reccently I got gigastudio and sonar. I would like to redo these songs using the samples instead of midi files. How ever, I am clueless on how to do this. I have 2 computers, and if I need to move stuff around to do it I can, but I have giga on one comp, and all my samples on giga comp on a different drive, but Sonar I put on a seperate comp. how do I get these 2 to talk to one another. Or is there a way to play midi files in giga? Thank you again

    Seth

  6. #6
    Senior Member
    Join Date
    Nov 2002
    Location
    Cannibal Island, Loleta, California
    Posts
    171

    Re: OT no midi sound

    Have you checked in control panel/sounds & audio devices to see what is set to play back midi? Seems like the solution to get your media players making midi sounds would be there.
    When I started using an Audiophile I was getting midi playback fine from winamp etc., but no GM sounds in Sonar. The only midi output option I had in Sonar was something like 'Microsoft Midi Mapper', which didn't make any sound. Eventually, I found out that if I use the ASIO drivers instead of WDM then 'MS GM Wavetable Synth' becomes available as a midi out choice, and it works fine.
    Maybe I'm missing something, but I never could get regular midi playback in Sonar with the WDM driver.

  7. #7

    Re: OT no midi sound

    [QUOTE=Ken-P] Usual PC has cheap synth, so use it, if you need. Go to control panel - sound.

    This did give me a quick fix, now just need to learn how to trigger samples for midi tracks.

  8. #8
    Senior Member
    Join Date
    Nov 2002
    Location
    Cannibal Island, Loleta, California
    Posts
    171

    Re: OT no midi sound

    Well, I'm no expert... but since I'm using an Audiophile + Sonar also, I can try to help you out. If you want you can pm me. What sampler are you using?

  9. #9

    Re: OT no midi sound

    Sonar actually comes with an Edirol Virtual Sound Canvas DXI. An easy solution would be to use that DXI as your temporary midi playback device in sonar. It might not sound awesome but it will at least give you a starting place. Then you can change the routing from the virtual sound canvas to giga.

    I hope this helps.
    Last edited by Al E. Cat; 07-15-2004 at 06:25 PM. Reason: fixed syntax :)

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •