• Register
  • Help
Results 1 to 7 of 7

Topic: IRQ sharing problem? ...(kinda OT)

Share/Bookmark
  1. #1
    Senior Member Gary M. Thomas's Avatar
    Join Date
    Nov 2002
    Location
    Myrtle Beach, SC (USA)
    Posts
    522

    Question IRQ sharing problem? ...(kinda OT)

    Sorry that this is kinda OT.... but I thought, since this is the most popular forum, more of ya'll would read this post and might be able to help me out. Thanks in advance.

    I seem to be having a problem with my PC "sharing" IRQ (interrupt requests).... as is the case in Windows XP. Is there anyway to manually set the IRQs so that there will be NO sharing?

    Also, does it involve re-installing Windows XP... and, if so, what settings should be changed at the time of re-install? Any help is appreciated very much. Sorry again for the somewhat "off-topic" post.......... Gary

  2. #2

    Re: IRQ sharing problem? ...(kinda OT)

    I thought this was a non-issue now? Yes you can prevent IRQ sharing, and it does require a reinstall of XP. Last time I tired the ACPI setup (non IRQ sharing), I had nothing but problems. CD burners would not burn, etc.

  3. #3

    Re: IRQ sharing problem? ...(kinda OT)

    Tips to prevent conflicts...

    Do not share slots with AGP cards. I mean, if you have an AGP card installed for video, do not put a PCI card in the first PCI slot (since these are typically shared with the AGP card.) Especially if the card is an audio card.

    Swap the cards around if you are getting IRQ conflicts.

    Next, turn off IRQ's in your bios that you aren't using. I had like 4 or 5 IRQ's in my bios being reserved for equipment I don't use (on board soundcard, the 8,000 USB ports, printer ports, etc.)

  4. #4

    Re: IRQ sharing problem? ...(kinda OT)

    Ok, from what i know with 2000 & XP IRQ 'sharing' is the norm and shouldnt cause you any trouble whatsoever. However when a video card & a sound card share the same resource, things can get a little troublesome at times.

    To be able to change IRQs you need to disable ACPI which is usually chosen during installation of the OS. However if you look here:



    You can right-click that ACPI computer, Update Drive and choose 'Standard PC' from the list and you *should* achieve the same result. I was going to do this myself, but i feared it might screw up my hyperthreading.

    You might want to backup first before you try it.
    Last edited by lumpyhed; 08-09-2004 at 10:00 AM. Reason: darn acryonms!

  5. #5

    Re: IRQ sharing problem? ...(kinda OT)

    What sort of negatives are we talking? Reduced polyphony in samplers and VSTis? Stability issues?

  6. #6

    Re: IRQ sharing problem? ...(kinda OT)

    Quote Originally Posted by Lee Blaske
    It's advised to not using hyperthreading with a number of audio applications.

    Also, I don't think disabling ACPI is that simple. It's best to choose whether or not to use ACPI when you format your HD and install windows. There is a somewhat risky procedure to disable ACPI (I believe I found it on Tweaker's Asylum). I had success with it on one of my machines, but I had to re-install all my drivers, so it was kind of a PITA.

    Lee Blaske
    Yes, disabling ACPI IS that simple. Yes, it is a PITA when it redetects all your drivers again. Doing this helped to reduce pops with my UAD1 card with my Maxtrox G450 (which is a known issue. Swapped in a new video card, problem went away) but otherwise, this has mostly become unnecessary to do the IRQ shuffle.

    Devon

  7. #7
    Senior Member Gary M. Thomas's Avatar
    Join Date
    Nov 2002
    Location
    Myrtle Beach, SC (USA)
    Posts
    522

    Smile Re: IRQ sharing problem? ...(kinda OT)

    Okay, I appreciate all the responses. I will give these suggestions a try and see how it works out. Thanks again............ Gary

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •