• Register
  • Help
Results 1 to 6 of 6

Topic: MidiOverLAN+ problem

Share/Bookmark
  1. #1

    MidiOverLAN+ problem

    I'm trying to setup my new three computer system and I'm hitting a snag with MidiOverLAN+ 1.1.

    The setup is simply 1 master computer sending MIDI to 2 Gigastudio computers. I've checked and rechecked the settings in all three's MOL settings and everything looks good.

    The master computer is setup as follows:

    LAN-Out 00 - GigaPC1 Port 1
    LAN-Out 01 - GigaPC1 Port 2
    LAN-Out 02 - GigaPC1 Port 3
    LAN-Out 03 - GigaPC1 Port 4
    LAN-Out 04 - GigaPC2 Port 1
    LAN-Out 05 - GigaPC2 Port 2
    LAN-Out 06 - GigaPC2 Port 3
    LAN-Out 07 - GigaPC2 Port 4

    The GigaPC1 is setup as follows

    LAN-In 00 - GigaPC1 Port 1
    LAN-In 01 - GigaPC1 Port 2
    LAN-In 02 - GigaPC1 Port 3
    LAN-In 03 - GigaPC1 Port 4

    The GigaPC2 is setup as follows:

    LAN-In 04 - GigaPC2 Port 1
    LAN-In 05 - GigaPC2 Port 2
    LAN-In 06 - GigaPC2 Port 3
    LAN-In 07 - GigaPC2 Port 4

    Simple enough. The problem is only GigaPC2 recieves any MIDI information. The GigaPC1 does nothing both alone or in combination with GigaPC2. The network is setup correctly and the LAN cables and Gigabit Switch are all brand new and working. Gigastudio is also configured correctly by all appearances so I'm at a loss for what to try next.

    Any help would be appreciated. Thank you!

  2. #2

    Re: MidiOverLAN+ problem

    i've noticed that sometimes the drivers don't *hang themselves* into the system properly if you don't restart windows after installing. i'd recommend uninstall MoL (from system - settings - software) -> restart -> re-install -> restart. now probably your settings appear again and you can check if midi arrives on the midi-from-lan tab. if not, repeat editing your settings and restart again. that's what helped here at least.
    christian

  3. #3

    Re: MidiOverLAN+ problem

    Did you check the "Assign correspondent device number" box and enter corresponding numbers for all of your ins and outs? e.g. Lan-Out-00 and Lan-In-00 should have this set to 0 and the box checked, Lan-Out-01 and Lan-In-01 would be set to 1, etc.

    Also, if you are using MOL with WinXP Pro, you may have problems with Remote Desktop - don't use it to start Gigastudio; start it from the satellite machine, then log in from your primary machine using Remote Desktop. Otherwise, the MOL ports won't show up in the Settings page of Gigastudio. Check to see if the ports are enabled in the Settings/Hardware Routing section of Gigastudio.

    Good luck!

  4. #4

    Re: MidiOverLAN+ problem

    Thanks for the helpful advice. I'll give these things a whirl tomorrow and see if they do the trick.

  5. #5

    Re: MidiOverLAN+ problem

    I've had the best luck setting all of the PCs with fixed IP addresses, and then setting these in MOL. If you use computer names, you're asking for trouble. The computer with DNS must be running first to get it to work - if not, reboot everything.

    Also, I remember that there is a bug in entering the IP numbers. You may need to do a bunch of reboots to get it all perfect. Once you get it working with fixed IPs, you're golden.

    -JF

  6. #6

    Re: MidiOverLAN+ problem

    Quote Originally Posted by stevefu
    Also, if you are using MOL with WinXP Pro, you may have problems with Remote Desktop - don't use it to start Gigastudio; start it from the satellite machine, then log in from your primary machine using Remote Desktop. Otherwise, the MOL ports won't show up in the Settings page of Gigastudio.
    Eh...strange!? I'm using RD to control my three Giga computers (I don't even have them hooked up to my KVM switch anymore...) and I can see the MoL+ ports in Giga on all of them.

    /Mattias

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •