• Register
  • Help
Results 1 to 5 of 5

Topic: Problem recording 24 bit in Sonar

  1. #1

    Problem recording 24 bit in Sonar

    I'm using an Audiophile 24/96 with Sonar 3. I'm able to set the default audio type to 24bit but when I set the driver bit depth to 24 and hit the record button, it sits there for a moment and then gives me the "Audio stopped" message. If I set the audio driver to 16 bit it works fine. So the question is, does it matter?

    1. If the driver bit depth is 16 but the "Default settings for new projects File bit depth" is 24, what is it actually recording, 24 or 16?

    2. When I play what was recorded, what bit depth am I hearing played back? Does the setting matter in that case?

    A seperate question...what happens when you play a 24 bit file in media player but your card is just an old SBLive that doesn't have 24 bit capability? Is it still playing back as 24 bit or is it converting it to 16 as it plays?
    Westgate Studios
    Sound Libraries for Gigastudio and Kontakt

  2. #2

    Re: Problem recording 24 bit in Sonar

    Before anyone asks, yes, I set the 24 bit enable setttings in the AUD.INI file.

    I also have reprofiled my card after making the new setting. Here are some additional things I've noticed.

    1. If the track output is set to none it won't record. Not sure why, but I can live with that one.

    2. (I'm currently using the default drivers which I believe are the WDM drivers since if I specifically choose WDM it does the same thing.)
    When choosing 24 bit driver depth and arming for Record with WDM, the input level shoots all the way to the top, luckily my monitors were off, otherwise I may be dead now. Either there is a feedback loop somewhere or Sonar is confused about the incoming signal, since all of my inputs are turned down and there is nothing plugged into my inputs.

    3. If I use the ASIO drivers instead, I can record and the signal level seems correct. However, the driver bit depth reads 24 but is "grayed out" which makes me wonder if it's really operating at 24 bit or it's just displaying the last thing that was there

    4. Using the MME drivers I can't even set to 24 bit.

    So are the ASIO drivers the way to go? Should I not be concerned that the bit depth can't be changed and that if it says 24 it really is 24?
    Westgate Studios
    Sound Libraries for Gigastudio and Kontakt

  3. #3
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: Problem recording 24 bit in Sonar

    1. You must set an input and output.

    2. You definitely have a feedback loop. Check your soundcard app to see if monitoring is turned on.

    3. Don't have this soundcard so I'm not sure about the ASIO.

    4. Definitely don't use MME.

    You may need to raise your buffer settings in Sonar. I'm at work now so I'm not sure what some of the settings are. There is one that is normally set to 2 when in 16 bits, it needs to be changed to 3 for 24 bits.

  4. #4

    Problem recording 24 bit in Sonar

    1. If you want 24 bit, make sure both Audio driver bit depth and file bit depth are set to 24 bit.

    2. Go to Options, Audio, and Drivers tab. Make sure your SBLive card is not selected. You don't want Sonar to even think it exists. If it's highlighted as one of the drivers, that's probably why Sonar keeps resetting to a 16 bit resolution. I don't have your Audiophilie card either, but I would work with WDM drivers if possible.

    3. Go to http://www.cakewalk.com/forum/ and look around too.


  5. #5

    Re: Problem recording 24 bit in Sonar

    I would agree that there's a feedback loop except that I'm only seeing the level peak in 24 bit mode. Switching to 16 with the exact same setup yields normal levels.

    Changing the buffers in the playback queue from 2 to 3 would seem to only effect performance once you had some audio recorded.
    Westgate Studios
    Sound Libraries for Gigastudio and Kontakt

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts