• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Topic: GS3 won't load my piano's properly

  1. #1

    GS3 won't load my piano's properly

    Upon loading my piano libraries, ALL notes above D5 (on the GS3 keyboard) play sustained no matter how briefly I hold a key down.

  2. #2

    Re: GS3 won't load my piano's properly

    Hmmm. That should be true for only notes above G6 or so. (The real pianos that I've played don't damp the topmost strings.) D5 is way too low.

    Tell us more about your system.


  3. #3

    Re: GS3 won't load my piano's properly

    My set up is a single PC for both Cubase and GS3, AMD 3Ghz, 1.5 Gb of RAM, ESI Wamirack.

    The sustained notes above D5 is with my Malsmjo and Studio 88.

    GigaPiano 2 behaves a little more strangely. Sustained notes always above G5.
    D1 and E1 have been additionally mapped to E7 and F7 respectively.

  4. #4

    Re: GS3 won't load my piano's properly


    In a right mapping the last key of a keyboard is the C8.

    In a real piano all keys F#6 or G6 to C8(last key) (or in another mapping F#5/g5 to C7) play sustained. And you need to have another mapping for these keys.

    But you say D5 - it's strange (It's D6 ?, D7 ?)

    give us more informations.



  5. #5

    Re: GS3 won't load my piano's properly


    Thanks for your help and observations guys.

    The references to notes I'm giving are as they appear on the GS3 virtual keyboard (they appear in tiny writing under the keyboards) .... so these may not equate to standard musical naming conventions.

    Can you see them on your version ?

    I guess the main problem is that above C5 (again the GS3 C5) the notes just ringing ... there is no damping when the key is released.

    I note your observations about notes above a certain range always play sustained on a real piano .... but I don't recall this behaviour with my Malsjmo is GS2.5.

    Can someone confirm whether the higher notes are damped for a Maljsmo in GS2.5 ?

    Has anyone else experienced this at all ????

    I notice also on the Malsjmo, when I go into the quick edit waveforms only appear in the waveform window on the keys with the sustain problem. Possibly linked.

    I tried re-loading the samples.
    I have tried re-booting the computer.

    I might try re-installing GS3 next.

  6. #6

    Re: GS3 won't load my piano's properly

    STOP! Don't re-install GST3 without a good reaaon.
    If the software launches then it works. If a problem occurs during program boot-up the software will not launch at all and a diagnostic run will be advised. If the diagnostic report shows real problems (TASCAM tech support can help you with this) you should be able to solve issues without re-installation.
    I think you may have to re-install the piano first. If the quick editor does not show wave files for the keys the instrument gig file may have become corrupted. Re-installing the piano library should fix that.
    Best regards,
    Michiel Post

  7. #7

    Re: GS3 won't load my piano's properly

    Opening the piano in the Giga Editor could show if the instrument has unassigned regions.
    Best regards,
    Michiel Post

  8. #8

    Re: GS3 won't load my piano's properly

    Okay ... thanks Michael I won't re-install.

    The problem is occuring on all my piano libraries (Art Vista, Studio Grand 88, and to a certain degree on the new GigaPiano libs). I haven't tried it on your demo libs yet though.

    But from your experience ... should the higher notes ring sustained after the paino key has been released ? Is the correct term "damped" after key release ?
    Some of the earlier posts suggest real pianos do not damp the higher keys after key release.

    What is your opinion ?

    Thank you

  9. #9

    Re: GS3 won't load my piano's properly

    All real grand pianos have sustained notes after the key is released above G6 (up to C8). Some libraries don't have this programmed...
    Best regards,
    Michiel Post

  10. #10

    Re: GS3 won't load my piano's properly

    As a precaution, try resetting the WamiRack Console after launching GS but BEFORE launching your sequencer. I don't have GS3 - waiting for FedEx :-) , but with GS 2.5, sometimes I need to reset the WamiRack because everything is an Octave off! Just a thought.

    Good Luck!


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts