• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Topic: GS3 Bugs?

Share/Bookmark
  1. #1

    GS3 Bugs?

    I was all primed and ready to upgrade to GS3, but have been told by three pretty "major players" (names familar to this board) that I should hold off, because GS3 is still pretty buggy.

    Could I ask those of you that have GS3 whatcha' think? Have you had problems, and are they big or little ones?

    Thanks!

    John Keltonic
    JDK Music

  2. #2

    Re: GS3 Bugs?

    The bottom line: you can make music reliably with GS3. Here are the problems that I've experienced or read about:

    * Basic installation is no problem

    * Getting MIDI in and sound out is problematic for some but smooth sailing for most. Honestly, I think it may have a better record than 2.5 in this regard.
    ---> RME users need to apply a tweak to get it to work
    ---> One guy with a highly optimized PC had problems. He went to a clean Windows install and the latest drivers and it came alive. I think he had to hit the reset button in GS3 to get audio.
    ---> Some have had success with W2k but not all. It's not officially supported.

    * Registration can be a pain, but there's a 10-day grace period. If you run GigaClean you lose the grace deal. If you have a major crash, you may also lose it. To play it safe install it Monday morning, get it registered and save the reg info. Don't wait for Friday night.

    * Playing music works fine. Here are some minor exceptions:
    ---> If you push GigaPulse to the wall you get pops, click and dropouts. Push it further and you may get a crash. I did, but I had a RAM problem at the time. I haven't pushed it too hard since, and it hasn't crashed or popped. I lquickly learned my machine's limits.
    ---> I got some errors when loading up RAM to high levels. I updated my BIOS and the motherboard now refuses one of my RAM sticks (from a different manufacturer than the other two), so I have 1 GB rather than the previous 1.5. After the BIOS upgrade and dumping the bad RAM, I can load up to 90% reliably. Main point: this was my hardware problem, not a Giga problem.
    ---> At 92% Giga locked up once. Oh well. I keep it under 90% and I haven't had a lock up since.
    ---> Some have had crash problems that were solved by getting the latest drivers. Good video drivers are key.

    So there it is. I think the most serious operational bug I've seen is that the "% loaded" indicator in the quicksound navigator is not always updated properly after instruments are unloaded. It's as minor as could be. I haven't dug into the editor. There may or may not be problems there.

    Like I said, the bottom line is that this thing can make music. Few people have had problems, and almost all of those that I've read about have been solved or worked-around - even the RME thing. To play it really safe, make a ghost drive of your system, or do a clean install of WinXP SP1 on a fresh hard drive. Install GS3 on that. If you have problems, you can go back to the old hard drive and use 2.5 until you have time to sort things out. It's not really necessary, but if you're in the middle of a big project, it could save your bacon. But that's true with any big software change in the middle of a project. It's not about avoiding risk, it's about managing it.

    Best of luck whatever you decide. I'm really glad I upgraded.

    -JF

  3. #3
    Senior Member Bruce A. Richardson's Avatar
    Join Date
    Sep 1999
    Location
    Dallas, Texas
    Posts
    5,755

    Re: GS3 Bugs?

    Man, I sure would not go back. Not for a second. There are just too many plusses.

    If you know you're going to want to upgrade eventually, I'd go for it. You can always uninstall and reinstall your 2.5 rig. If everything goes well for you, though, I am quite certain you'll never look back.

    I'm not a big media name, but I did complete a film for Sundance in Giga 3, am doing two scores for plays, and am in the middle of a 26-episode series--and starting another film in January. I think that qualifies as a heavy hitting work load...even if I ain't a major player. It's about as major as I can handle!! And I'm getting it done using Giga 3 every single day.

    Hans Zimmer converted his entire operation to Giga 3 halfway through the beta.

    So, people who are doing quite a bit of work are having good luck, too. It all depends upon your individual situation and machine, I guess...and whether you have a spare day or so to ensure you'll be ready to go to work no matter what happens (if, luck lacking, you need to reinstall 2.x).

    Just be sure to have all your registration codes, etc., for 2.5 written down in advance...or obtain them from Tascam Tech Support before you jump in. That way, you've got guaranteed smooth sailing, no matter what.

  4. #4

    Re: GS3 Bugs?

    I recieved GS3 yesterday afternoon, and other from a slight registration problem (which was my fault for overlooking the CD-Key in my email) it has been smooth sailing.

    I have been working on programming the GS3 version of my bass lib over the last couple of hours and it is extremely easy and flexible IMHO...

    Not sure it will convince me to switch from Kontakt - cause I really like Kontatk - but I can tell you that GS3 has been flawless on my machine... even while editing and building instruments - along with testing out all the included VSL stuff.

    I, for one, amd very surprised... I thought it would be a two day job to get it running smothly - but - I haven't a single complaint - yet.
    Alan Lastufka | www.BelaDMedia.com
    Producer/Artistic Design | Content Producer

    20 Things

  5. #5

    Re: GS3 Bugs?

    My main issue is rewire isn't working and alot of people are having problems with it. There's a large thread about it in the Giga forum.

  6. #6

    Re: GS3 Bugs?

    Quote Originally Posted by nt
    My main issue is rewire isn't working and alot of people are having problems with it. There's a large thread about it in the Giga forum.
    I am using nothing but ReWire into SX 2 - no GSIF card on this machine. Everything appears cool here - but I am not really "pushing" it either, mostly just 8-10 instruments running into a stereo output bus.
    Alan Lastufka | www.BelaDMedia.com
    Producer/Artistic Design | Content Producer

    20 Things

  7. #7

    Re: GS3 Bugs?

    Alan thank you for the informaion. Please post at http://www.northernsounds.com/forum/...ad.php?t=24609 as you may be the first SX user to report a working situation.

    The problem seems to be affecting RME and Echo soundcard users, if it's not a Giga 3 bug. No one seems to know what's causing it yet...

  8. #8

    Re: GS3 Bugs?

    Quote Originally Posted by nt
    ...The problem seems to be affecting RME and Echo soundcard users, if it's not a Giga 3 bug...
    I'm running the Echo MIA with the latest (6.08) driver. No problems - after updating my BIOS and moving the odd-man-out RAM stick into my wife's PC.

    -JF

  9. #9

    Re: GS3 Bugs?

    Quote Originally Posted by nt
    Alan thank you for the informaion. Please post at http://www.northernsounds.com/forum/...ad.php?t=24609 as you may be the first SX user to report a working situation...
    I was curious that you guys were having so much trouble, so I went and read thru the thread - then went back to SX and Giga to Export and.......

    ...sure enough, my smile has been turned upside down. I am having the EXACT same problems as all of you, anyone who wants to hear can add me to their MSN and I will IM the mp3 to them - I don't have FTP software on this machine. My MSN is cubase_sx_user@hotmail.com (AOL IM is LastLibs)

    Sorry guys... I just hadn't the need to export anything until now, been busy with rebuilding the bass lib - and everything was going so well too - for the Tascam folks - here are the specs on my Giga/SX2 comp:

    Pentium 4 2.4GHz w/ 533 FSB
    768MB of RDRAM PC1066 @ 533MHz

    Giga and SX are on the C: drive while samples are on the D:
    Alan Lastufka | www.BelaDMedia.com
    Producer/Artistic Design | Content Producer

    20 Things

  10. #10

    Re: GS3 Bugs?

    I was wondering if anyone has tried running GS3 with Max's GIGA VST Adapter?

    Particularly if they are teleporting from another machine?

    Thanks,
    ---------------------------
    - SCA - Sound Studios -
    www.sca-soundstudios.com
    ---------------------------

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •