• Register
  • Help
Results 1 to 8 of 8

Topic: midi feels a little off ?

Share/Bookmark
  1. #1

    Red face midi feels a little off ?

    HI, I just picked up the orchestral version of giga studio 3 and I have a hammerfall dsp multiface RME set up.while installing gs3 I did run into the overwriting thingy with the registry and Im am now able to use my r-m-e with midi but my question is when I re-wire gigastudio thru nuendo 2 l(atest version) I am able to record a midi even in nuendo but when I play back the midi event gs3 gets alittle off beat then catches up after a bar or so. ANd when gs3 does catch up it feels as if it falling a bit off with the metronome in nuendo. just wondering if anyone other than me ever experienced such a thing?

    my rme drivers are the latest 2.82 hammerfall breakout box dsp multiface
    I have 1 gig of corsiar memory
    an asus a7n8x delux motherboard
    AMD 3000+ cpu
    windows xp home sp1
    1 WD 40gig 7200 rpm for programs
    1 WD 40gig 7200 rpm for just samples

  2. #2

    Re: midi feels a little off ?

    Yes, but only with big projects.

    Amd AthlonXP 3000+
    1 Gig Infineon Pc2700
    DSP 24 StAudio/ESI
    Win XP Pro SP1
    2x WD 120 SE
    1X IBM 30,6
    1x WD Raptor 74
    best regards

    Przemyslaw K.

  3. #3

    Re: midi feels a little off ?

    thank you for your quick reply.. thats interesting that you say only with big projects but in my situation I get this with a new nuendo project and the only thing I would have is gs3 re-wired.and the only midi even is the gs3

    maybe I need to further tweak my machine.. bad enuff I have this machine as the internet computer aswell

  4. #4

    Re: midi feels a little off ?

    Hi,

    I think its a Gs3 issue with rewire, because I have a rock solid midi timing with Propellerheads Reason rewired to Cubase SX2.

    Hopefully there will be an update available soon... not only for bugfixes but for performance as well
    best regards

    Przemyslaw K.

  5. #5

    Re: midi feels a little off ?

    This is an issue that I may be having as well- without rewire. I've been revisiting a solo piano piece in hopes to get a good midi realization with the use of GPulse- I've not been satisfied with the playback of fast-sequential 16th notes in particular.
    There is a real uneveness about the playback- I'm using Finale 04, and with 2.54, the same midi data was played correctly, but since the upgrade I've had problems...
    I'd record it if I could and post the realization of both GS160 and GS3 performances- but at the moment I still can't capture audio.... There is a real difference.
    Jason DeWater aka Lickety-Split
    Very busy, yet always unproductive.
    Some of my music is here:
    http://www.audiostreet.net/jasondewater

  6. #6

    Re: midi feels a little off ?

    Quote Originally Posted by Lickety-Split
    This is an issue that I may be having as well- without rewire. I've been revisiting a solo piano piece in hopes to get a good midi realization with the use of GPulse- I've not been satisfied with the playback of fast-sequential 16th notes in particular.
    There is a real uneveness about the playback- I'm using Finale 04, and with 2.54, the same midi data was played correctly, but since the upgrade I've had problems...
    I'd record it if I could and post the realization of both GS160 and GS3 performances- but at the moment I still can't capture audio.... There is a real difference.
    Hmm,

    in hardware mode I had loaded a project which was a little bit cpu demanding
    I had 2 gigapulse loaded and about 66% of samples loaded.
    It is a OPUS 1 demo I made for VSL and it played correctly.

    Yesterday night I gave up on testing rewire and capture audio. I have a "workaround" which actually i hate, but I have no choice as long as it works.
    I record into my audio interface on another inputs directly into Cubase SX2.
    I only have to check somethink out, because the performance played well but
    after I listened to the recorded audiofile there was a little glitch in the middle of this orchestral piece...like a timing issue maybe? I hope not.
    best regards

    Przemyslaw K.

  7. #7

    Re: midi feels a little off ?

    Lickety Split reports that he solved his timing problem by correting buffer settings in his audio card. Timing is now fine.

    There is a known issue with Cubase/Nuendo and midi timing which may or may not relate to your problem. It has to do with using midi ports which Cubase calls 'emulated'.

    I had a client with completely whacko midi timing the other day and eventually tracked this solution down.

    This may have nothing to do with your problem, but who knows?

    QUOTE: "I found the problem was due to emulated midi drivers. For SX follow instructions below, not shure if the same applies to VST.
    1. Locate your Cubase SX folder, (usually C:\programs\steinberg\cubasesx).

    2. Here you will find a folder named 'MIDI Port Enabler'

    3. Open this folder.

    4.Pick the file "ignoreportfilter" and move it into the Cubase SX / SL application folder (one directory up).

    5.Start Cubase SX / SL

    6. Now all available MIDI ports provided by the MIDI interface driver will appear in the MIDI device list of Cubase SX / SL.

    Please be aware that the MIDI ports now can show up 2 or 3 times in the list. If you're used to manage your MIDI IN by setting "All MIDI Inputs" in the MIDI IN selector, you should go to the Device Setup/All MIDI Inputs and disable the unwanted ports. Otherwise you will record MIDI from multiple ports which results in double MIDI notes.

    There is a readme file in the Cubase SX folder named 'MIDI port filter' which details these instructions and some of the midi interfaces that work incorrectly when emulated ports are used.

    I was getting a sync problem with midi recorder from my keyboard, the strange thing was that they appeared before the beat I had played them on - my timing is not that bad! The longer Cubase was running that worse the sync error got.

    Now I am not using the emulated drivers I have had no further problems."

    Interesting thing is that occasionally I pull up one of the old projects which has a track set to listen for the emulated midi port, and sure enough the timing goes out the window. All I have to do is point the input to a non-emulated port and timing is rock solid.

  8. #8

    Re: midi feels a little off ?

    BB Sound,

    I encountered the exact same Rewire problems in my Nuendo 2.2 / GS 3 scenario on a high powered box. I then fired up Sonar 3, and experienced identical results.

    I'm going to investigate the emulated port thing Chadwick mentions below (I don't remember if I selected emulated ports or not - I've slept since then). Hopefully, that will resolve the problem. However, I've seen numerous posts reporting Rewire bugginess, including (if I recall correctly) audio file exports, so even if this solves the timing issue, be aware that you may encounter other adventures with GS3 / Rewire.

    In addition to investigating Chadwick's suggestions, there's also a 3.01 update "coming to a theater near you soon". It's not known with certainty if there are any Rewire fixes, but I expect Tascam will be releasing the update sometime soon.

    And Chadwick, thanks for the info - I'm going to explore that myself!

    [edit] I just saw on another thread that the 3.01 update is now officially on the updates page. However, there is no documentation on what the patch addresses, so I don't know if it'll help our Rewire adventures or not. [/edit]

    Chris

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •