• Register
  • Help
Results 1 to 8 of 8

Topic: VERY odd timing issue..what's going on here?

  1. #1

    VERY odd timing issue..what's going on here?

    Hey folks,

    I just encountered a really weird problem. I'll try to describe it the best I can.

    I recorded a fairly up tempo piece, and it plays just fine. However, in Sonar, when I have an audio track set to record, and I hit play (or record, either one), the result is a tad slower than playing the tune without the audio track there and set to record mode.

    I verified this by opening up the recorded audio track in SoundForge, and having the tune ready in Sonar..and making them play at the same exact beginning point. For a short while they're in unison, then I can hear a delay as they drift apart.

    What's going on & how can I fix this?

    Thanks in advance.

  2. #2

    Re: VERY odd timing issue..what's going on here?

    Wow, that's a tough issue. So you have multiple audio tracks, and that's it? No midi tracks? I mean to ask, it's not the midi tracks that are going out of sync with the audio tracks, right?

    the only thing I can suggest is to make sure that you have Sonar as the clock source. If it starts synced, and then drifts out I can only assume that it's a clock issue. It could be that some tracks are one samplerate, and the armed track is a different rate, but I don't think it's possible to set tracks to different samplerates. Besides that it would sound wrong from the start.

    Try setting your buffer to a greater number, 1024 if it's lower than that, and higher if it's set to 1024. Do you notice a change?
    Michael Peter

    If music be the food of love...
    play on

    William Shakespeare


  3. #3

    Re: VERY odd timing issue..what's going on here?

    Here's the situation: I have several MIDI tracks that I'm dumping to a single audio track within Sonar. This is how I normally do it. Then I apply reverb to the audio track, and dump it to WAV for further editing in SoundForge. That recorded audio clip plays a tiny bit slower than just playing the MIDI tracks. And if the audio track has not yet been recorded, but record mode is turned on, and I'm playing back just the MIDI, there's also a slowdown.

    My choices for clock sync are: Internal, MIDI Sync, SMTPE/MTC, and Audio. It's currently set to Audio.

  4. #4

    Re: VERY odd timing issue..what's going on here?

    I'm not very familiar with Sonar but it sounds as though your system switching to a different clock source as soon as you enable recording. Is it set to record from a digital source? If you enable recording during playback do you hear a click in the audio? This would confirm your clock source is changing.

  5. #5

    Re: VERY odd timing issue..what's going on here?

    I think Looper's right.
    Does the speed difference seem like about 10% - about the difference between 48k and 44k?

    What's at the other end of your clock sync - is it set to 44, while Sonar is set to 48?

  6. #6

    Re: VERY odd timing issue..what's going on here?

    OK this is getting too tech for me Clock sync set to 44? How do I check? I've got an Audiophile 2496. In the control panel settings for it, it's set to 48KHz (locked rate). Sonar is set to 24-bit 48KHz. And that's 24-bit for the file settings and 24-bit for the audio driver as well. Actually it was 16-bit for the audio driver.. I just changed it to 24.

    Anything else I should check?
    Sam Hulick

  7. #7

    Re: VERY odd timing issue..what's going on here?

    Sorry mate - I assumed that you were syncing two pieces of gear together, and was hoping the timing difference was because the two PCs were set at different sample rates.

    If this is all going on on a single machine, it reminds me of what people were screaming about on Cubase some years ago - audio being out of sync with midi. From memory this was supposed to be because any recording and playback you did needed to have a solid external clock reference in place at all times (like word clock).

    What made me think you were syncing two machines was the fact that the simple act of arming record made the sequencer slow down (midi as well - not just audio).

    I found a faq at Cakewalk which mentions that you can have timing problems if bitrates aren't uniform when you're set to 'audio' sync, but nothing else so far:

  8. #8

    Re: VERY odd timing issue..what's going on here?

    This Cakewalk forum post looks pretty relevant (read the whole thread - this solution didn't work for some):


    ""Thanks to everyone for the posts on gradual audio lag...this particular solution worked for me:

    I'm currently using SONAR 3.1.1 and was having audio latency issues when converting my MIDI tracks from external modules to audio tracks. After trying many other things, the solution that conclusively worked for me was to set this as follows in the Cakewalk AUD.INI file:


    I don't know why it works, but it works. Probably something to do with my system's USB audio latency and/or SONAR's ability to adjust or force the syncronization via this configuration setting.

    It was getting very frustrating to have my basic MIDI tracks play back in perfect sync with my audio tracks, only to hear after the MIDI tracks were recorded to audo from the external keyboards that there was a definite lag behind the original MIDI track...not right away (a gradual audio lag) - usually becoming painfully obvious around 2 to three minutes into the tune - the latency (lag time) was undeniable and the MIDI to audio mixes could not be used. (I'd even resorted to dumping quick demo mixes directly to my iRiver MP3 recorder without even trying to get audio mixes of the MIDI - but that solution is not unacceptable for mixes that need to be more polished).

    Without this KsUseInputEvent option, there were only a couple other options that I could come up with, none of which were particularly appealing:

    1. Record the MIDI tracks to audio in smaller sections (e.g., 32 measures at a time rather than the entire track) - but the down side to this is that it's a major time drain and hassle when dealing with lots of MIDI tracks.

    2. Record the MIDI to audio, and end up splitting the tracks and adjusting the start time of the lagging audio by various milliseconds (usually to start playing about 10 to 30 ms later to catch up with the other audio). I actually have to do this sometimes anyway (for performance reasons!) but having to do it with music that sometimes comes from a Finale or MIDI source, re-sync with the vocals or horns...arg...that would be a pain for all MIDI to audio conversions.

    My sound card is a Roland UA-30 USB and I use a Yamaha UX256 USB MIDI thru box.

    In summary, if you find your MIDI track, when converted to audio, lags behind your original MIDI (test this by soloing the two together) then, for me at least, setting KsUseInputEvent=1 in the Cakewalk AUD.INI worked.

    Rob Birdwell""

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts