• Register
  • Help
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Topic: Dropout with plenty of RAM to spare.

  1. #1

    Dropout with plenty of RAM to spare.

    EDIT: I use GPO Studio

    I discovered a problem while writing a piece for a current project I am working on. I am getting droputs of chords on some areas of my music. I don't think it is a polyphony problem (only 13 - 20 notes playing). I doubt it is a low RAM problem because I have 80 megs free with the loadout I am using.

    I think it may have something to do with the CPU usage, though. When it approaches the dropout point, the CPU meter starts climbing. The last number I see is around 85%. When the cutout happens, the CPU monitor disappears for about 1/4 of a second.

    I am using DFD, but I have no clue what those sliders in the options actually do and I'm afriad to mess with them because of that. (sorry if that sounds n00bish)

    Here is a file that shows the dropout:
    There is a chord in the violins (section violins KS 1, set to tremolo). This chord lasts for three measures and then holds again for another three (new note, same chord). Halfway though the 5th measure in this MP3, the violins drop out. I can tell that studio didn't drop the MIDI data because the chord still appears to hold full value on the keyboard display, but the sound stopps.
    The problem causing part, I think, is the basses that have an effect like trill going on that is entered as 32nd notes.
    There are also some muted trumpet, horn, and muted trombonce chords as well as a harp part doing quarters low and sixteenths high.


  2. #2

    Re: Dropout with plenty of RAM to spare.

    You don't say what your system configuration is, but the first thing I'd look at is the latency. This is adjusted in the "Preferences" window in Studio. Just for an experiment, try doubling the value of the "Buffer size".

    Note also that by using DFD, you are placing a somewhat higher demand on your CPU (and less on memory). You should be using DFD only if you don't have enough memory to load the instruments (Garritan site make this statement).

    Also, as you increase the number of "notes" being played simultaneously, you also are increasing CPU demand--you can get dropouts even though you have not technically exceeded the polyphony value of a given instrument.

    Increasing the value of the "Buffer size" will give your sound card more time to get ready to play what's being demanded of it, at the expense of a slightly longer delay between the time the note is encountered (or played from a keyboard) and the time you actually hear the sound. This delay is usually imperceptible unless it's very long and you're playing real-time.

  3. #3

    Re: Dropout with plenty of RAM to spare.

    My buffers have been at 512, which is the highest I can select.

    I turned DFD off (oddly, that actually gave me 5 more free megs...) and it is still maxing out the CPU, but just not as bad. I get some crackeling.

    I can reduce the crackeling by increasing the latency, but I am getting close to the point where my effect trill doesn't sound right. The CPU usage still remains in the high 90s at this point. I guess I could tweak the Trombone swell, as it seems like the louder it is the more CPU it takes.

    Maybe I should think about replacing that 2.4GHz P4 with a 3 GHz one...

    Or maybe upgrade to a quad Itanium 2 server board with 64 gigs of RAM! (Just out of curiosity, does GPO run in Server 2003?)

  4. #4

    Re: Dropout with plenty of RAM to spare.

    Quote Originally Posted by DZComposer
    My buffers have been at 512, which is the highest I can select.
    It would be quite unusual if 512 is the highest number attainable with a soundcard. That corresponds to a latency of 11.6ms at 44.1, which is pretty low. I'm thinking you have to get your latency up around 20-40. There may be something you can do in the configuration of your soundcard. 2.4 Ghz should give you enough power if you can get your latency up.

    A couple of ?s:

    1. What is your soundcard?
    2. Is there a configuration utility for your soundcard independent of the "Preferences" in GPO Studio where you can adjust the latency.

    On my old machine, I have an 2.0Ghz/512MB ram/SBLive!. I'm using MME drivers. If I bump up the latency on the card to 50ms or so, I can get quite a bit of mileage out of it.

  5. #5

    Re: Dropout with plenty of RAM to spare.

    I agree with Bill. FYI, I have the buffer in Studio set to 512, but it is set to 2048 on my soundcard. You need to set your soundcards buffer higher as well as Studio's to get the CPU usage down. It made a considerable difference in my PC when I adjusted the buffers. Also, what type of sound card do you have?

  6. #6

    Re: Dropout with plenty of RAM to spare.

    I have a Soundblaster Audigy 2 Plantinum. I have yet to find the config panel for dealing with the buffers. But, this card was designed for gamers so there may not be such a control panel.

    Before I started playing with the latency, it was at 20ms. At last run, it was at 50.

  7. #7
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: Dropout with plenty of RAM to spare.

    Make sure that you're only using the dry instruments. Are you using the Ambience plugin for reverb? It is pretty high in CPU usage.

  8. #8

    Re: Dropout with plenty of RAM to spare.

    Quote Originally Posted by DZComposer
    I have a Soundblaster Audigy 2 Plantinum. I have yet to find the config panel for dealing with the buffers.
    I'm a bit confused about how you know what the latency values were (20, 50ms, etc) if there is no other way to configure the soundcard than from within Studio.

    This stuff is driver-dependent. In Studio, go to the "Settings | Audio Drivers" option and see which driver is checked. Your going to get different latency options (buffer sizes) on the "Settings | Preferences" window depending upon which driver is selected.

  9. #9
    Senior Member
    Join Date
    Mar 2004
    Wilton, NH

    Re: Dropout with plenty of RAM to spare.

    I just solved a similar problem.

    Everything was working fine. I changed some sounds to versions from the GPO upgrade. Still fine. I moved the rest over and parts of the song became unplayable.

    I tried everything. Upping the latency caused other strange things to happen. Finally I checked an old version and found that the new was taking 25% more processor power just sitting (not playing) than the old version (almost 30% as opposed to under 5% on a 3 GHz PC). I went through and found 9 of the 60 or so sounds were somehow the wet versions. I was careful when I was loading but somehow loaded the wrong instruments. I changed them to dry versions and everything worked perfectly.
    Trent P. McDonald

  10. #10

    Re: Dropout with plenty of RAM to spare.

    That latency control panel is only latency:

    This is all I get.

    Yes, I do use Ambience. I'm pretty sure I'm using the drys as well, I'll doublecheck this evening after I get out of my classes.

    I'll also check some other drivers.

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts