• Register
  • Help
Results 1 to 7 of 7

Topic: GS3 EW.sys ERRORS and Rewire.

  1. #1

    Exclamation GS3 EW.sys ERRORS and Rewire.

    AMD 2600+XP
    Asus A7n8X-X (Nforce 2)
    1 gig, Corsair mem @ 333mhz, 3, 3, 7, 2.5T
    Nvidia Gforce 6800GT
    80gig HD
    120 Gig HD
    DVDR 16x
    Aardvark Q10

    Windows XP Home, SP2

    So many, many many issues here. At first I was having major issues with gs3.
    Error at the end of the installation, "GLJ4.tmp The procedure point ?Get Message Map@CEW@@XZ could not be found in the dynamic link library EWCTL32.dll"

    Still worked after the error, so I ignored it. Messed around with it a bunch, pretty cool program (I orginally had G96 2.5) CPU kept maxing though and could only do about 3 notes before pops and studders in Gpulse, kinda annoying since that's why I bought the program.

    K then went to audio dump (not useing Re-wire or Gpulse) just an internal dump of some midi data. I tried Live and a midi program (sonar 2). Gave me a BSD citing EW.sys.

    K then went in, disabled re-wire. Same.

    K then went in, lowered my polyphony to 96, worked, error with the sound file.

    Rebooted, Then second time started up, BSD and same error.

    K then I activated all my inputs on my Q10, still worked, but sorta.

    Now both of these times of randomly working, the file itself sounds very distorded, and not the "over-driven clipping distortion", mind you.

    It's like its playing back at a different bit depth (not sampling freq). So I went in and all I see for the q10 is a 32 bit depth (can't change it). When it's physical max is 24.

    I have also tried multiple samples both from VSL and the giga piano2 still all the same issues.

    I am guessing it's a GSIF1 problem?

    So I did the following anyway to see if it would fix any of those problems:

    Bought new ram (replace older Crucial Mem)
    Bought a DVD drive so I didn't have to network the install from my wifes compy.
    Bought a New Video card (had a ATI Radeon 9000)
    (BTW, it's a EverQuest2 thing, not a GS3 thing)
    Wiped the hardrive, reintalled windows
    Updated all of my drivers and GS3 Orchestra to 3.03.

    All the same issues (including the install) and BSD errors again.

    Help please, can't get through to Chris over at Tascam.



  2. #2

    Re: GS3 EW.sys ERRORS and Rewire.

    I would be suspicious of the Aardvark Q10. Did you have the Q10 when you were using GS2.5?

    I used to have a Q10, but I got tired of waiting for WDM drivers. When they came out with their "A-WDM" driver, which appeared to be some modified WDM driver (since they couldn't seem to develop a "normal" WDM driver), I sold it and I have never looked back. From other posts, I also understand they are in financial trouble.

    I did a Google search on "EWCTL32.DLL" and found this:

    From what I am reading, I deduce that "EWCTL32.DLL" probably stands for "Endless Wave 32-bit control", and this is a module that GS uses to connect with your audio interface AND midi interface. If you get an error with a "General Protection Fault", then GIGA is having difficulty with your audio or midi interfaces (the audio and/or midi drivers).

    My guess would be Giga doesn't like the Aardvark GSIF driver. I assume you are using the most current driver, version 7.13:

    Also, see these two posts:


  3. #3

    Re: GS3 EW.sys ERRORS and Rewire.


    Yeah I kinda figured as much. I really like the q10 in nuendo, it works really well. When I had G2.5 it took a bit but it seemed to work okay, a few buffer issues occationally, but other than that just fine. It did take aardvark a bit to come out with a gsif driver initially, but since it worked with gs2.5, I am not sure if I blame aardvark. Considering the difficulties I've had and others (with other cards) have had I'd say it's a Tascam error. GS2.5 was pathetic tring to get that to work, even with my buddies tascam cards. He finally bought an aardvark too, which worked fine.

    GRRR where is a solid, good quality D/A interface that will work perfectly with Nuendo2 and Giga? That I don't have to shell out $$ for? Maybe I should buy the echo MiaMidi. I hate this, always pouring money into stuff that I am not sure will fix the problems.


  4. #4

    Re: GS3 EW.sys ERRORS and Rewire.

    With your current system, can you get a "clean install" of GS3, or do you always get that errror message you mention?

    I went back and re-read your original post. Given your statement about getting a midi error running Sonar (and pointing to EW.sys), the problem may be with the midi part of GS and not the audio part.

    From what I can tell, that EWCTL32.dll is the module that GS uses to interface with your audio driver AND your midi interface.

    Look at the NS post about that person's midi troubles with GS3. For SOME RME audio interface owners, the GS3 install seemed to overwrite/erase their midi registry entries. If you are comfortable looking at the Windows Registry, you might make certain that your midi ports are stil there.


    I wouldn't necessarily give up on the Q10 just yet. Theoretically, GS3 is supposed to be able to run fine on hardware with GSIF-1 drivers.

    Here is another post about the RME midi entry problem. Perhaps GS3 is doing the same thing with the Q10.

    The following link shows how to "see" what the midi registry entries are. The link discusses a DIFFERENT problem, unrelated to GS. However, I think the RME GS problem above DOES have to do with the GS3 installer writing over some of these midi entries:

  5. #5

    Re: GS3 EW.sys ERRORS and Rewire.

    There was one thing I forgot to mention. I use the MIDIMAN USB-MidiSport 4x4 as my interface.

    I have tried dumping both with Sonar, Sibelius and also direct into Giga's midi-ins. I still have the same errors.

    I think the major issue is with the q10. The EW.sys happened as soon as I clicked "Save" after I named the Capture-to-wav file. I did not even play anything, or "press" play, never had the chance.

    Being that the bit rate is stuck on 32 under SystemSettings, Hardware, and my q10 only does 24. I think this is one of the big problems (BTW Reads GSIF v1.7).

    The synth, however is set to 16-bit for the bounce.

    I did check all my registries, everything is there and working.

    Oh and by the way, Aardvark is out of business. That's why I am now looking at getting an RME Digi 96/8 PAD card.

    Thanks again.

  6. #6

    Re: GS3 EW.sys ERRORS and Rewire.


    You should be aware that RME-Audio has not issued a driver for GSIF 2.0 for the digi 24/96 PAD. The thing that really burns me about this is that I bought this card partially because of the recommendation on Tascam's website that this card was indeed GSIF 2.0 compatible. NOT SO!! At least yet. I have yet to see or read anything from RME regarding an update timetable for this line of cards either.

    Using the 1.7 drivers could very well result in the same BSD you are getting with your current sound card. I am speaking from personal experience here, I am unable to use this feature in GS 3 either. Tarantec (sic) has no plans to update their drivers for some of their cards either. Audiophile make a decent card for less than $100 that does have GSIF 2.0 drivers. Everyone that has used these cards has been pleased with their performance considering the price.

    Echo Audio drivers have been updated. And most people seem pleased with their performance as well.

    Hope this is useful.

    Allen Zurcher

  7. #7

    Re: GS3 EW.sys ERRORS and Rewire.

    Hello Guys...
    I'm having the same problem. When clicking "save as" when trying to capture sound the computer reboots with a message: Driver_IRQL_NOT_LESS_OR_EQUAL (I have GSIF1)

    If I try to save a GS performance the computer reboots with that ew.sys message and it also says PAGE_FAULT_IN_NONPAGED_AREA

    Is this really because I have GSIF1? I'm also tired of spending a million on things that doesn't fix the problem.

    Please help!

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts