• Register
  • Help
Results 1 to 9 of 9

Topic: Gigastudio 2.54 hangs on startup

  1. #1

    Gigastudio 2.54 hangs on startup

    Hello all!

    After changing my soundcard from Pulsar II to RME Fireface 800 Gigastudio96 2.54 doesn't start up anymore! It just hangs on the splash screen. I know that this was a major issue in some of the first versions of GS, and that leaving it for a couple of hours would often solve the problem. However, this does not work!

    I have also tried uninstalling and reinstalling, but nothing seems to help!

    Does anyone know how to solve this issue?

    Thanks in advance,

    Thomas Regin.

  2. #2

    Re: Gigastudio 2.54 hangs on startup

    Is Quicksound disabled?

  3. #3

    Re: Gigastudio 2.54 hangs on startup

    Another thing to check -- make sure the 'userinit' process (windows xp) is finished before starting gigastudio. You can see userinit for 15-30 seconds in task manager, after rebooting and beginning a user session.

  4. #4

    Re: Gigastudio 2.54 hangs on startup


    Yes, Quicksound is enabled! I have selected a specific folder where my Gigs are located, and the Search Mode is set to "Recursive".


    This happens even after the computer has been on for days, so I don't think it has anything to do with the userinit process. Unfortuanately!

    Thanks for any help!


  5. #5

    Re: Gigastudio 2.54 hangs on startup

    For more info, there is a diagnostic log written in your windows directory, "nemdiag.log" -- maybe there is a clue there. Seems to me I've heard about midi loops or other conflicts causing things to hang on startup.

  6. #6

    Re: Gigastudio 2.54 hangs on startup


    When this happen I kill the job using the task list window (ctrl+alt+del in Win XP) and reload giga again. It's not elegant but works and avoid headache of trying to find the for ever solution which is not obvious.


  7. #7

    Re: Gigastudio 2.54 hangs on startup


    Thank you for the tip, but unfortunately that approach doesn't work either!


    The only questionable thing I could find in the log file was this:

    Registry location: Software\NemeSys\GigaSampler\Settings
    Software\NemeSys\GigaSampler\Settings - Missing Registry Key

    I couldn't find any other apparent errors in the log file. Here are a few of the last lines concerning Midi loopbacks etc.:

    Progress 790 -
    Progress 788 -
    Progress 789 -
    Max. Backup reads of registry is set to 50000
    BackupRead: Polyphony is correct - no need to reread registry!! (0 iterations)
    Progress 791 - PROGRESS_INITWSTREAM:
    WSTRM32 successfully initialized the WaveStream module.

    WSTRM32: MidiLoopback thread succeeded.



  8. #8

    Re: Gigastudio 2.54 hangs on startup

    You found the problem, perhaps: midi loops. My system is now gs3, so the nemdiag.log is different, but I seem to remember that I had lockups where that message was the last one in the log file. I'd suggest unplugging midi cables as another easy test.

    In gs3, anyway, the log goes on to talk about other things in a chatty way: "...we will continue on as normal..."

  9. #9

    Re: Gigastudio 2.54 hangs on startup

    Have you tried disabling quicksound? Every time I've had a startup hang it was because of a bad file that confuses quicksound.

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts