• Register
  • Help
Results 1 to 7 of 7

Topic: can't get GPO working with my keyboard

Share/Bookmark
  1. #1

    can't get GPO working with my keyboard

    i just got GPO & a keyboard for christmas! prob is i have been puzzling over this for days now and can't get ANY orchestral sounds to occur when i play my keyboard!! i can click notes w/ the mouse in kontact player and i hear the flutes etc but if i play keys on my casio keyboard, just the keyboard's piano sound occurs.

    so tried using overture and i can see that the midi signal is working (the little red lights in overture blink when i hit the keyboard.) when i hit record and play the keyboard, just the regular piano sounds occur, but when i play it back in overture, i get GPO's instruments from my computer's speakers!

    how can i play GPO's instruments from my keyboard?!?!?!?

    computer sound setup:
    M-Audio Firewire 1814 <--> midi <--> Casio PX-300 keyboard
    SoundBlaster Audigy External Platum
    if you need any additional information about my setup please let me know i'm really getting frustrated

  2. #2
    Senior Member rwayland's Avatar
    Join Date
    Jun 2004
    Location
    California Redwoods
    Posts
    2,937

    Re: can't get GPO working with my keyboard

    Quote Originally Posted by bachrock
    i just got GPO & a keyboard for christmas! prob is i have been puzzling over this for days now and can't get ANY orchestral sounds to occur when i play my keyboard!! i can click notes w/ the mouse in kontact player and i hear the flutes etc but if i play keys on my casio keyboard, just the keyboard's piano sound occurs.

    so tried using overture and i can see that the midi signal is working (the little red lights in overture blink when i hit the keyboard.) when i hit record and play the keyboard, just the regular piano sounds occur, but when i play it back in overture, i get GPO's instruments from my computer's speakers!

    how can i play GPO's instruments from my keyboard?!?!?!?

    computer sound setup:
    M-Audio Firewire 1814 <--> midi <--> Casio PX-300 keyboard
    SoundBlaster Audigy External Platum
    if you need any additional information about my setup please let me know i'm really getting frustrated
    Well, I don't have much experience with keyboards with onboard sounds, but here is what I would do.

    Open GPO (the stand alone version) and click on the file menu. Then check out the various options that appear. Be sure you have selected the necessary midi in and outs, and sound card, with correct ASIO and duplex setting. If you can get working this way, then the obvious next step would be to check all your Overture options.

    When you are new to the game, getting started will be frustrating, and annoying, but it is worth the effort to learn, and some effort is required. GPO is one of the easiest to learn, but still, expect a little effort.

    richardw

  3. #3

    Re: can't get GPO working with my keyboard

    Quote Originally Posted by rwayland
    Well, I don't have much experience with keyboards with onboard sounds
    uh oh - do you mean that i got a keyboard that can't trigger midi events or something? i'm a real newb to this stuff

    btw - happy new year!!!!!

  4. #4
    Senior Member rwayland's Avatar
    Join Date
    Jun 2004
    Location
    California Redwoods
    Posts
    2,937

    Re: can't get GPO working with my keyboard

    Quote Originally Posted by bachrock
    uh oh - do you mean that i got a keyboard that can't trigger midi events or something? i'm a real newb to this stuff

    btw - happy new year!!!!!
    Possibly so, but I can't say for sure. I will see what I can find out for you. Just now, I am thoroughly aggravated with internet searches that give results not at all according to your search terms! So a little reading up on your keyboard will be a welcome change of pace -- after I have some more French Roast coffee.

    Richard

  5. #5
    Senior Member rwayland's Avatar
    Join Date
    Jun 2004
    Location
    California Redwoods
    Posts
    2,937

    Re: can't get GPO working with my keyboard

    Quote Originally Posted by bachrock
    uh oh - do you mean that i got a keyboard that can't trigger midi events or something? i'm a real newb to this stuff

    btw - happy new year!!!!!
    Well, I checked out the Casio web site, and discover that the Privia 88 note Piano (PX-300), while probably not of professional quality, is not a cheap childs toy, and certainly it appears to me that it should work as you wish. Perhaps the problem is your midi connections?

    Should be:

    Keyboard, Midi out to sound card midi in.

    Soundcard, midit out to keyboard midi in.

    I did not find any firewire or usb support for your keyboard.

    Also, possibly related, listen to the output from your sound card, not from your keyboard speakers (if they are present. I forgot to check this).

    Did I check out the correct instrument? It is the only thing I could find on the Casio site with the designation PX-300.

    Richard

  6. #6

    Re: can't get GPO working with my keyboard

    Bach,
    You can do it. Try this.

    Go to win start menu and open "Garritan Personal Orchestra".

    Go to the "File" menu in GPO and select "Setup"

    On the "Soundcard" tab, make sure it sees your sound card and that the correct driver is selected. This is probably already correctly set up since you can play from the Kontakt player.

    Go to the "Routing" tab and make sure that you are sending from GPO to your audio out. This is probably already correctly set up since you can play from the Kontakt player.

    Go to the "Midi" tab and make sure the input midi port is selected through which your keyboard is connected. Since you have 2 soundcards (?), you need to rationalize this. I'd guess it's the M-Audio from your post. Don't worry about the output port right now...

    Close the setup window.

    Now...
    Load a voice, flute for example, in slot 1 of the player.

    If you know that your keyboard transmits on channel 1, don't do the following...

    The following...
    If you don't know what channel your keyboard is transmitting on (1 is normal), change the midi input on the first slot to "Omni" so the voice will see midi input from all channels. This is changed by clicking the number (1 ususally) in the lower left hand corner of the voice's parameter window, right below the CPU Usage area. There's a little graphic of a midi plug to the left of this number.
    End of the following.

    You should now be able to play from your keyboard...well maybe...there's always something you miss, but this is the general idea.
    Bill

  7. #7

    Re: can't get GPO working with my keyboard

    YES!
    thank you rwayland & billp for your help billp it was on the midi tab in the GPO setup. i set it to play through my computer's speakers (yes the latency using creative's drivers is 50 as opposed to m-audio's 8 but i don't have a second set of pro speakers..yet.. )
    now all i know is that i can never ever ever ever shut off my computer cuz it's working
    thanks!!
    -jaan

    ps oops i should actually document here in case someone else has this prob:
    in SOUNDCARD tab: i chose the creative soundcard (to make the sound come out of my computers' speakers)
    in ROUTING tab: i dunno what that stuff is
    in MIDI tab: input interface - m-audio 1814 MIDI (where the keyboard's info is coming from) then output interface - GPO studio: 1

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •