• Register
  • Help
Results 1 to 9 of 9

Topic: User account question

Share/Bookmark
  1. #1

    User account question

    I´m aware of that this is perhaps not a strictly "GPO-question".( More like a "OS - question")But I´ll ask anyway if someone has an idea.

    Is it possible to get GPO/Kontakt player to work with several User accounts in XP?
    (It´s very practical with user accuonts when you are more than one person who shares the same computer.) I couldn´t find anything about this in the forum so I ask here.

    I really enjoy GPO and it works great when I use the Administrator account but when I try to use GPO in another accounts(same computor) I get the following messages:

    "Select your Personal Orchestra studio base dirctory"

    Then I select C:\Program\Garritan Personal Orchestra and GPO studio opens and then i get:

    "Your serial number is not correct run the registration tool and enter correct serial number"

    and when I close that window I get something like....

    "Warning could not open content file. It should be located at not set..."

    I have bought GPO and I´m registrated user and I have authorized it(kontakt player) at the NI-page.

    I haven´t tried the registration-tool again so far.

    And I´m not a computerexpert so feel free to enlighten me if it´s possible and if it is, perhaps someone knows how to do it.


    Thanks / Thomas
    "Every journey, even one of a thousand miles, begins with a single step."

  2. #2

    Re: User account question

    Use the registration tool, that should help you with all of your problems.

    ~FireGS
    ~Sam Ferrara~

  3. #3

    Re: User account question

    Thanks for the advice.

    In Administrators account all runs smoothly, as it always has. Yeah!

    So now I´ve completed the registration tool (licens nr and the auth.key
    I recieved from the very beginning)- in a different user account (same
    computor) but now get following messages.


    "Application error. Please reinstall GPO"

    and then

    "portaudio error -9985: Device unavailable"

    "Can´t set value of HKCR\Personalorch patch\shell\open\command
    (error 5: access denied")

    Does anyone use GPO in different user accounts (same computor)?
    Please tell me about it.
    "Every journey, even one of a thousand miles, begins with a single step."

  4. #4
    Moderator
    Join Date
    Jun 2000
    Location
    Chandler, Arizona
    Posts
    4,045

    Re: User account question

    You can only use GPO and other NI instruments only in the user account it was created in. Unfortunately it writes it's registry info into the H_Key_current_user section of the registry. This is why it only works in the account it was installed under.

  5. #5

    Re: User account question

    Quote Originally Posted by Haydn
    You can only use GPO and other NI instruments only in the user account it was created in. Unfortunately it writes it's registry info into the H_Key_current_user section of the registry. This is why it only works in the account it was installed under.
    Ok, I´m enlighted, thanks.
    I wish and hope that it will be possible in the future, perhaps someone has a good idea about this.
    "Every journey, even one of a thousand miles, begins with a single step."

  6. #6

    Re: User account question

    This had been bugging me for a while so I decided to try to crack the problem now someone else is suffering - and here is the solution which basically involves exporting the keys from the registry account that works, and re-importing them into the account that does not. All registry edits come with a caveat - you may render your computer unuseable with incorrect edits in the registry, so do the following at your own risk, and ensure you have a restorable back up for your system before proceeding - that said details below:

    - log into the account that works with GPO (ie the one you installed it with)
    - START....RUN......regedit [type this in]
    - navigate to HKEY_CURRENT_USER....SOFTWARE...
    - navigate to GARRITAN
    - right click on GARRITAN folder and choose EXPORT
    - save the file somewhere that both accounts can access (eg root of C: drive)
    - repeat the EXPORT for NATIVE INSTRUMENTS folder (by right clicking and choosing EXPORT)
    - close the registry
    - log out of the user account and log into the one where GPO does not work
    - START....RUN....regedit
    - navigate to HKEY_CURRENT_USER....SOFTWARE....
    - on the FILE menu choose IMPORT
    - import the two .REG files you exported above
    - now try using GPO on that account ! [it works for me].

    Good luck.

  7. #7

    Re: User account question

    Thanks a lot LOW!

    I haven´t got time to try this out right now, but I´ll try this(with caution) and I´ll be back when my computer crashed.
    "Every journey, even one of a thousand miles, begins with a single step."

  8. #8
    Moderator
    Join Date
    Jun 2000
    Location
    Chandler, Arizona
    Posts
    4,045

    Re: User account question

    That trick should work fine. I only have a single user on my systems, so I never run into this issue.

  9. #9

    Re: User account question

    So now I´ve tried and it seems to work fine, thanks again!

    Thomas
    "Every journey, even one of a thousand miles, begins with a single step."

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •