• Register
  • Help
Results 1 to 8 of 8

Topic: Hey Guys..Dumb Windows XP Question..

  1. #1

    Hey Guys..Dumb Windows XP Question..

    Mac user mainly, but use XP Pro for Giga on a PC.

    I must have inadvertantly done something at some point, because now whenever the computer starts up, it asks me which operating system I'd like to use, XP or something else. It never used to do that, it autobooted to XP. Where do I change the pref for this?


  2. #2

    Re: Hey Guys..Dumb Windows XP Question..

    Could it be that you loaded the program more than once?


  3. #3

    Re: Hey Guys..Dumb Windows XP Question..

    I'm using XP home but should be the same.
    Right click on My Computer select properties.
    Click on the advanced tab. At the bottom you will startup and recovery options.
    Choose settings. You have options for choosing the default operating system.

    What other option is it giving you? Safe mode perhaps.


  4. #4

    Re: Hey Guys..Dumb Windows XP Question..

    If it is asking you in black and white text, long before you get to the Windows splash screen, then the answer is in c:\boot.ini.

    This is where dual-boot info is stored, so that you can potentially boot the computer into more than one operating system.

    The file will be marked "system" and "hidden", so you'll have to change your Explorer settings to allow it to show hidden files, or it will never show up.

    Or, you can open a DOS box, navigate to C:\ and type "dir /a boot.ini" to see if it is there.

    If it is there, it is certainly possible to delete the multiple entries. Basically, if there is only one entry in boot.ini, it doesn't pause to let you choose anything... it just immediately goes on.

    Before we get into how to edit boot.ini (or, you could search on "boot.ini" on the www.microsoft.com site), please confirm that what you are talking about is the black and white text thing that I mention above. It would also be good if you could write down the options that it is offering you, and indicate which one you want to boot automatically.

    Another possibility is that you are shutting down the system while it is booting. Then, the next time you boot, it will offer you several choices, including "normal boot" and "safe mode".

    Let us know what it is.... and we can help further.

  5. #5

    Re: Hey Guys..Dumb Windows XP Question..

    Well that is basically what I suggested except doing it through the System Properties in Windows which would be safer for him. If you mess up the boot.ini file or accidentally delete it then Windows won't boot at all until the file is restored.


  6. #6

    Re: Hey Guys..Dumb Windows XP Question..

    Yes, that is true, JS, but I wasn't aware that the Settings dialog will allow you to *remove* entries from boot.ini. I just looked, and it will pop up an edit window if you choose the Edit button on that page, but it doesn't really give any instructions.

    So, other than that, all you can do on that page is to select which entry in boot.ini will get chosen by *default*, and changing the amount of time you have to wait before it moves one. This is a good thing if the default is wrong. Otherwise, you're still stuck staring at the screen for a while, or hitting <return> to proceed. I guess you could always make sure that the default choice was a good one, and then change the timeout value to something small, like 4 or 5 seconds. That gives you enough time to change it to something else if you *had* to, but makes it so you don't have to wait very long in every other case, and it is very safe.

    It is certainly true that if you mess up boot.ini, you can hose your ability to boot. Then you'd be stuck booting from a floppy or CD, and trying to repair the damage. Don't do this unless you know what you are doing!

  7. #7

    Re: Hey Guys..Dumb Windows XP Question..

    You can select the one you want and just unclick the wait time and it will go to 0 so I assume this would prevent the startup screen from appearing.


  8. #8

    Re: Hey Guys..Dumb Windows XP Question..

    Hey thanks! That was it!

    Yes, it was on the black screen on startup...so I went to place you guys said to, and it was set to AUTO DETECT the right system, but it had a wait time of 30"....so unchecking the wait time box fixed it. It now starts up like it used to....

    Thanks a lot!


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts