• Register
  • Help
Results 1 to 6 of 6

Topic: Cell Phone MIDI Looping Problem

Share/Bookmark
  1. #1

    Cell Phone MIDI Looping Problem

    Hey everyone,

    I am just curious if anyone has any experience with midi files for the Sanyo PM8200.

    The problem is that the client has requested a 10 sec loop, which works fine on my machine, and on some other boxes (windows) that I have tested it out on.

    However, he says there is a noticeable delay in the piece looping on his phone. He is requesting that I chop off a little (like .2 or .3 seconds) to see if that helps, but I was wondering if anyone knows anything about this problem? It would be better to fix it, I believe, then chopping off.

    Thanks!

    Eric
    =-=-=-=-=-=-=-=-=-=-=-=-=
    Eric Doggett
    MoonDog Media
    www.moondogmedia.net

  2. #2

    Re: Cell Phone MIDI Looping Problem

    There should be no problem at all, don't know that particular phone, but I would suggest:
    1.- Tell he client to test it in a real context. I mean, some phones, when you previw the sounds put a delay or don't loop at all, so the only way to test it properly is calling to the mobile phone.
    2.- Make sure there is absolutely no midi events (like some stray CC or something) after what you want to be the end of the loop
    3.- Some phones (like the ones with Yamaha SMAF chips) use markers to define loops, so generally avoid them

  3. #3
    Power Profile User lukpcn's Avatar
    Join Date
    Nov 2003
    Location
    on the end of the bow...
    Posts
    1,326

    Thumbs down Re: Cell Phone MIDI Looping Problem

    From my knowledge on Nokia,Siemens,Motorola Phones... playing MIDI in JAVA always puts a delay on the end of the MIDI

  4. #4

    Re: Cell Phone MIDI Looping Problem

    oh, sorry, i thought it was a midi ringtone-oriented but i see it's for a game

    yes, lukpcn is right, when using java a slight delay is included at the end

  5. #5
    Power Profile User lukpcn's Avatar
    Join Date
    Nov 2003
    Location
    on the end of the bow...
    Posts
    1,326

    Talking Re: Cell Phone MIDI Looping Problem

    and YES it's PAIN IN THE A S S

  6. #6

    Re: Cell Phone MIDI Looping Problem

    Ok - thanks guys, for the help!

    The developer has decided just to have the piece be doubled/twice as long, so it will play through once, but sound like it is looping once.

    Thanks!!!!!!

    Eric
    =-=-=-=-=-=-=-=-=-=-=-=-=
    Eric Doggett
    MoonDog Media
    www.moondogmedia.net

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •