• Register
  • Help
Results 1 to 10 of 10

Topic: "emulated" midi drivers.

Share/Bookmark
  1. #1

    Re: "emulated" midi drivers.

    In all Steinberg products I also get \"Emulated\" - both on MOL and Unitor8 devices. I don\'t know whats up with that.

  2. #2

    Re: "emulated" midi drivers.

    Originally posted by Simon Ravn:
    In all Steinberg products I also get \"Emulated\" - both on MOL and Unitor8 devices. I don\'t know whats up with that.
    <font size=\"2\" face=\"Verdana, Arial\">Simon
    This is the article I was talking about...
    http://www.soundonsound.com/sos/sep03/articles/pcnotes.htm

    The fix for SX doesn\'t work for V-Stack

  3. #3

    Re: "emulated" midi drivers.

    Emulated drivers only work with Steinberg interfaces apparently. I have emagic & MOL midi as well. You need to add a dummy file in the SX folder called ignoreportfilter . Remove the file name extention (.txt) and SX will allow the non-emulated ports. I have seen Steinberg document this process but I don\'t remember where. Now over to the device manager go to the direct music options and click the \'Show\" option to no for every [Emulated} port. You should now be able to see only windows midi ports.

  4. #4

    Re: "emulated" midi drivers.

    Thanks Mattzen

    That did the trick [img]images/icons/smile.gif[/img]

    It works for V-Stack as well as SX. Just to be clear, I\'m sure you were talking about Device Setup in SX/V-Stack and not Windows Device Manager yes?

    Anyways it works!

  5. #5

    Re: "emulated" midi drivers.

    Yeah I just read about this \"trick\" at Cubase.net a few hours ago actually. It fixed a problem I had with Cubase SX MTC sync drifting more and more, the longer I had used the application. It apparently also fixes the \"MIDI notes appear earlier than I record them\" problem. I wonder why Steinberg use those \"emulated\" ports as default in any case. Must create a lot of problems for a lot of people.

  6. #6

    Re: "emulated" midi drivers.

    Hi Guys, this is something I have to do every time I re-install Cubase.

    As Mattzen and Simon have mentioned moving the ignoreportfilter file into the MIDI Port Enabler folder does both jobs of giving you non-emulated midi and recording midi on time. I have never had to remove a file extension though.

    The only other thing I do after that is to go and turn off the emulated ports in the Device Setup.

    Dave, yes it is the Device Setup for Cubase, not the Windows Device Manager.

    One of my few solid skills is rock-solid timing. [img]images/icons/smile.gif[/img] It drives me up the wall if I dont apply this fix as all my notes record early.

  7. #7

    "emulated" midi drivers.

    According to the latest Sound on Sound magazine, it\'s not a good idea to use the \"emulated\" version of MIDI interface drivers. You get noticeably higher latency and more slop/jitter apparently.

    I just looked in V-Stack, and ALL the MIDI drivers are \"emulated\" (they have the word \"emulated\" after the driver name.) This is for my Midisport, RME MIDI drivers and all the Windows stuff. I\'ve never seen these emulated drivers in Gigastudio, only in V-Stack.

    Does anyone know how to get the non emulated versions to show up? I\'ve never seen this in Gigastudio, only in V-
    Stack.

    TIA

  8. #8

    Re: "emulated" midi drivers.

    Actually I had to move that file OUT of the MIDI port enabler folder to fix the problem!

  9. #9

    Re: "emulated" midi drivers.

    Originally posted by Simon Ravn:
    Actually I had to move that file OUT of the MIDI port enabler folder to fix the problem!
    <font size=\"2\" face=\"Verdana, Arial\">Yes, that is the correct prodedure, as the DOCs indicate, when you are installing the program. (Sometimes it is worth reading the README!)

    You simply move the file from

    c:\\Program Files\\Steinberg\\CubaseSX\\MIDI Port Enabler

    to

    c:\\Program Files\\Steinberg\\CubaseSX

    Then in Device Manager disable all of the Direct Music MIDI ports, and use teh Windows MIDI ports. At this point you can also rename the ports, which is useful.

    Lawrence

  10. #10

    Re: "emulated" midi drivers.

    Actually I had to move that file OUT of the MIDI port enabler folder to fix the problem!
    <font size=\"2\" face=\"Verdana, Arial\">Sorry my mistake!

    You are right, move it OUT of that folder and into the application root directory (Cubase SX)

    Cheers, Scott.

Go Back to forum

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •