• Register
  • Help
Results 1 to 7 of 7

Topic: Vstack Giga3.0 rewire midi problem?

Share/Bookmark
  1. #1
    New Member
    Join Date
    Mar 2005
    Location
    Pittsburgh, Pennsylvania
    Posts
    7

    Vstack Giga3.0 rewire midi problem?

    I am running Giga3.0 on a PC with Vstack as a host. New to Vstack. Other intruments like Plugsound, Kontakt, etc open fine as VST instruments. Audio works, and MIDI works.
    But with Gigastudio3.0 I can only get the audio to work in rewire mode.

    I have my sequencer and DAW on a second machine (MAC).

    MIDI messages are getting into VSTACK because the other instruments are responding to MIDI messages, but GIGAStudio is not. I can play audio on the Gigastudio from the GIGA virtual keyboard. Giga is not hearing my keyboard MIDI messages, though.

    Can anyone help out an old man?

  2. #2

    Re: Vstack Giga3.0 rewire midi problem?

    GS3 works in two modes. It can connect to MIDI streams, and it publishes its MIDI connections, so others can connect to it.

    In the first case, go to Giga's System Settings and select the MIDI hardware that you want to send MIDI to Giga. Typically this would be a soundcard connected to your keyboard.

    In the second case you open your sequencer (or other MIDI generating software), and you configure that software to send the outputs to the Giga ports.

    So, how does one toggle between the modes? The simple way is to click on the little keyboard icon in Giga's lower right corner. If it's flashing you're in case two. Not flashing is case one.

    The other way to get into case two is to configure Giga to know the path of your sequencer app, and then launch the sequencer from Giga. The icon will now flash. Exit the sequencer app and the icon stops flashing.

    I'm not sure how you want to connect things. I don't own VSTack. But hopefully the above description will help.

    -JF

  3. #3
    New Member
    Join Date
    Mar 2005
    Location
    Pittsburgh, Pennsylvania
    Posts
    7

    Re: Vstack Giga3.0 rewire midi problem?

    Thanks for getting back to me.

    Gigastudio works fine in stand alone mode. It receives all MIDI information from both the keyboard and the sequencer located on the MAC computer.

    The problem with MIDI happens when I try to rewire it using VSTACK as the host on the PC.

    I'm probably not setting something up correctly in VSTACK or GIGASTUDIO when using giga in rewire mode. Like I said, audio is OK. Just not getting the MIDI signal into Gigastudio when rewired in the VSTACK host.

    I am probably just missing something simple but to this point unable to recognize it.

  4. #4

    Re: Vstack Giga3.0 rewire midi problem?

    Quote Originally Posted by lgs
    Thanks for getting back to me.

    Gigastudio works fine in stand alone mode. It receives all MIDI information from both the keyboard and the sequencer located on the MAC computer.

    The problem with MIDI happens when I try to rewire it using VSTACK as the host on the PC.

    I'm probably not setting something up correctly in VSTACK or GIGASTUDIO when using giga in rewire mode. Like I said, audio is OK. Just not getting the MIDI signal into Gigastudio when rewired in the VSTACK host.

    I am probably just missing something simple but to this point unable to recognize it.
    Hi if you do get this going OK could you please report your findings - I'm interested in doing the exact same thing (similar position - I run seq on a Mac) but am a little sceptical that it can really work!

  5. #5
    Senior Member
    Join Date
    Jul 2004
    Location
    Pluto, hydrogen 11 severnth
    Posts
    303

    Re: Vstack Giga3.0 rewire midi problem?

    I don't see the need for rewiring GS. Why not using Vstack as standalone for using the VSTi's (and use the ASIO driver for audio playback). Alongside you can use GS running on the GSIF driver! Ofcourse both programs use their own midi settings! What is the advantage of rewiring GS?

  6. #6
    New Member
    Join Date
    Mar 2005
    Location
    Pittsburgh, Pennsylvania
    Posts
    7

    Re: Vstack Giga3.0 rewire midi problem?

    don't see the need for rewiring GS. Why not using Vstack as standalone for using the VSTi's (and use the ASIO driver for audio playback). Alongside you can use GS running on the GSIF driver! Ofcourse both programs use their own midi settings! What is the advantage of rewiring GS?

    Thanks for the advise. I'm not sure my audio card can handle the burden of ASIO and GSIF at the same time. What audio card are you using in the PC?

    Thanks for helping an old man.

    Lou

  7. #7
    Senior Member
    Join Date
    Jul 2004
    Location
    Pluto, hydrogen 11 severnth
    Posts
    303

    Thumbs up Re: Vstack Giga3.0 rewire midi problem?

    Audiophile 2496 But i think alot audiocards will alow multiple driver usage!

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •