• Register
  • Help
Results 1 to 7 of 7

Topic: GSIF buffer size for Firewire 410?

  1. #1

    Question GSIF buffer size for Firewire 410?

    I have GS3 Ensemble (latest update) and an M-Audio Firewire 410 (latest update drivers). It's (finally) stable (touch wood).
    When I play the Gigapiano II, I get glitches on pedal changes. Tascam's doco suggests increasing the GSIF buffer size. But how? The Firewire Control Panel (hardware page) only has a control for "ASIO/WDM buffer size", which doesn't appear to make any difference to percieved latency or the glitch problem.

  2. #2

    Re: GSIF buffer size for Firewire 410?

    Could you describe your system?

    Motherboard? CPU? Clock speed? Amount of memory? Hard disks? Video card? What's in PCI slots? Operating system, which service pack? Any tweaking done to the OS?

    Not sure if anyone would be able to give you an answer, but without knowing more about your system there could be too many things that could be a problem...


  3. #3

    Re: GSIF buffer size for Firewire 410?

    I am just asking where can I find (and control) the size of the GSIF buffer.
    I don't understand how details of my system are related to that question.
    However, it's a Gigabyte motherboard (can't remember the model number) with a speed of 2GHz, with two WD 80GB drives, one Sony DVD RW, a Swann PCI card modem, a SB Live card (for Skype-chatting) and my Firewire 410 conected to the onboard Firewire port. There's 512 MB of RAM, and my video card is Matrox Millenium something-or-other. I'm running a pretty up-to-date Windows XP Pro, and the latest GS3 and M-Audio driver.
    As I said, GS3 is nice and stable, the only problem is clicking when I pedal the new gigapiano - a problem specifically mentioned in the Tascam FAQ, with a suggestion to increase the GSIF buffer size. But how?

  4. #4

    Re: GSIF buffer size for Firewire 410?

    The buffer setting you found is the one used for adjusting latency. Most likely it should work for GSIF as well as ASIO/WDM. You should try increasing the value.

    If you do not perceive any change in latency, it may not work for GSIF, but only ASIO/WDM.

    I think you may have a trouble with CPU loading, not the buffer size. If you get glitches only on pedal changes, it might be that you do not have fast enough PC to handle Giga Pulse processing.

    Try monitoring CPU load in Windows (Performance monitor). If you see it going much higher than 50% you need a faster PC to use Gigapulse. Try also using some versions of Piano that do not use Gigapulse.

    If the glitches go away when you don't have Gigapulse active, your problem is definitely CPU speed or something related (memory speed, etc.)

    If the glitches exist no matter what type of instruments you play, the problem is more likely in the buffer size, or something else. However, in this case you should hear glitches all along, not just on pedal events.


  5. #5
    Senior Member
    Join Date
    Apr 2005
    St. John's NL

    Re: GSIF buffer size for Firewire 410?

    I'm almost certain that Bogdan is right on the money. Here's why:

    I'm pretty sure the manual recommends increasing DMA buffer size. I tried this when I had the same problem (M-Audio Delta 44). GPII played fine without the resonace modelling, but glitches were frequent when pedalling in full modelled GPII, even at the highest buffer sizes with no other instances of gigapulse running. That was on my Celeron 2.4 with one gig of ram. Just got a new box with a p4 2.4 gig processor, and kept the gig of ram. Now GPII plays wonderfully. Somwhere in the gigapiano appendix you will find a note saying something to the effect that realtime convolution changes (like switching pedal up/down resonance) put a strain on your cpu load. I think it also says (or maybe this was another thread here or on the convolution forum) that RAM is pretty irrelevant, ie CPU is the heart of convolution. All this considered, I'm almost certain that your problem is processor speed. Tascam recommends at least P4 2.8 GHz or AMD-something or-other equivalent (sorry-don't know their numbering system) to use gigapiano 2.

    Hope this helps,

    ps...in terms of the actual question you asked, I use the M-Audio Delta 44, and its control panel has the DMA buffer size option in its "hardware settings" tab. If your M-A control panel is like mine, that's where this setting should be. As a final note, I'll just say that since I got the P4 I haven't had to change this setting from the default 256 samples. Good luck!

  6. #6

    Re: GSIF buffer size for Firewire 410?

    Thanks guys, you are probably right. I'll probably upgrade my computer in a few months. Hopefully non-realtime rendering will still be OK.

    However you can understand my original question if you look at this link:
    Where it says:

    "GigaPiano-II and GigaPiano-II LE
    If you hear popping in the audio as the sustain damper pedal is moved up and down:
    Try increasing the audio buffer size in your sound card driver...."

    It goes on to mention CPU load, but that first sugestion is pretty unequivocal.

  7. #7

    Re: GSIF buffer size for Firewire 410?

    maybe your ram latencies. Try a relaxed or auto setting for low latencies.

    hyperthreading disabled might also help.'

    hope this helps...



Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts