• Register
  • Help
Results 1 to 6 of 6

Topic: 22.05 kHz & FireWire Audiophile

Share/Bookmark
  1. #1

    22.05 kHz & FireWire Audiophile

    I'm working on a piece for full orchestra in Fin2005 w/GPO Studio and my poor 1.42 GHz Mac mini can't handle all those instruments. I want to try reducing the sample rate to 22.05 kHz to give the mini a fighting chance at playback, but doing this kills my sound module (M-Audio FireWire Audiophile).

    Seriously -- if I change the sample rate in GPO Studio to anything other than 44.1 kHz, the FireWire Audiophile stops outputting sound completely, not just GPO sounds but audio from any other app as well. (The MIDI I/O still works, though.) When I click on a note in a GPO Studio Player, the level indicator at the right of the window stays completely black.

    Changing the audio driver to "Built-in Audio" does "fix" the problem, in that the GPO sounds do play through the mini's headphone jack. Except (A) the FireWire Audiophile won't output any more audio until I restart the computer, and (B) my speakers are hooked up to my FireWire Audiophile, not the headphone jack on my mini!

    Any ideas?

  2. #2

    Re: 22.05 kHz & FireWire Audiophile

    You may have to change the sample rate directly in the soundcard as well. If the FireWire Audiophile is anything like the PCI version, then there's an application from MAudio that allows you to change settings for the soundcard (channel volumes, assignments, sample rates, etc.) Under Windows it's directly accessible via a tiny black "M" icon on the taskbar. I'm guessing there's something similar on the Mac. If I remember correctly, there's an option there that's called something like "Lock sample rate." If that's set, then the MAudio card won't change sample rates even though your host application (GPO Studio in this case) wants to. Unsetting this should allow the MAudio card to lock to different sample rates, or manually setting the sample rate to 22.05kHz should sync GPO Studio up with your soundcard. Hope this helps.
    -E

    "Welcome to Rivendell, Mr. Anderson."

  3. #3

    Re: 22.05 kHz & FireWire Audiophile

    Hey E,

    Thanks for the help. There is an app that allows me to configure the M-Audio FireWire Audiophile, but I can't get it to do what I want. For instance, on the "hardware" tab, there's an box that says "sample settings," and below that "sample rate detected" (which is, naturally, 44.1 kHz). However, I can't change that value manually.

    To the right of that, there's an option for "sync source" -- either "external" or "internal". It defaults to "internal." If I set it to "external," two things happen:

    1) The "sample rate detected" indicator switches to "unlocked." So far, so good, but...

    2) The device stops outputting any audio whatsoever and the S/PDIF "In" light starts blinking. That's bad.

    There doesn't seem to be any other way to unlock the sample rate, or to enter a custom sample rate.

  4. #4

    Re: 22.05 kHz & FireWire Audiophile

    I went out and took a look at the user's guide to make sure I wasn't giving you any bum advice. Looks like M-Audio took the option to manually lock/change the sample rate out of the app. Unfortunately, the "sync source" is for allowing you to use S/PDIF digital input to set the sample rate rather than apps on your computer, which is what the "internal" setting is for. So when you set it to external, the sample rate will go to unlocked, because it's waiting for a digital data stream from the S/PDIF port to determine what sample rate to use.

    The way it looks like it's set up, the soundcard (if the sync source is set to internal) should automatically detect the sample rate based on what information it's getting (in this case from GPO Studio). So I suggest that you start GPO Studio, start the hardware app, and change the sample rate in GPO Studio to 22k. The big sample rate display in the M-Audio app should read 22k if it's truly syncing up. If it stays at 44k, then there's some sort of disconnect between the M-Audio drivers and GPO Studio or maybe the Mac OS. If this was a Windows installation I'd suggest reinstalling the drivers, but since the Macs have traditionally been more bulletproof when it comes to drivers and software installs, I'm not sure that advice would really apply here. You may have to get help from M-Audio on this. If you call them and you feel you're not getting anywhere, use the magic phrase "I think we need to escalate this to the next tier." That's help desk talk for "I need to talk to somebody who knows more than you do on this stuff."
    -E

    "Welcome to Rivendell, Mr. Anderson."

  5. #5

    Re: 22.05 kHz & FireWire Audiophile

    Quote Originally Posted by Easy_Rhino
    Looks like M-Audio took the option to manually lock/change the sample rate out of the app.
    That's what it looks like to me. I can set it manually in OS X's Audio MIDI Setup utility, but not below 44.1 kHz.

    So I suggest that you start GPO Studio, start the hardware app, and change the sample rate in GPO Studio to 22k. The big sample rate display in the M-Audio app should read 22k if it's truly syncing up.
    I tried that. Unfortunately, the sample rate remains 44.1 kHz, GPO reports some kind of critical driver error, and the M-Audio device stops outputting any sound whatsoever, including system audio.

    You may have to get help from M-Audio on this.
    Argh. That's what I was afraid of. I don't have time to sort this out now -- I'll deal with it in a few weeks.

    But thanks for all your advice! It's greatly appreciated.

  6. #6
    Member
    Join Date
    Nov 2003
    Location
    Kauai, Hawaii, USA
    Posts
    685

    Re: 22.05 kHz & FireWire Audiophile

    Call M-Audio at 626/633-9055 -- they're nice folks and just waiting by the phone to guide you through it! (Been there!)

    KevinKauai

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •