• Register
  • Help
Results 1 to 6 of 6

Topic: Sustain pedal in GigaEditor

Share/Bookmark
  1. #1

    Sustain pedal in GigaEditor

    I've used Chicken Translator to convert some Kurzweil piano files to GIGs. It works OK with one big exception. The GIGs play as if the sustain pedal is down, and they don't respond to the pedal (i.e. the notes sustain whether the pedal is down or not).

    So far Garth hasn't been able to help me. This seems like something that should be easy to fix with the Editor, but I haven't been able to find the parameter. I've searched the help files and the manual, but no luck. Can anyone tell me...

    How do you get a GIG file to respond to the sustain pedal as a sustain pedal?

    Thanks in advance!

  2. #2

    Re: Sustain pedal in GigaEditor

    Can anyone help out with this?

    Thanks!

  3. #3

    Re: Sustain pedal in GigaEditor

    Perhaps you can write down some settings and post them here.
    With the translated piano in the the GS3 editor, what are the values under ENVELOPE 1 (amplitude)?
    Is there anything assigned to the DIMENSION CONTROLLER section(the rectangular boxes between the VELOCITY and ALL PARAMETERS windows)?

    You may want to open.....Giga or mega Piano II and compare values. You may even be able to SAVE a MACRO (NOT an Articulation)from the giga piano and APPLY it to the new piano. If you do this, make sure you engage the SELECT LOCK icons at the bottom of the Editor (basically, solid green and solid yellow) before saving a macro and just leave them in that state for applying the macro to the new piano.

  4. #4

    Re: Sustain pedal in GigaEditor

    Thanks, pbug. I had a look at the amplitude settings. I haven't found any consistent difference between the pianos that handle the pedal properly and the ones that don't. Saving and applying the macro didn't do the trick either. I've got another bug report in to Garth, and I hope he'll come up with something.

  5. #5

    Re: Sustain pedal in GigaEditor

    Sorry I couldn't help, I wish I could play with that here!
    I once translated a organ and it ended up with velocity....like a piano. That was an easy fix.

    There's an iMIDI rule to filter Key Off. Make sure it didn't end up getting translated with ANY imidi rules applied. I don't see how that would be possible.
    So there are no SPLITS assigned in the dimension controller?

    Good luck with that!

  6. #6

    Re: Sustain pedal in GigaEditor

    Quote Originally Posted by potatobug
    Sorry I couldn't help, I wish I could play with that here!
    I once translated a organ and it ended up with velocity....like a piano. That was an easy fix.

    There's an iMIDI rule to filter Key Off. Make sure it didn't end up getting translated with ANY imidi rules applied. I don't see how that would be possible.
    So there are no SPLITS assigned in the dimension controller?

    Good luck with that!
    There were no splits. But putting in a controller 64 split didn't activate the sustain pedal.

    Thanks again.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •