i have white grand piano, using kontakt 1.53, and i am having problems controlling the volume from my keyboard using CC#7. what i've tried doing, and it works for other sounds that came with kontakt, is clicking on EDIT, and then right click on the volume knob down in the amp section, and select AUTOMATION, and then choose the midi control 7. i've tried it with the button enabled and disabled that says something like 'allow soft control" or something like that.

when i move my knob that is assigned to cc#7, i see the volume control knob in kontakt move, but it doesn't actually change the volume. this is the weird part! because this works on other samples i tried.

any ideas? i'm going to be playing a live gig on monday and would like to be able to control my volumen a little bit at the keyboard and this would help a ton. thanks!