• Register
  • Help
Results 1 to 8 of 8

Topic: some problems.

  1. #1

    some problems.

    Hi all.

    Recently I've been experiencing some problems with Garritan and Cakewalk home studio. My CPU usage is pretty high (the cpu % reading at the bottom of cakewalk home studio). Like right now, all I have is an aggressive string section playing, timp, snare, and brass, and I'm on 75%? Is this normal? (I also have other strings loaded too, but not playing). edit: when the sus+short string patches (4-5) are playing, I am on 27%.

    I'm on an SBLive. Does this have something to do with it? I've been wanting to upgrade my card, and am considering the upgrade to an M-Audio Revolution. Basically what I did yesterday was install the kx drivers for SBlive. It fixed a few things like made my strings less hissy, but now I get pops etc. Does the soundcard have anything to do with why my cpu usage is so high?

    Also I tried to use VST with cakewalk home studio (I have the adaptor thing). It seemed to work, but then if I press stop in the middle of a note playing, all the notes just keep carrying on (like a massive reverb echo or something, but forever!)...and the only way to stop the noise is to close Cakewalk.

    Can anyone help me with these problems? Should I grab the M-Audio revolution?

    Windows XP
    1GIG RAM
    SBLive 5.1 with kx drivers (latency of 2ms or so)
    Cakewalk Home Studio (DXi)

    I'm using reverb on 2 garritan players (not wet samples though). But after taking them off it made hardly any difference.


  2. #2

    Re: some problems.

    SBLive 5.1 with kx drivers (latency of 2ms or so)
    Do you really mean 2ms? This may be part of the problem. Set your latency higher, say 10-20ms and see if that improves the situation.

    Also, the timpani are notorious for CPU consumption, particularly in "busy" passages. Reduce the polyphony of the timpani from the default of 64 down to something lower, like 16, and see if that helps. If you need to know how to reduce the polyphony, post back to this topic.

    and the only way to stop the noise is to close Cakewalk
    Does home studio have a "Reset" or "Run/Stop Audio Engine" button like SONAR? That will do it.

    You can get all sorts of anomalous behavior when you're pushing the limits of the CPU. That may explain the run-on sounds.

  3. #3

    Re: some problems.

    Thanks for the reply. How do I reduce the polyphony? I tried changing the latency to 8, 10 etc. and no difference. If I got a revolution card from M-audio would it fix any of these problems? (specifically the cpu thing). I've heard it's a good card to use (and it's in my price range)...



  4. #4

    Re: some problems.

    If the high CPU occurs at a point where the timpani is doing a roll or close to it, then lowering the polyphony will help:

    Below the "CPU Usage" box on the player window are two smaller boxes. The right-hand box is the polyphony.

    When you've selected the timpani slot, the polyphony will display as 0/32.

    Click and hold the left mouse button on the 32 and drag downward to reduce the polyphony, say to 8 or 12 or so and see if that does the trick.

    BTW, my former DAW was a 2.0GHz P4 with an old SBLive. I actually used the MMC drivers on that machine. I was never able to get the KX drivers to work well. The WDM/KS drivers also will work, I think. But try the MMC drivers and see if you get better results.

    I can't comment on the M-Audio card. Maybe someone that is using that card will see this thread and comment. M-Audio is fairly popular with members of this forum.

  5. #5

    Re: some problems.

    Thanks for that. I'll try it. Also, looking at the CPU usage on the player as each instrument is playing...the short aggressive strings are taking over 20-40%! The polyphony for the timp was already on 0/13, and the aggressive strings are like 0/8.

    If I take everything down a bit the CPU gets better...not a lot, but some. What exactly does taking the polyphony down do? I can't hear a difference in the sound,heh.



  6. #6
    Senior Member rwayland's Avatar
    Join Date
    Jun 2004
    California Redwoods

    Re: some problems.

    Your latency setting probably ought to be adjusted more. Start with about 50 ms, with buffers at 512. Also, since you have the VST adapter, be sure to use it, as it is considerably less demanding of cpu.


  7. #7
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: some problems.

    Make sure you're loading the 'dry' sounds. The 'wet' sounds use up CPU fast.


  8. #8

    Re: some problems.


    -I tried messing with the latency. No differences.
    -the samples loaded are dry.
    -The aggressive strings are taking the most RAM. (by quite a bit) Even so, 20 something percent for 4 samples playing? (the normal strings at the start of the piece).

    I would've thought a P4 2.53GHZ with a gig of RAM could easily handle these. Hmm.


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts