• Register
  • Help
Results 1 to 3 of 3

Topic: Legato using GPO and Logic Pro

  1. #1

    Thumbs up Legato using GPO and Logic Pro

    Hi all. I'm not sure whether this is a Garritan issue or a Logic issue so I'm asking folks in both forums.

    I understand that legato is controlled by the CC#64, sustain pedal. Is there any way that I can have 12 bars of a violin or piano passage play every note legato without having to manually insert controller on and off events around each note to make them play legato?

    I know that having all the notes connect to each other and reducing the velocity of the notes also gives a legato feel, but I feel like there should be a way to bracket notes (pedal-down just before the new note starts, pedal-up just after the new note starts) with the CC#64 sustain pedal (true legato) without having to do them each individually.

    Any thoughts are appreciated.

    Thanks for your help!
    Last edited by Justin.H.Cohen; 12-31-2005 at 01:02 PM. Reason: Changing question mark to thumbs up so people no longer think I have a question.

  2. #2

    Re: Legato using GPO and Logic Pro

    Hi Tom. Thank you very much for your reply.

    Unfortunately, if I pedal down after the first note is attacked and don't insert a pedal up until after the last note of the legato phrase starts, all of the notes are blended together. Just as if I were playing piano and held the sustain pedal down the entire time I played.

    I've written a midi passage in Logic Pro and I'm playing it with a GPO full string ensemble on a Mac. I think there must be a difference between the way Logic Pro interprets pedal downs and whatever you are using to play the GPO instruments.

    Or is there an option on the Kontakt player after I load the strings that I'm just not seeing? Actually, that's probably where I'm going wrong.

    On the Kontakt player I see the drop down menu that has selections for Velocity, pitchbend, etc, CC#64 pedal. To the right of the drop down menu is a fader that can be moved horizontally. I've played around with fader and the different drop down menu selections while the instrument is playing the midi passage and have not heard any affect. The fader moves left and right and the values change from 100% to negative 100% respectively with me not hearing any change to the output. I can, however, hear changes when I adjust the tune, pan and volume knobs.

    Perhaps my inability to use this dropdown menu is the root of my problems?

    Thanks again for your input. Any further assistance would be greatly appreciated.


  3. #3

    Smile Re: Legato using GPO and Logic Pro

    Thanks, Tom! That did the trick. It seems that either of the "no sustain" settings in the options drop down will work.

    Thanks again,

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts