• Register
  • Help
Results 1 to 2 of 2

Topic: PMI Old Lady Clicks and Pops

  1. #1

    PMI Old Lady Clicks and Pops

    I love this Piano, but I can't seem to get click free.

    Here's the low down:

    Asus A8n5x
    Athalon 3800 dual Core.
    1 gig Ram
    Maxtor 100 gig (primary)
    WD 200 gig (gigs and audio files)

    Aardvark Direct Pro 24/96 (soon to be replaced)

    Win XP Home (No Updates, and No SP2)
    Giga 3 ens
    Cubase SE

    I've tweaked setting after setting, tried running it as the only instrument in giga and cubase, but I just don't get consistant performance, even pedal up.

    I looked for hardware requirements on the PMI website but couldn't find any.

    Would more RAM do the trick?

    Different sound card?

    Is my set up bugy? (I admint, this thing crashes once in a while.)

    thanks for reading,


  2. #2

    Re: PMI Old Lady Clicks and Pops

    You should definitely use the forum's "search" function to look through prior posts -- your problem is a common one.

    Clicks and pops are often caused by setting your sound card's buffer size too low.

    What are your sample rate / buffer size / samples per buffer / etc. sound card numbers?

    This web page is talking about different hardware, but the concepts are applicable here, too:

    What does Override Internal Buffer Size do?

    The "Override Internal Buffer Size" setting is found in Performer or Digital Performer's Configure Hardware Driver dialog box when the Audio System is set to use the built in jacks on the mac. MAS defaults to an internal buffer size setting of 1024 samples per buffer. This buffer size setting can be adjusted to another setting other than the default 1024 samples. Lowering the buffer size can reduce latency on faster processors. However, the payoff of lower latency will be slower response in Digital Performer. Realistic override settings are 512 or above. Alternately, if you encounter audible pops, clicks or distortion in your audio, you may want to increase the buffer size. You do not want to set a buffer larger than the default.
    Some other thoughts: does the sample rate that you've selected in Giga's Configuration Manager match the sample rate that you've selected in whatever app accompanies your sound card?

    Are you overloading your CPU? Keep an eye on the CPU meter as you load/launch/play the piano...

    Good luck!!
    — alanb




Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts