• Register
  • Help
Results 1 to 10 of 10

Topic: K2 can't see the nki file...

  1. #1

    K2 can't see the nki file...

    I've just installed the Stradivari samples and nki to my audio instruments drive. The problem is the nki doesn't appear in the K2 list, unless I put in the samples folder, but then, every time I drag the nki to the rack it cannot find the samples, so I have to go through the tedious procedure of showing the nki where all the samples are. Should the nki go in the samples folder? It's not clear in the manual, which states that all the DVD contents should go on the desired directory of one's hard drive. But if I take the nki out of the Stradivari samples folder it disappears from the K2 files list! This is quite annoying.

    This afternoon it seemed to work: how can the nki go missing in the space of a few hours, without my having changed anything?!


  2. #2

    Re: K2 can't see the nki file...

    The Samples folder should be a subfolder of the Stradivari folder, which holds the .nki file. I don't know why Kontakt wouldn't see your file; did you select the Database tab without Rebuilding the database first (after installing the Stradivari)?

  3. #3

    Re: K2 can't see the nki file...

    Hi, Nickie. I will take a look at that in the morning: it's been a l-o-n-g day. I did rebuild the database, though, and when I first copied the data over it seemed to see the patch, but then didn't. I suspect,if I follow your heirarchical advice it'll work. I'll let you know.

    It sees the nki if it's in the samples folder: clearly not the right way to do it, since when I open the patch I cannot find the samples each time.


  4. #4

    Re: K2 can't see the nki file...

    Do you have the latest updates Strad file see here at

    That corrected some problems with the original Strad where kontakt could not load a few of the sample files. (As I recall two samples had incorrect internal names.
    See here for original problem
    Topic: PROBLEM: Loading Stradivari samples into Kontakt2

    See this for any problems with keyswitches not being visable
    Topic: Strad help - where's my keyswitches?

    Once version 107 is loaded-if Kontakt load it correctly you're home free

    if you have to manually find a few of the samples, once you do get it loaded properly onto kontakt, Save using a different file name like "strad v107 fixed.nki" into the sane location as the original .nki file (Save just the .nki file not the samples)


  5. #5

    Re: K2 can't see the nki file...

    Thanks for the info there, Fred. I'll look into it. Things are still not right. K2 simply cannot see the .nki, unless I place within the samples folder. If I create a folder, called, eg: Stardivari and place the samples folder and .nki in that, K2 cannot see the .nki. This is very odd, since I have a very large amount of libraries for it and they're fine. It took me over 40 minutes yesterday to rebuild the database: I don't want to be doing that every day.

    With the .nki visible inside the samples folder, if I then open the Stardivari patch, it can't find the samples! I've downloaded the latest .nki (1.07) to no avail.

    I'll take a look at you suggestions. It seems very unsatisfactory that I should have to start renaming files, as a fix.

    No problem with the keyswitches, though, except another pair of hands would be nice.

    The problem,as far as I can see, is not that it won't load the samples: it loads all of them once told where they are, but having to do this every time I want to open the Stradivari is,frankly, annoying. Appreciate the help.

  6. #6

    Re: K2 can't see the nki file...

    OK,Fred, renaming the .nki fixed the problem, I'm very happy to say! Is this a K2 bug, or what? Not being discourteous to anyone, and respectful of the obvious hard work that went into creating such a magnificent instrument, but for something as obvious and simple as this not to work out the box....seems a bit odd.

    If it's me, then I take it all back and will get the humble pie in the oven. Anyway, thanks very much!

  7. #7

    Re: K2 can't see the nki file...

    Hi strawinsky
    If you have even once loaded the file, and it plays correctly, then all you need to do is save the file (patch only- not samples) either overwriting the original .nki or (my preference) giving it a new name.

    The Kontakt 2 SAVE dialog box gives you several choices - choose the "Patch Only" option
    Once you've done that always load the new saved file and Kontakt will automatically load the samples for you.
    Let me know how it works

    OBTW Even if the K2 database somehow can't find the strad .nki file you should always be able to locate the file using "File" in the browser section

    In my particular installation my Strad .nki file is located in drive H:\Garritan Stradavari directory and underneath that is the sample directory " The Stradavari Violin V1.06 samples"


  8. #8

    Re: K2 can't see the nki file...

    That's what I did, Fred: all is now well,thanks!

  9. #9

    Re: K2 can't see the nki file...

    Great - enjoy.
    It's a extraordinary program!!!!

  10. #10

    Re: K2 can't see the nki file...

    Thanks: I'm already using it on a faux classical project .

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts