• Register
  • Help
Results 1 to 4 of 4

Topic: Convert Giga-MIDI to Audio in Cubase

  1. #1

    Convert Giga-MIDI to Audio in Cubase

    Hi, all

    I'm having trouble converting MIDI to audio.

    I was fine with converting VST instruments recorded within Cubase.

    The problem is converting MIDI that’s been routed through gigastudio (V 2.5)—with a US-122 Audio-Midi Interface.

    My MIDI guitar records into Cubase OK, but when I try to transfer it onto an audio track, the keyboard’s internal piano sound records instead. Local control on the keyboard is turned off.

    I tried every variation I could think of:
    I created a new audio mono track (then I tried a stereo track), soloed MIDI guitar and audio, and hit record.
    Audio channel is: stereo in/ stereo out.
    MIDI is: in: All MIDI inputs/ out: US-122

    I even tried adding a virtual port (“Maple”). Same deal—it recorded keyboard sound instead of giga-MIDI-guitar.

    What am I missing?


  2. #2

    Re: Convert Giga-MIDI to Audio in Cubase


    I probably should not be answering this since my Giga/Cubase computer is just sitting in the room waiting for me to get to to them...however.

    When purchasing my soundcard (Hammerfall 2496DSP) I was told by the owner that the only way he could get Giga into Nuendo was by going OUT the SPDIF W/GIGA and right back into the IN SPDIF. It is truly all I know but maybe it will give you a work around.


  3. #3

    Re: Convert Giga-MIDI to Audio in Cubase


    your midi out should point to one of the Gigastudio ports; i think with giga 2.5 the first port would be named "Nemesys midi port 1". Then create a new stereo track, solo the midi channel and then set the input of the audio channel to the mixer output of your audio interface.


  4. #4

    Re: Convert Giga-MIDI to Audio in Cubase

    A belated Thank you, Karin and Congalocke.
    You helped me figure it out.
    Here are my detailed notes, for the next newbie who comes along:

    Convert MIDI To Audio:
    With Giga MIDI, Cubase Sequencer, US-122 Audio Interface/sound card, Triton keyboard controller.

    1) Turn on Triton Keyboard / Global / Menu / MIDI (F2) / Open (F8) / Local Control Off [ ] [Unchecked] (with INC key)
    2) US-122
    a. Direct switch: on / Mono switch: on
    b. Rear of US-122: 2 RCA lines out (L & R) à go to front of US-122, 2 line/ guitars in (L&R), and top switch is on “Guitar”
    c. “Line out” dial: controls the monitor levels AND controls the signal. Put at 12:00. NOT higher; I get a bad hiss and distortion on playback. I can normalize sound later if necessary.
    3) Open Giga file, load the correct MIDI instrument in port 1
    a. DSP station: add NFX1 reverb / [Edit] FX / Change FX amount
    b. Settings / hardward & routing / Hardware: US-122 / Sample rate: 44.1 kHz / Bit depth: 24 bit / MIDI In port: US-122 MIDI port / MIDI out: Nemesys
    c. Open Cubase (3-note-icon) through Giga
    4) In Cubase:
    a. Audio Guitar: use same audio track that I set up when I recorded MIDI:
    i. IN: Mono In [Stereo is OK, too]
    ii. OUT: Stereo out [If necessary, go to Devices / VST Connections / Inputs / [Add Bus] / Mono in]
    iii. Track lane: [S] (*) (M)---Solo, Record, Monitor [To play back afterward, turn monitor off]
    b. MIDI Guitar: (Open an audio and a MIDI track)
    i. IN: ALL MIDI
    ii. OUT: Nemesys
    iii. Channel: (1), Bank (0)
    iv. Track Lane: [S] (*)---Solo, Record
    v. [ ] Send is activated, ie, blue; sends FX from Giga to Cubase
    vi. MIDI track is activated (ie, selected track). Audio is not.
    c. In Transport, Rec. mode is “normal” not replace or merge…and “mix” (MIDI)
    d. Finally, hit record. MIDI track will record to Audio track in real time. If volume is too low, normalize (select audio track / Audio / Process / Normalize / Process)


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts