• Register
  • Help
Results 1 to 8 of 8

Topic: Modwheel, GPO, and Logic (old news, new post)

Share/Bookmark
  1. #1

    Arrow Modwheel, GPO, and Logic (old news, new post)

    I remember reading posts here regarding the modwheel reset problem when running GPO under Logic (but couldn't find them after an extensive search of the forum). So I'm bringing this issue to the fore in an effort to explain the behavior and b) ask if anything can be done about it.

    SUMMARY: Under certain (and typical) circumstances (see below), when Logic is stopped, the program sends a modwheel=0 value to all instances of GPO instruments. This means that it's not possible to play GPO instruments when the sequencer is stopped unless you physically move the modwheel to some value that allows the patch to again be heard. Multiply this extra effort when working with a full compliment of instruments and it gets really tired in short order. It's quite the productivity-killer.

    BEHAVIOR:

    1. If modwheel data (even a single event) of any value is contained within any recorded tracks playing GPO instruments, Logic will reset the modwheel value to zero for those instruments when you hit STOP.

    However...

    2) Logic will not send a modwheel=0 message to the instruments if:

    a) there is no modwheel data contained in your track(s) and
    b) you have sent the instrument(s) a non-zero, static modwheel value via any one of the following methods:

    • moving the modwheel as found in the Garritan Kontakt Player GUI
    • sending modwheel info from your controller
    • sending modwheel info via any of Logic's internal virtual knobs programmed to output CC#1

    Now, it may seem that the behavior described in #2 above would be a viable workaround for preventing Logic from resetting the volume of GPO instruments to zero, but it's not. The long and short of this situation is that you can't have recorded modwheel data in a track and also play that instrument when Logic is stopped without having to go through an extra step (i.e., manually setting the modwheel to some value).

    Gary, has there been any communication between yourself and Apple/Logic to try to remedy this problem? If not, would it be possible for such a conversation to happen?

    Many Thanks!

  2. #2

    Re: Modwheel, GPO, and Logic (old news, new post)

    Hi Orkguy

    I've gotten so used to this I hadn't even thought about it, but yes, this issue still exists with Logic and GPO, and yes, your observations are correct.

    If I don't record the modwheel as part of the performance, I usually draw in this information in the hyper editor for that particular instrument. It's a variation on your #2 explanation. When I'm simply comping something out, I usually just record the modulation ramping up to about mid-level onto the track itself, so at reset, there's at least something being heard. I tend to copy and paste these onto any GPO tracks without even thinking about it, so as to keep the workflow going.

    Not sure if that helped or not, but it would be nice to see this issue resolved someday.

    pax

  3. #3

    Re: Modwheel, GPO, and Logic (old news, new post)

    Quote Originally Posted by gpax
    When I'm simply comping something out, I usually just record the modulation ramping up to about mid-level onto the track itself, so at reset, there's at least something being heard. I tend to copy and paste these onto any GPO tracks without even thinking about it, so as to keep the workflow going.
    I'll do the same in order to make sure I can hear a part that I might have otherwise neglected to write into a track, but still, entering that data is of no help after hitting stop; basically, per my point #1 above, anytime Logic is made to stop it will reset the GPO instruments to a modwheel=zero condition.

  4. #4

    Re: Modwheel, GPO, and Logic (old news, new post)

    OK... since there's been no reply from the Garritan crew on this rather serious GPO+Logic performance issue, and, since it's been a source of paramount agitation for the past few weeks during my work, I decided it was time to do try and figure it out myself. In the process I got a little help from some friends on some other forums, and the results are in...

    THERE IS A SOLUTION TO THIS PROBLEM.

    Anyone interested in hearing about it?

  5. #5

    Re: Modwheel, GPO, and Logic (old news, new post)

    Yes, I’m interested… I’m guessing it has something to do with transformers in Logic?

  6. #6

    Re: Modwheel, GPO, and Logic (old news, new post)

    Ah, an interested party. Yay!

    Nope, has nothing to do with transformers. The fix is actually amazingly straight-forward, but there are fine points to consider as well.

    First an acknowledgement... the fix is not something I discovered on my own. A stealthy Fred B., member of the Apple/Logic discussion forum, came up with this one as part of a thread I started there on general problems with plugs (including GPO) and how they perform within Logic.

    OK, on to the fix!

    The main thing to do is to check the "no reset" parameter for the audio instrument hosting your GPO pluggy.

    (CORRECTION)

    • in the Arrange window, select a track assigned to your GPO instrument and checking the "no reset" parameter. If you don't see this parameter, click the triangle on the LH side of the screen to access the parameters.

    NOTE #1: If you're using a multi-instrument as the front-end, you can check the "no reset" parameter checkbox for each individual "sub-channel".

    (It occurs to me that perhaps checking the "no reset" parameter for the audio instrument itself, rather than each individual sub-channel, might just do the trick for the entire audio instrument. Might be worth experimenting with.)


    Next, go to Prefs>Audio>General>Reset and make sure that the modwheel box is unchecked.

    NOTE #2: This almost goes without saying, but you need to check "no reset" for all instances of GPO instruments in order for this fix to be effective.

    EXTRA -- Sustain Pedal/Legato Fix: the interaction of GPO and Logic with respect to using the sustain pedal as legato on/off is also problematic. In short, sustain pedal events-->GPO don't chase correctly in Logic under certain conditions. To fix this, check the sustain pedal checkbox under Prefs>Audio>General>Reset. In fact, check it, uncheck it, then check it again. You may need to do this while a track is actually running too. (This is because Logic seems to have a problem getting the sustain=checked state to "stick". Once it does, it works great.

    HTH.

    -=orkguy=-

  7. #7

    Angry Re: Modwheel, GPO, and Logic (old news, new post)

    Quote Originally Posted by orkguy
    Ah, an interested party. Yay!

    The main thing to do is to check the "no reset" parameter for the audio instrument hosting your GPO pluggy.

    (CORRECTION)

    • in the Arrange window, select a track assigned to your GPO instrument and checking the "no reset" parameter. If you don't see this parameter, click the triangle on the LH side of the screen to access the parameters.

    -=orkguy=-
    Thanks Orkguy

    But if GPO is inserted on an Instrument track, the ‘no reset’ parameter isn’t available; it’s only available on 'normal' MIDI tracks is it not?

    Anyway, it all seems rather academic ‘cos I can’t even get past the stuck notes bug! Grrrrrrr


    =====EDIT=====

    NI have just replied:

    “Logic 5 PC is not a supported host program.

    Stuck notes are a known problem in Logic and wont be fixed

    since its a problem with the logic vst interface. A workaround

    could be to have the GPO Audio Instrument Track selected.

    Our current releases are fully incompatible to Logic PC.”


    So that’s it then… a waste of time trying to run GPO in Logic PC!

  8. #8

    Re: Modwheel, GPO, and Logic (old news, new post)

    Quote Originally Posted by TnT
    But if GPO is inserted on an Instrument track, the ‘no reset’ parameter isn’t available; it’s only available on 'normal' MIDI tracks is it not?
    If your version of Logic on PC is anything like it is on Mac these days, the object itself (MIDI or audio instrument) will indeed have a "no reset" checkbox available in the Arrange page. So in Arrange, assign your audio instrument to the track and then click on the triangle in the Arrange page to expose the no-reset checkbox. Sorry if I didn't make that clear previously.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •