• Register
  • Help
Results 1 to 3 of 3

Topic: 2.54 on an X2: No midi ports

  1. #1
    Senior Member Steve_Karl's Avatar
    Join Date
    May 2004
    Pittsburgh, PA 15206 USA

    2.54 on an X2: No midi ports


    I've been trying to get GS 2.54 running on an Athlon 64 X2 4400+ and can't get any midi ports to function.
    MidiOverLan is working fine and I can get it to receive test signal but I just can't get the port indicators in GS to go Green. They're always Gray.

    The keyboard in GS is also not working. I've reinstalled everything 3 times and the results are always the same.

    I've tried it with XP SP-1, SP-2 with and without the dual core drivers and no go in any situation.

    I've been successfully running GS 2.54 for a few yrs. with MidiOverLan and never had this problem until I tried it on this new machine.

    Are there known issues with X2 processors?
    Is anyone having success with 2.54 on an X2 or dual core?

    Any and all thoughts are welcome.


    64 X2 Toledo 4400+
    MSI neo2Platinum (7025)
    3GB OCZ ram
    ati 8500DV
    Gina 24 WDM
    3 Samsung 250GB IDE Drives

  2. #2

    Re: 2.54 on an X2: No midi ports

    Hi Steve,

    I'm wholly unfamiliar with a lot of your setup, so I'm afraid I can only ask simple questions in the hopes that something proves useful...

    Is this a MIDI-keyboard problem, or a sequencer-app problem or both?

    Have you launched Giga's "MIDI-monitor" ... which I think is [Ctrl+R], to see whether anything is being received by Giga, albeit perhaps on the wrong channel, in connection with a single key-up/key down action?

    Is it possible that you inadvertantly changed the channel upon which your keyboard is transitting MIDI data, or that MOL is mapping the keyboard's MIDI data to a different channel?

    Have you double-checked all of the MIDI/hardware settings in Giga's Configuration Manager?

    Under your setup, is Giga working in standalone mode or rewire mode?

    Can you try playing Giga using a keyboard connected directly to the Giga machine, as opposed to a keyboard/sequencer on a different machine which communicates with Giga via MOL (which is what I imagine your setup involves)?

    Have you considered updating Giga to v3.21?

    I don't think that pre-v3.12 Giga will run on a dual core machine...

    Also, check this: http://tascamgiga.com/faq.html#Athlon

    Sorry that I couldn't be more helpful...
    — alanb




  3. #3
    Senior Member Steve_Karl's Avatar
    Join Date
    May 2004
    Pittsburgh, PA 15206 USA

    Re: 2.54 on an X2: No midi ports

    Thanks ... but most suggestions don't really apply to this issue.
    I have years of experience with MOL and GS 2.54 or 3 other machines.

    It's not necessary to input signal to get a green reading on the port indicators. The green means it recognizes the ports.

    See the images here and it might be more clear to you.

    Inactive but recognized:

    Recognized and active (busy)


    MOL LAN ports, Local Pipes, and also Tascam PCI-822 midi ports have been tried an all and not able to be recognized by Giga.

    They are all recognized and working in other software.

    Also, the onscreen keyboard in GS has always worked in all other setups.

    Thanks again.

    I'm hoping someone else will have an idea.

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts