Is anyone out there using Logic on a network together with other composers, with shared samples and audio on an external RAID system via File Server? If you are, can you please offer some advice on what does work, because at the moment our system does not!

We are a studio with 3 workspaces & 3 G5 Macs, making music for TV and media. Our samples and our music archive are on 2 separate RAID 5 configurations of about 2TB each. The samples are on one of the RAIDS, most of the music Archive on the other RAID. A G4 Dual operates as file server. Our RAID system hardware is custom, not Apple's X-serve.

This system served us well for a year or two, but now we are having extreme difficulties for the second time in several months. The system has actually had a heavier load because in the last few months we went from 2 Workspaces to 3, but it's hard to make a direct correlation between this and the current problems.

What's happening is that repeatedly the data on the RAID system becomes unavailable -samples get cut off, and in exs24 you can see the "couldn't get samples in time" error. The problem is probably more serious than just a bottleneck of data because when it occurs, files also become inaccessible via the Finder: in other words, we can navigate through the folder structure within the Finder, but the individual files themselves can't be previewed as is usually possible from the Finder; when you click on the Preview triangle (for an Audio file let's say) there is the message "fetching", and you wait....and wait. Generally a Restart of Logic, or a Fileserver Restart cures the problem but only for a very short time (sometimes minutes, sometimes hours) before it crops up again. Basically, communication between the Workspaces and the RAID system at file level is hung up or lost completely.

This problem caused our File Server computer to have Kernel Panics (last Autumn) and we thought there was a Data Registry problem on one of the RAID systems, so we re-initialized the RAID hoping that would cure it. Things went fine for a few months, but last week the File Server had a KP again and according to my computer Tech the problem is similar to the one we had before.

We have multiple deadlines every week, and I originally chose this system for its capacity and reliability as our organization has expanded. At the weekend we will try out a different File Server configuration - a G5 and a more powerful Switcher. What I don't know is whether the problems are hardware-based or actually a result of using Logic on a Network, which perhaps it was never intended for.

Any feedback/advice/suggestions would be much appreciated. We're all on Logic 7.2.3 under OS 10.4.7.

Thanks very much