• Register
  • Help
Results 1 to 10 of 10

Topic: Piano samples turn off in Kontakt 2

Share/Bookmark
  1. #1

    Piano samples turn off in Kontakt 2

    Maybe one of you has a solution to this. It could be that I am the only one. Perhaps we all have this problem? Either way, I am fed up and either need a fix or I forget about using sampled pianos in Kontakt 2.

    What is happening is when I play, say, a treble chord and anything else (even one stinking note) in the bass range, if held down for a bit, notes turn off (possibly the dreaded note stealing problem I've read about?)

    It records this way, too. It happens in EVERY piano library I have that uses large samples and is made for Kontakt 2 - which is pretty much all of them.

    Akoustic Piano does not do this, but I hate the sound of Akoustic Piano, so forget that. Everything else I have is a library (Vintaudio, PMI, Sampletekk, etc).

    I don't think it is their products either. It has happened on SEVERAL of my computers - all fully capable of massive projects - 3ghz processor, 2GB ram and over a terabyte of space and a perfectly robust midi and asio sound system. All of my other synths work great. All of my other sample libraries work fine. However, with most libraries, except for strings, I do not play complex chords. Using EWQLSO Silver or Gold XP in Kontakt 2 DOES NOT show the dreaded note stealing mentioned above. Using KHSO Emerald DOES NOT have this problem either in Kontakt 2 - ONLY THE PIANOS??????????

    Has anyone experienced this? Has anyone fixed it? Or am I doomed? I have Pianoteq and it plays perfectly - zero problems. I used the TruePianos demo and it, too, was perfect.

    I would love to know other people's experience or problems like this - if any?

    Mike

  2. #2

    Re: Piano samples turn off in Kontakt 2

    I have this happen in Kompakt if I change the polyphony setting with Sampletekk Black Grand Close. My solution is to not change the polyphony setting, which kind of stinks, because, what's the point of all of those large samples? I had kind of expected that this would have been fixed by Kontakt 2. (Kompakt is a derivative of Kontakt 1). Maybe I'll have to get GVI instead of Kontakt 2?

  3. #3

    Re: Piano samples turn off in Kontakt 2

    Hey Karma,

    Go into the options tab of Kontakt and increase the memory allocation. This might help.

    John
    Student in Electro-acoustics

  4. #4

    Re: Piano samples turn off in Kontakt 2

    Thank you for the suggestion. It did not work, however. I upped the memory allocation to 250MB and nothing, so then I went all the way - still the problems happened instantly. There was even a option to turn off cpu protection (relaxed, tight, etc). I disabled that and still the problems.

    Thanks anyway. I appreciate the possibility of help.

    Mike

  5. #5

    Re: Piano samples turn off in Kontakt 2

    Karma,
    Hmm. I wonder if this will happen to me too when I get my copy of Kontakt2 in the mail?
    Cheers,
    Chris

  6. #6

    Re: Piano samples turn off in Kontakt 2

    Quote Originally Posted by karmacomposer
    I don't think it is their products either. It has happened on SEVERAL of my computers - all fully capable of massive projects - 3ghz processor, 2GB ram and over a terabyte of space and a perfectly robust midi and asio sound system. All of my other synths work great. All of my other sample libraries work fine. However, with most libraries, except for strings, I do not play complex chords. Using EWQLSO Silver or Gold XP in Kontakt 2 DOES NOT show the dreaded note stealing mentioned above. Using KHSO Emerald DOES NOT have this problem either in Kontakt 2 - ONLY THE PIANOS??????????
    That is odd. I have played Black Grand, TBO, 7CG and Emperor on a PC with similar specs (P4 3.2, 3 GB RAM, 150 GB Raptor), and I have never encountered this kind of behaviour. Even with 2 ms latency I can play two cluster chords (one forearm each) and nothing cuts out (I tried it with Emperor).

  7. #7

    Re: Piano samples turn off in Kontakt 2

    Same here...BG, WG, 7CG, Rain Piano, Emperor, Old Lady...all on a 3.2 Ghz P4. No problem at all in K2.
    Are any or all the samples that DO work on the same Drive as the Pianos? Sounds like it could be a streaming problem.

    matto

  8. #8

    Re: Piano samples turn off in Kontakt 2

    I am still setting up my system and just tested it and had a similar experience to Karmacomposer. I've got a 2 GHz iMac G5 with 2GB ram, a 320 GB Glyph external HD, Presonus Firebox audio interface and Korg Triton extreme keyboard. Not the most powerful, but not bad either.

    Previously, I had noticed that some of the larger sampled pianos, such as the Emperor and even the August Forster in the K2 library, would crackle when playing large chords or fast notes, and after a few measures blur together and become unplayable. This is especially when using settings involving convolution or harmonics, or having the sustain pedial down even a little too long. In this case, the CPU is obviously getting maxed out.

    However, this morning I found that even playing gently and slowly on the Black Grand (and also to a lesser degree on 7CG Jr) would create missing notes in the way Karmacomposer described. This is a different situation than the previous one. It's NOT related to CPU and didn't improve when I changed various settings. DFD is on and all the orchestral instruments sound just fine. Interestingly enough, the Steinway B from EW Gold XP, although admittedly using fewer samples and less ideal for solos, has given me no problems in Kompakt or Kontakt 2.

    This situation is a sad one because there is nothing that inspires my composing like a really beautiful, resonant grand--subtle yet powerful, and one is needed as the heart of my system. That's why I went out on a limb to get these pianos recently. The Emperor has that kind of sound but, unless I'm missing something, I'll need a bigger computer to access its more inspirational settings. But maybe something can be done at least about the missing notes in the Black Grand etc.? Maybe someone here has the answer.

    And I do wonder if the Garritan Steinway will work OK on a system this size. Hoping, hoping, hoping, longing, dreaming....

    Saraswati

  9. #9

    Re: Piano samples turn off in Kontakt 2

    It is not a cpu problem, nor an asio problem. The piano samples are on separate high speed usb 2.0 drives, as all ALL my other samplesets. They are defragged and in good working order.

    I use KHSO Emerald, EWQLSO Gold, Stylus RMX, EWQL Stormdrum, Drumcore, EWQLS Choirs and tons of other vsti's and sample sets with zero problems.

    It's just these darn pianos!!! And all used through Kontakt 2. My Kontakt 2 version is 2.1.1.001 (through Komplete 4) It should be noted that this happens BOTH with stand alone and dxi/vsti versions. I REFUSE to update it since every time I do, it no longer works. I tried other libraries that are NOT pianos with Kontakt 2 and no note stealing on long chord passages.

    I have two theories. These happen with sustain pedals - so perhaps my sustain pedal is to blame. Or, maybe it's my CME UF8 - together with it's included sustain pedal. I don't use that for any other samples (no need to sustain strings and what not - that I can do in envelope and other editing).

    Obviously, when I do NOT use the sustain pedal (damper), the notes are too short to turn off.

    Perhaps the work-around is use a nice transparent reverb with a large tail to SIMULATE a damper pedal. That sucks, though, for expressitivity.

    This does not cause me a problem in Pianoteq or Truepianos.

    I just tried this in wusik with two pianos I had converted from other sources - and it happened there too. It must be the damper pedal or CME UF8!!!

    Mike

  10. #10

    Re: Piano samples turn off in Kontakt 2

    Karma, are you streaming from disk (DFD on in the options)? I had some problems like this, and it was because DFD was getting choked. I unchecked it, now the samples load into RAM and it is fine.

Go Back to forum

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •