• Register
  • Help
Results 1 to 4 of 4

Topic: Setting GPO Pedal behavior in Kontakt2 Player

  1. #1

    Setting GPO Pedal behavior in Kontakt2 Player

    After a long ordeal, I was finally able to install and authorize the Kontakt2 player upgrade for GPO. One problem: how do I set the pedal behavior for GPO instruments when using them in the Kontakt2 Player. I want the pedal to behave as a normal, sustain pedal would on a piano. It was a trivial matter to make this setting in the old GPO player, but I can't seem to find a setting that will let me do this. (I have the full version of Kontakt 2, if that helps.)

  2. #2

    Re: Setting GPO Pedal behavior in Kontakt2 Player

    Quote Originally Posted by ejr
    It was a trivial matter to make this setting in the old GPO player
    Same in KP2: Click the instrument's Edit (<wheels>) button (above "GPO") | Controller tab | MIDI Controller #64 ...

  3. #3

    Re: Setting GPO Pedal behavior in Kontakt2 Player

    Thanks. I was looking for a global setting.

    Anyway, I found a much more serious problem with the Kontakt 2 player: the volume levels are all screwed up. I left all the controls at their defaults, as I always do with Kontakt 2, JABB, and Akoustic Piano (and I always did with the old GPO player). I control the volume through the note velocities and CC values that I enter in the MIDI list view (in Sonar).

    This has always worked well, allowing me to tightly control dynamics, etc. But as soon as I tried using the Kontakt 2 player for GPO all the volume levels went haywire. The libraries don't appear to recognize cc1 events (regardless of how the pedal option discussed earlier is set). I can boost the volume if I add a cc 7 event ... but at the max (127) bass trombone 2 is so soft that is is covered by the flutes or violins when they are playing. Substituting it with bass trombone 1 was so loud that it distorted, even with the cc 7 at 20 or 30. When I finally got all the instruments at an acceptible level, one or two parts suddenly reverted to much softer or lower volumes (regardless of the controller settings, and even after I removed them all). Every time I'd fix the offending tracks, the same problem would crop up with other ones, and eventually the earlier ones again. I spent the better part of the afternoon trying to find some sort of logic to it, but there doesn't appear to be any. These are not drop outs. Every note still plays, but the volume goes all over the map, with no visible control setting the levels for it. (No automation enabled, etc.)

    I went back to the older GPO interface, reset my old levels, and everything was fine. I have another library that also uses the Kontakt 2 player -- and it appears to be working fine, as well. This is strictly a GPO problem -- and it is only a problem when using the Kontakt 2 player.

  4. #4
    Join Date
    Jun 2000
    Chandler, Arizona

    Re: Setting GPO Pedal behavior in Kontakt2 Player

    The correct pedal settings should be set for each instrument in the Kontakt 2 player. The Kontakt 2 player is capable of having different sustain pedal settings for each instrument unlike Kontakt 1.53 player which only had one global setting.

    Please note that the GPO Kontakt player is not an official release and has some other issues besides the ones you mentioned. The good news is that I've tested the latest version and the flex envelope bug has been fixed.

    I have not noticed any difference in the general volume settings and CC1 is working fine on my system. Only difference is that the instruments now have a higher default CC1 setting. Which instrument are trying to use CC1 on? Remember that percussive instruments such as piano, percussion, pizzicato strings don't use CC1 and volume is controlled by velocity.


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts