• Register
  • Help
Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Topic: Issues,bugs and questions about KP2 - Tom help me!

  1. #1

    Issues,bugs and questions about KP2 - Tom help me!

    Hi all,

    As much as I like some of the new features of KP2, I found last night a ton of issues/questions after playing aound with it a bit. some of these things are what seem to me errors while others are features that have been lost from the old player that made setting up a GPO instance so much easier. If Tom or Gary could help answer these I'd (and I imagine others too) be so greatful, cos at the moment Im wishing I'd never updated! here goes:

    1. No global setting for sustain! Now if you want sustain to work on each instrument you have to go into the gears menu for EACH one and change the setting! So if your setting up a large orchestra (say 20+ instruments) its a real pain in the arse. the only instrument that I found that works from the off is the vibraphone. Is there any fix for this?

    2. What happened to multiple outputs? the 1/2, 3/4, 5/6, etc etc system was invaluable and so very easy to use! now for some reason i get 1/2, 1/2 (again) and then "5.1 surrond! If i add more channels, cubase doesnt recognise them AND it tells me to restart the pluggin, which doesnt help. it just removes everything i set up!...help?

    3. The Assign midi controller port to opening instruments function doesnt work. I want it set to omni when i open an instance, it only does so if i reload the instrument in the same KP2 session... Gone are the good days when (in standalone mode) you could just select the midi channel and then quickly change your midi controller to ouptut on that channel.... it was simpler back then...

    4. On the flute theres a slight glitch in the sound half a second in to a sustained note, as if its switching to a sustain loop or something. I also noticed it in Violins 1 Muted. dont know what other instruments might have same problem. (It wasnt my cpu being overloaded, i had no other instruments loaded up)

    5. The GPO multi 09 (tpt, tbn, tba section) opens up in a GREY skin and not as GPO instruments (i.e. not in the lovely yellowy-orange skin).

    6 - Old projects seem to fail to load half the time. they just crash my otherwise v stable pc.

    7. Is it beter to use the inbuilt reverb in the KP2 or a separate one (say garritan ambience)? which is more demanding on the processor and which is better quality?

    8. How come a KP2 instance allows up loading of up to 64 instruments, but if you using it with a DAW (im using cubaseSX) you can only control 16 instruments individually? you can choose midi channels from port A (from host) 1-16 in KP2 but then port B to D are all unusuable, so its overcomplicating things with more selecting and clicking! (sounds like im moaning here, but as a sufferer of RSI it makes a difference...) I realise tho that I can load a new instance of KP2 (so I have KP2 and KP2(2) ) but i get the feeling that that will really drain my CPU.....

    Lastly does anyone get the impression that it is generally more cpu intensive? I used to be able to load 2 standalone instances, whack 16 instruments in, play a 5-6 note chord and get no cutting out or glitching of any kind. Even with all instruments playing at once. Now im lucky if i can play a 6 note chord with a complete brass section (loaded from multi).

    If tom or gary or anyone else who knows the answers to my whines (other than "shut ben and get used to it!) Id be so thankful cos at the mo im wishing Id never updated. But the old player wont work anymore!!!!!

    Thankyou for reading!!!!!


  2. #2

    Re: Issues,bugs and questions about KP2 - Tom help me!


    There is one bug which crashes the KP2. It also happened with the unofficial release. I was hoping it would be fixed in the latest update. I am a programmer and i know how time consuming it is to make a program bug free. But crashing bugs come at the top of my priority list. Over all i'm happy with the KP2. All software has bugs. But if the issues that you mention where resolved I would be very happy.


  3. #3

    Re: Issues,bugs and questions about KP2 - Tom help me!

    I understand ye, Id be delighted if they fixed it!

    Oh, and I found some more today while making a short piece to try it out! (tho these may be me specific...) The piece used about 29 instruments, which used to be fine for me, so it was loaded into two instances of KP2.

    10. when exporting an audio mixdown (cubase SX) all the instruments in the first KP2 instance cut out after 3-5 seconds. exact time varies.

    11. Then nothing will play again. The midi data is still being sent through, nothing is muted but it just refuses to make a noise. (and i never purged anything). reloading samples doesnt help either.

    12. Closing and instance of KP2 causes a crash, so you have to restart cubaseSX.

    These last 3 problems mean that at present if you/I even attempt to do a mixdown and want to change something, you have to restart the who'll project. which with 30 odd instruments can takes AGES!!!

    13. The cymbal roll sometimes cuts out. It was doing it on crescendos. Dont know about decresc.

    Really hope someone reads this and releases an update .... soon...If your experience the same issues, please say, so that something gets done and done quickly!


  4. #4

    Re: Issues,bugs and questions about KP2 - Tom help me!

    ben, i don't really have any advice, but i know how you feel. before the newest update from a couple days ago, i was unable to use my gofriller cello. it was randomly shut down my kontakt player, and i couldn't even load more than one - it was immediately shut down during the load process. i called gary and ni, they were both nice and offered suggestions, but nothing seemed to work. i even sent NI my crash reports and they sent them out to the germany office to look at. i thought they forgot about me, but the new update completely solved it for me (they very easily could have forgot about me, and it was just dumb luck that the update fixed it).

    my point is this: what was happening to me was ONLY happening on my computer. no one else seemed to have this problem. i uninstalled and reinstalled everything a couple times, but it did nothing... SO - with all that said. i would first call gary (you can get the number on your owners manual). you'll probably get straight through to him with no wait time at all. he'll give you a few pointers, and if it doesn't work you're going to have to call NI. the thing with NI is that you will be on hold for at least 30 minutes (the first time i called them i was on hold for OVER AN HOUR, then they hung up on me), but the guys over there are very knowledgeable.

    other than that - hang in there. i know how it feels.
    -Keith Fuller

    iMac Quad i7 * MacBook Pro * Logic Studio 9 * WD 320GB & 1TB Externals@7,200RPM * Presonus Firebox * M-Audio Axiom 25 & Keystation 61 * Rode NT1-A * Epiphone Hollowbody * Fender Amp * KRK Rokit 8's

  5. #5

    Re: Issues,bugs and questions about KP2 - Tom help me!

    wow, Ben---I could So feel your pain while reading your post.

    It seems that some people are happily working away on music with the new KP2, but on the main thread about the update, there are so many complicated, contradictory, difficult-to-decipher instructions, warnings, bad experiences etc--Now you've described your awful experience. Ack!

    The fact that percussion velocities are still messed up has been confirmed--it's supposed to be fixed soon.

    But after reading posts like yours, I have the feeling things just aren't as ready as they could be, and that more bugs and problems could be officially acknowledged as time goes on.

    I Must have the old player remain on my computer, so my old projects still function the same--with both GPO and JABB. I'm totally spooked that something extremely difficult to unravel is going to happen if I try the upgrade.

    It seems the only way to have both old and new Kontact set ups is via a lot of cutting, pasting, re-naming of files--? This has been described in several different ways. Just now I tried to follow Tom's patient explanation on the main thread for this--maybe I'm dense, but I couldn't follow what he was saying.

    SO, I'll still wait it out, for at least a week, probably more. I get the creeping feeling there are more freak-outs to be posted.

    I don't mean for my worries to reflect on the company--I'm just having to say that looking at all this explosion of posts leaves me not wanting to touch the update yet, not with a ten foot keyboard!

    Randy B.

  6. #6

    Re: Issues,bugs and questions about KP2 - Tom help me!

    Hey Rbowser

    I read a few days ago that you were gonna hold out and wait for confirmation that it was all ok. I was gonna do the same, then thought "nah, i'll go for it." How i wish i hadnt!!!!

    so the percussion velocity is an known issue is it? and the crashing? I think it would be sensible for a sticky to be set up listing all known problems with the player (not including installation and registration issues), we cant set up stickies tho, so go Gary go!

    I think i will be getting the old player working again. if i can.


  7. #7

    Re: Issues,bugs and questions about KP2 - Tom help me!

    Hello again, Ben

    If you look through the long thread Tom started, the official KP2 announcement thread, you may be able to untangle what to do to have the old player working again.

    I've tried to follow the advice there--with all the cutting and pasting, re-naming of files, moving folders etc--but I'm afraid that even Tom's post where he tries to step through this that there are some things that don't quite make sense. As I said on another post, maybe I'm dense, but there seemed to be lapses in logic there.

    BUT you gotta look through there anyway to see if you can figure out to get back what you had. Or maybe you need to do a system restore on your computer.

    It's probably too early to have an official sticky explaining everything we need to know--because the reports are still coming in. But hopefully at some point there will a simple, to-the-point sticky stepping users through the whole upgrade.

    Randy B.

  8. #8

    Arrow Re: Issues,bugs and questions about KP2 - Tom help me!

    As a fellow Cubase user I can verify the output problem between K2 and Cubase. (I am still on SX 3 because Cubase 4 is still, in my opinion, a mess.) I installed the beta version of the K2 player for GPO and when I started researching the output issue, that is certainly a NI bug, I have found everyone to have the same problem. There is a workaround posted on the NI Kontakt forum, however it did not work for myself or many others. NI is silent on the bug.

    Concerning your other issues, I don't have any pieces with as many instruments as you do, so take what my experience with a grain of salt. I've not had any crashing or loading issues whatsoever. However, I have had an issue that samples will become `corrupted' after a time in that they begin sounding like static or white noise has been added to some samples. (Usually the violins.) I have to restart SX to resolve the problem.

    Have you tried turning on the `old VST' switch for K2 to see if the crashing problems go away? I'm not using the right term, but you probably know what I mean. Its a column in the VST list in SX.

    I have not installed the official update yet, but I will tonight and if anything changes I will let you know.

    Best of luck with your challenges!

    We are the music makers, we are the dreamers of dreams …
    24" 2.4 Ghz iMac, OSX 10.4.10, MOTU 828 MKII, 2 Glyph 250 Gig external drives, Logic 9, Finale 2008 GPO, JABB, Strad, Gro, Reason 4, EWQL Storm Drum, Adrenaline, Symphonic Choirs, SO Gold,All Arturia Synths, Many NI Synths, Spectrasonics Synths, KH Strings, VEPro on a Windows 7 4x 2.8 Ghz 12 gig of RAM

  9. #9

    Re: Issues,bugs and questions about KP2 - Tom help me!

    Guess we'll take these one at a time!

    Quote Originally Posted by BenNichols
    1. No global setting for sustain! Now if you want sustain to work on each instrument you have to go into the gears menu for EACH one and change the setting! So if your setting up a large orchestra (say 20+ instruments) its a real pain in the arse. the only instrument that I found that works from the off is the vibraphone. Is there any fix for this?
    Hrm, but this seems to indicate that you're not using the legato feature in GPO and JABB! Why not?

    Anyway, possible fixes:

    1) Do it yourself! K2P allows you to save your own instrument files, so after using the 'gear menu', save it so you don't have to do it again.

    2) Use the Notation version of the instrument: those use cc64 for sustain and cc68 for legato.

    3) Use an external 'fake sustain pedal', like my TenCrazy.com MFX SustainFix (free!)

    Hopefully one of those will do the job. Unfortunately, NI no longer supports the global setting in their Player.

    - m
    Free MFX and other plugins: http://www.TenCrazy.com/
    Markleford's music: http://www.markleford.com/music/

  10. #10
    Senior Member rayzalaf's Avatar
    Join Date
    Jan 2007

    Re: Issues,bugs and questions about KP2 - Tom help me!


    I use Cubase 4, which I'm very happy with generally but there are issues with the size of it before added vst instruments etc. I use 2gig of ram I can load max 8 GPO or JABB instruments. My computer will just switch off if I try to do more. I'm well used to such problems over the years. The bottom line is convert individual tracks to audio asap when working.


Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts