• Register
  • Help
Results 1 to 9 of 9

Topic: macintel KP2 woes

  1. #1

    macintel KP2 woes

    hey everyone,
    I posted this in another thread/forum, but realized that this forum is probably the best place to post. I'm running a mac mini with a core 2 duo, 1.66 GHz w/2G RAM. OSX 10.4.9

    yesterday I downloaded the new patch and installer (GPO KP2.2.2.2 Installer) and ran it. it installed the kontakt2 player and everything appeared to work fine, only problem was the kontakt2 player couldn't find the samples. I could still load the instruments using the "search in spotlight" function, but this is annoying and because of this I thought it might be best to reinstall. I trashed the Kontakt Player 2 folder and installed again.

    after reinstalling, Kontakt Player 2 stopped working and I haven't been able to get it working again. the symptoms are as follows:

    1) double clicking on KontaktPlayer2, it brings up the startup screen and says "Initializing User Interface".

    2) the startup screen disappears, and the Kontakt player window never appears. here's the weird part: if I use expose to look at all my open windows, the window appears in expose. but if I click on it, it just disappears as soon as expose goes away.

    3) I cannot quit KontaktPlayer2 via the menu at the top, or open the preferences or anything else. it appears to just be hung, and I have to force quit to exit the application. attempting to open the preferences causes all the other menu items to gray out.

    I tried deleting the GPO Library directory and installing everything again from scratch. GPO seemed to install fine, although Kontakt Player 2 gave me the same bug. I noticed the GPO_Library_Part[1-3].nks files weren't in the "GPO Library" directory, so I copied them there manually. is it normal for these files not to be copied over during installation? everything I have read indicates they should be in the "GPO Library" directory.

    I tried running the "PersonalOrchestra" executable in the "Garritan Personal Orchestra" directory, it loads the original kontakt player but obviously won't load any of the new samples.

    at this point, GPO is not working at all, so any advice, including how to uninstall everything and start from scratch, is much appreciated. I get the feeling that trashing the "GPO Library","Garritan Personal Orchestra", and "Kontakt Player 2" directories is not enough. do I have to use some sort of uninstaller?

    thanks in advance,

  2. #2

    Re: macintel KP2 woes


    Check out my response in the other thread: I answered there before I saw your new post here.

    - m
    Free MFX and other plugins: http://www.TenCrazy.com/
    Markleford's music: http://www.markleford.com/music/

  3. #3

    Re: macintel KP2 woes

    In the Windows version, the default install uses the same folder as KP1 to install the KP2 library. But. I believe the Mac version prompts you, so I assume you installed KP2 in a different folder than KP1? If so, then the .nks files are not copied over from the KP1 library folder. You need to do this manually. NI has been quite uncooperative with this issue.

    At this point, I’m not sure what you have installed. You need to figure out what is the KP1 library folder and what is the KP2 library folder. For both of them to work, they both need a copy of the .nks files. If you only need KP2, just move the .nks files there.

  4. #4

    Re: macintel KP2 woes

    I currently have the KP2 installed, the KP1 files were moved into a backup directory in my "GPO Library". I moved the .nks files into the "GPO Library" directory.

    since I posted this I tried opening GPO as a vst plugin inside of ableton live, and that appears to work fine . so really my problem just seems to be with the standalone player. I haven't tried to get the new KP2 working with sibelius yet, so I'm not sure if that's even possible.

  5. #5

    Re: macintel KP2 woes

    I just got JABB in the mail, and it works fine in ableton live as well. however, the standalone player still does the same thing as before, only now when I use expose I can see that both GPO and JABB are loaded.

    still, the Kontakt Player 2 hangs as before. does anyone know the best way to uninstall Kontakt Player 2 completely, and just try reinstalling? I get the feeling trashing the directory isn't going to cut it.

    also, I can't load any of the multis in ableton live, is this standard?

    this is really frustrating for me, mainly because it was working, and reinstalling caused it to break. so I know that it can work on my system, but I'm really at a loss as to why it's not currently working.

    thanks in advance,


  6. #6

    Re: macintel KP2 woes

    I just selected "custom install" and only selected "Kontakt Player 2 Standalone Basic Installation" and got the same problem, only this time I could open "Audio Configuration". trying to open Kontakt Player 2 preferences (command , ) still hangs the software.

    this really seems like a bug in Kontakt Player 2 to me, however it seems I'm the only one having this issue so far.

  7. #7

    Re: macintel KP2 woes

    Have you tried trashing all the pref files then reinstalling? KP2 puts pre files in your Home/Library/Prefereces as well as in the system Library/Preferences.

    If that doesn't work, you probably need to contact NI tech support.

  8. #8

    Re: macintel KP2 woes

    Quote Originally Posted by Craig F
    Have you tried trashing all the pref files then reinstalling? KP2 puts pre files in your Home/Library/Prefereces as well as in the system Library/Preferences.
    this appears to be it!!! it's not seeing my midi controller, but at least the program is coming up! many, many thanks craig!

  9. #9

    Re: macintel KP2 woes

    Glad it worked.

Go Back to forum


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts